summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2017-05-14 23:56:23 +0200
committerPatrice Clement <monsieurp@gentoo.org>2017-05-15 00:03:48 +0200
commit6de7dc149e5b3614130530cc7e7ec10b964fa7c8 (patch)
tree886a7ce090ba02711831289f2c7db53f92d09558 /app-admin
parentdev-python/Babel: backport fix for buggy test (diff)
downloadgentoo-6de7dc149e5b3614130530cc7e7ec10b964fa7c8.tar.gz
gentoo-6de7dc149e5b3614130530cc7e7ec10b964fa7c8.tar.bz2
gentoo-6de7dc149e5b3614130530cc7e7ec10b964fa7c8.zip
app-admin/filewatcher: EAPI 6 bump.
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/filewatcher/filewatcher-2.4.6-r1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/app-admin/filewatcher/filewatcher-2.4.6-r1.ebuild b/app-admin/filewatcher/filewatcher-2.4.6-r1.ebuild
new file mode 100644
index 000000000000..db9d3becf660
--- /dev/null
+++ b/app-admin/filewatcher/filewatcher-2.4.6-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="File control configuration system and IDS"
+HOMEPAGE="https://sourceforge.net/projects/filewatcher/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+RDEPEND="
+ dev-perl/MailTools
+ dev-vcs/rcs
+ virtual/mta"
+
+DOCS=( Changes README )
+
+src_install() {
+ keepdir /var/lib/filewatcher /var/lib/filewatcher/archive
+ dosbin filewatcher
+ doman filewatcher.1
+ insinto /etc
+ doins "${FILESDIR}"/filewatcher.conf
+ einstalldocs
+}
+
+pkg_postinst() {
+ elog " A basic configuration has been provided in"
+ elog " /etc/filewatcher.conf. It is strongly"
+ elog " recommended that you invoke filewatcher via"
+ elog " crontab."
+ elog
+ elog " 55,25,40 * * * * root /usr/sbin/filewatcher"
+ elog " --config=/etc/filewatcher.conf"
+}