summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2024-04-29 14:37:46 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2024-04-29 14:38:29 -0500
commit91fb49f46150f7fb076fb8317900fe81ba4ab5a6 (patch)
tree2186bb00aafdbf19a05381d23d2e5dbcb614a94d /app-admin
parentapp-admin/puppet: drop 7.24.0-r1 (diff)
downloadgentoo-91fb49f46150f7fb076fb8317900fe81ba4ab5a6.tar.gz
gentoo-91fb49f46150f7fb076fb8317900fe81ba4ab5a6.tar.bz2
gentoo-91fb49f46150f7fb076fb8317900fe81ba4ab5a6.zip
app-admin/puppet: drop 7.27.0-r1
Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/puppet/Manifest1
-rw-r--r--app-admin/puppet/puppet-7.27.0-r1.ebuild128
2 files changed, 0 insertions, 129 deletions
diff --git a/app-admin/puppet/Manifest b/app-admin/puppet/Manifest
index bfd7024ba84f..c8a2bdc1a3f3 100644
--- a/app-admin/puppet/Manifest
+++ b/app-admin/puppet/Manifest
@@ -1,4 +1,3 @@
-DIST puppet-7.27.0.tar.gz 2825666 BLAKE2B dffc2329c28588a5b4a08996f5fbff95c092961aa68af6287c4216ffb3e5b6ab811df876b8efb0f6724d9990b21ad1c56d65bd9fd8d502008ba385f4460f0591 SHA512 a864357f5079c9fad53c2cff35f73f0bc25900359e25b5fb1130e3a3e6f77f63bc38ef59c0ce1b37913eb0acb1e42f39891ed7de0fe39ab138faa426ab2a9392
DIST puppet-7.28.0.tar.gz 2827538 BLAKE2B 65f25d9de60ed1b511acb5c9d72370198f68f3158cfede2ffda90ee23ebcfecfdabcf35459d1a048c3a204e13611f67852028233e4da4b9ed2ea08cad07a37c9 SHA512 d570452ceec764c657f4678f7179400d30f8513766edc6f020db35c3a4246c1d857615a647ca481920a7d1a40cf9a15057432468ccd4697e4335dca55e121faa
DIST puppet-8.5.1.tar.gz 1565085 BLAKE2B f352f9f70e090c4a32edd45ced5c01ed4eff891fb46c0f2d753ceeba43250960356ceb2d9047e7308732585ec114c5f728ec29a65b6a08348b74a9709ec92a89 SHA512 f1d661c34fc7c1381c6422ff7e027fdf4554a69939f5db926bf8a61a89583090fb8d28151f90093d3ca8037950ed911b0a5c7b8677a80ede72e83d9cbf89af7f
DIST puppet-8.6.0.tar.gz 1567398 BLAKE2B 749cc055c6797e5715907fdb768264774efba62e4681733a59a457cfda9dd2682990a96331cc04d313a367e32b820ce351fb103e19891976e900d99c30ca7ba5 SHA512 b08d59b4ec79fec5f3dd2d37c9b6a9f016cf25068e507866ab8d545f59792b9af84e302675182a0318c792814f0bff2bf052c8953b6b44c5441fa2c692a9f04d
diff --git a/app-admin/puppet/puppet-7.27.0-r1.ebuild b/app-admin/puppet/puppet-7.27.0-r1.ebuild
deleted file mode 100644
index b23327410b34..000000000000
--- a/app-admin/puppet/puppet-7.27.0-r1.ebuild
+++ /dev/null
@@ -1,128 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="7"
-
-USE_RUBY="ruby27 ruby30 ruby31"
-RUBY_FAKEGEM_RECIPE_TEST="rspec3"
-RUBY_FAKEGEM_TASK_DOC="doc:all"
-RUBY_FAKEGEM_EXTRAINSTALL="locales"
-
-inherit ruby-fakegem systemd tmpfiles
-
-DESCRIPTION="A system automation and configuration management software"
-HOMEPAGE="https://puppet.com/"
-SRC_URI="http://downloads.puppetlabs.com/puppet/${P}.tar.gz"
-
-LICENSE="Apache-2.0 GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~x86"
-IUSE="augeas diff doc emacs ldap rrdtool selinux shadow sqlite vim-syntax"
-RESTRICT="test"
-
-ruby_add_rdepend "
- dev-ruby/hiera
- dev-ruby/json:=
- dev-ruby/semantic_puppet
- >=dev-ruby/facter-3.0.0
- dev-ruby/concurrent-ruby
- augeas? ( dev-ruby/ruby-augeas )
- diff? ( dev-ruby/diff-lcs )
- doc? ( dev-ruby/rdoc )
- ldap? ( dev-ruby/ruby-ldap )
- shadow? ( dev-ruby/ruby-shadow )
- sqlite? ( dev-ruby/sqlite3 )
- virtual/ruby-ssl
- dev-ruby/hocon"
-
-ruby_add_bdepend "
- doc? ( dev-ruby/yard )
- test? (
- dev-ruby/mocha
- dev-ruby/rack
- dev-ruby/rspec-its
- )"
-# this should go in the above lists, but isn't because of test deps not being keyworded
-# dev-ruby/rspec-collection_matchers
-
-RDEPEND+=" ${RDEPEND}
- rrdtool? ( >=net-analyzer/rrdtool-1.2.23[ruby] )
- selinux? (
- sys-libs/libselinux[ruby]
- sec-policy/selinux-puppet
- )
- vim-syntax? ( >=app-vim/puppet-syntax-3.0.1 )
- >=app-portage/eix-0.18.0
- acct-user/puppet
- acct-group/puppet"
-PDEPEND="emacs? ( >=app-emacs/puppet-mode-0.3-r1 )"
-
-all_ruby_prepare() {
- # Avoid spec that require unpackaged json-schema.
- rm spec/lib/matchers/json.rb $( grep -Rl matchers/json spec) || die
-
- # fix systemd path
- eapply -p0 "${FILESDIR}/puppet-systemd.patch"
-
- # Avoid specs that can only run in the puppet.git repository. This
- # should be narrowed down to the specific specs.
- rm spec/integration/parser/compiler_spec.rb || die
-
- # Avoid failing spec that need further investigation.
- rm spec/unit/module_tool/metadata_spec.rb || die
-}
-
-each_ruby_install() {
- each_fakegem_install
-# dosym "/usr/$(get_libdir)/ruby/gems/$(ruby_get_version)/gems/${P}" \
-# "/usr/$(get_libdir)/ruby/gems/$(ruby_get_version)/gems/${PN}"
-}
-
-all_ruby_install() {
- all_fakegem_install
-
- # systemd stuffs
- systemd_dounit "${WORKDIR}/all/${P}/ext/systemd/puppet.service"
-
- # tmpfiles stuff
- newtmpfiles "${FILESDIR}/tmpfiles.d-2" "puppet.conf"
-
- # openrc init stuff
- newinitd "${FILESDIR}"/puppet.init puppet
-
- keepdir /etc/puppetlabs/puppet/ssl
-
- keepdir /var/lib/puppet/facts
- keepdir /var/lib/puppet/files
- fowners -R puppet:puppet /var/lib/puppet
-
- fperms 0750 /var/lib/puppet
-
- fperms 0750 /etc/puppetlabs
- fperms 0750 /etc/puppetlabs/puppet
- fperms 0750 /etc/puppetlabs/puppet/ssl
- fowners -R :puppet /etc/puppetlabs
- fowners -R :puppet /var/lib/puppet
-
- # ext and examples files
- for f in $(find ext examples -type f) ; do
- docinto "$(dirname ${f})"
- dodoc "${f}"
- done
-}
-
-pkg_postinst() {
- tmpfiles_process puppet.conf
-
- elog
- elog "Please, *don't* include the --ask option in EMERGE_EXTRA_OPTS as this could"
- elog "cause puppet to hang while installing packages."
- elog
- elog "Portage Puppet module with Gentoo-specific resources:"
- elog "http://forge.puppetlabs.com/gentoo/portage"
- elog
- elog "If updating from puppet 5 to 6, keep in mind that webrick (server/master)"
- elog "suppert was removed for >=6.x, please migrate to puppetserver if you have"
- elog "not already done so."
- elog
-}