summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-09-30 09:11:15 +0200
committerMichał Górny <mgorny@gentoo.org>2017-09-30 09:27:26 +0200
commit95269f1ece2007d4850ad2b8b04c3f27a9669313 (patch)
treeb271c0f04d73598b2162db9103a0c674e3d29664 /app-admin
parentxfce-extra/xfce4-pulseaudio-plugin: Bump to 0.3.1 (diff)
downloadgentoo-95269f1ece2007d4850ad2b8b04c3f27a9669313.tar.gz
gentoo-95269f1ece2007d4850ad2b8b04c3f27a9669313.tar.bz2
gentoo-95269f1ece2007d4850ad2b8b04c3f27a9669313.zip
app-admin/systemrescuecd-x86: Bump to 5.1.1
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/systemrescuecd-x86/Manifest1
-rw-r--r--app-admin/systemrescuecd-x86/systemrescuecd-x86-5.1.1.ebuild61
2 files changed, 62 insertions, 0 deletions
diff --git a/app-admin/systemrescuecd-x86/Manifest b/app-admin/systemrescuecd-x86/Manifest
index 43534812e296..365a340dee5f 100644
--- a/app-admin/systemrescuecd-x86/Manifest
+++ b/app-admin/systemrescuecd-x86/Manifest
@@ -27,3 +27,4 @@ DIST systemrescuecd-x86-5.0.2.iso 495773696 SHA256 a2abdaf5750b09886cedcc5233d91
DIST systemrescuecd-x86-5.0.3.iso 501446656 SHA256 e892d3e0aeabec2c435484f0a6913d56b5cc4505e61032bd86f39443e3ab162e SHA512 a6748224f3f8cac5f9751648278bbc06acfc123c64b7c0a3b6e47f00b0a3c255082e9ffc43fd0fd3df26322cf154797ea6a02c6b37087ae832219ec4f3bec673 WHIRLPOOL 3f197342689fa764bf66b269f3afd1213774cba16b04b3bcb45d408f2e650e503499303120bb233f3b15c4e254953f703c2b042ae1cfcbe0f1119330562952c0
DIST systemrescuecd-x86-5.0.4.iso 501141504 SHA256 3b38c15ec8e2f60348181423b0f445856c8b290aac96e92210f316652d621507 SHA512 26b624c75f75e181051b164b0a1f24b612d9ac11c2ed8df3e40fd13e48bfa58022be814e4ac608f3fde892eaa99954f10c0e1fb1ef4831a501dc4e1c0c87b764 WHIRLPOOL 8a372a13edf76d31d44dfe1167216d2b89b3b75ac7437397341bb7e721b31336cbcedda05f087a0d061ca25b5cb95acd252fa042ce6639852c8795568a4ca128
DIST systemrescuecd-x86-5.1.0.iso 505047040 SHA256 49466daab472d29fbbd38ac7d4d36363ecd73e27f7872dde1d67e62e190920d0 SHA512 15d019bbb91019f1b6d1847fc786e6c02f3f768826241e0823842bca9745ff1fa48fe7d32828f899b90845b2f4ce948a1f98e093edf8ca4c0c39cc0da72b4aa8 WHIRLPOOL 5bc909b4c2eea8ffb58f574b120ba07f53361cb4ff2782f214947f5dbccb0f33bc4168ea8a832ba65ebb56a6ea9fb08437af060ec793c6f07c33236bef0f825f
+DIST systemrescuecd-x86-5.1.1.iso 517359616 SHA256 5ab22119f2ca2e53d28880367e53b887df5cd82599b38d3175870d023455117a SHA512 a4063305da50ea8b73fb7157f46bf386b80d3ef777adabdcdd944814c801d078fe63778f166b80788b0851549b35bf6ada5940ca5a40a6c1a3e0f4c66efbea91 WHIRLPOOL e49d64915f487c31efc3ecd590965b4fe94b1a65b7c0261f1ccb4d2b0dc4336885398f2d021a670ec0041a3e3ba1d6c1cc524b1db95d1d7e3c6371f3806ca78d
diff --git a/app-admin/systemrescuecd-x86/systemrescuecd-x86-5.1.1.ebuild b/app-admin/systemrescuecd-x86/systemrescuecd-x86-5.1.1.ebuild
new file mode 100644
index 000000000000..a15aecbe41c4
--- /dev/null
+++ b/app-admin/systemrescuecd-x86/systemrescuecd-x86-5.1.1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="The .iso image of SystemRescueCD rescue disk, x86 (+ amd64) variant"
+HOMEPAGE="http://www.sysresccd.org/"
+# Large ISO mirroring explicitly approved by infra in bug #588766
+SRC_URI="mirror://sourceforge/systemrescuecd/sysresccd-${PN#*-}/${PV}/${P}.iso"
+
+LICENSE="GPL-2"
+SLOT="${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="+isohybrid"
+
+DEPEND="isohybrid? ( >=sys-boot/syslinux-4 )"
+
+S=${WORKDIR}
+
+src_install() {
+ insinto "/usr/share/${PN%-*}"
+ doins "${DISTDIR}/${P}.iso"
+
+ if use isohybrid; then
+ set -- isohybrid -u "${ED}usr/share/${PN%-*}/${P}.iso"
+ echo "${@}"
+ "${@}" || die "${*} failed"
+ fi
+}
+
+pkg_postinst() {
+ local f=${EROOT%/}/usr/share/${PN%-*}/${PN}-newest.iso
+
+ # no version newer than ours? we're the newest!
+ if ! has_version ">${CATEGORY}/${PF}"; then
+ ln -f -s -v "${P}.iso" "${f}" || die
+ fi
+}
+
+pkg_postrm() {
+ local f=${EROOT%/}/usr/share/${PN%-*}/${PN}-newest.iso
+
+ # if there is no version newer than ours installed
+ if ! has_version ">${CATEGORY}/${PF}"; then
+ # and we are truly and completely uninstalled...
+ if [[ ! ${REPLACED_BY_VERSION} ]]; then
+ # then find an older version to set the symlink to
+ local newest_version=$(best_version "<${CATEGORY}/${PF}")
+
+ if [[ ${newest_version} ]]; then
+ # update the symlink
+ ln -f -s -v "${newest_version%-r*}.iso" "${f}" || die
+ else
+ # last version removed? clean up the symlink
+ rm -v "${f}" || die
+ # and the parent directory
+ rmdir "${f%/*}" || die
+ fi
+ fi
+ fi
+}