summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2019-11-28 20:37:24 +0100
committerUlrich Müller <ulm@gentoo.org>2019-11-28 20:39:30 +0100
commit95a6a9d60dcddb0a3a8335c5fd8f8924a8ece766 (patch)
treeacbd4a913402e09a0eea735144c7cf40ce303be7 /app-admin
parentmedia-sound/musescore-{3.3,9999}: fixes (diff)
downloadgentoo-95a6a9d60dcddb0a3a8335c5fd8f8924a8ece766.tar.gz
gentoo-95a6a9d60dcddb0a3a8335c5fd8f8924a8ece766.tar.bz2
gentoo-95a6a9d60dcddb0a3a8335c5fd8f8924a8ece766.zip
app-admin/eselect: Version bump to 1.4.16.
Closes: https://bugs.gentoo.org/701382 Package-Manager: Portage-2.3.80, Repoman-2.3.19 Signed-off-by: Ulrich Müller <ulm@gentoo.org>
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/eselect/Manifest1
-rw-r--r--app-admin/eselect/eselect-1.4.16.ebuild61
2 files changed, 62 insertions, 0 deletions
diff --git a/app-admin/eselect/Manifest b/app-admin/eselect/Manifest
index ec976ec27b46..846a8f244536 100644
--- a/app-admin/eselect/Manifest
+++ b/app-admin/eselect/Manifest
@@ -1,3 +1,4 @@
DIST eselect-1.4.12.tar.xz 177520 BLAKE2B 0938fe9bd8785fe711edc1af63a9c318a4a5fe9141c61d7f1c4da0352242322f1e18e4f68f7e219a1aa2beae5b25ddac58d7c47d4272408fd8fe5207324ef7c7 SHA512 2ea182364dfb2333112e9eebe691e1963e95a4c9ab40945eb2e5bc8c81da76105c1ae6aa3d153b78dea6c1e0cadb9b0237f7556b8ceb9d48e0fba67a642d6081
DIST eselect-1.4.14.tar.xz 177492 BLAKE2B 236ddb09231283a153c20be779d012979a25d42a7043c75af866e777731761406d92896bfef399c3bc63e529af4e36cf538801302dc4bb719f065d6bab8ad9e4 SHA512 b17fb63039577f20515056fae1b0f7e86fa2d96f38a5eec22e637cee0b25f4d68087ef8a5bd4043893db5be66ea201bc8ae6437bb049d208b81e76a57612d658
DIST eselect-1.4.15.tar.xz 178996 BLAKE2B 4354d975c8af2e1de0f0c6efe2badc92584e947f9b73c05aac144caf8f9d74c850d366c7c225112322a504262b5f285f6e2e8d32223f1b2d4bac87db740a148c SHA512 ceb55fecc2bf70e816679af9b20653b29aa9ce24ca2d4cd0c6e02ab214689459bc2ccd5b3968ac49249b8fb6613c6055e7e76598b86c6a114a9abf847c4a2b58
+DIST eselect-1.4.16.tar.xz 178660 BLAKE2B dae97ee324cb67983c5395b5dc54c4b84d2da43f6a0c5c8ab81ff402ab211e9d1f1d3fe5c174b130ac1e11d3dd19e3812056274145415ee029e649cda880cd95 SHA512 264fb6122f5f7c9e73bb2250a94c3c0377e5263e2e5ae653ed58e08ebf6ed1b4aa165ae5c1d70b0156081c4db5672d1ec9d379782919d5b40a2f3e862378ce62
diff --git a/app-admin/eselect/eselect-1.4.16.ebuild b/app-admin/eselect/eselect-1.4.16.ebuild
new file mode 100644
index 000000000000..aa84c092b387
--- /dev/null
+++ b/app-admin/eselect/eselect-1.4.16.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit bash-completion-r1
+
+DESCRIPTION="Gentoo's multi-purpose configuration and management tool"
+HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Eselect"
+SRC_URI="https://dev.gentoo.org/~ulm/eselect/${P}.tar.xz"
+
+LICENSE="GPL-2+ || ( GPL-2+ CC-BY-SA-4.0 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="doc emacs vim-syntax"
+
+RDEPEND="sys-apps/sed
+ || (
+ sys-apps/coreutils
+ sys-freebsd/freebsd-bin
+ app-misc/realpath
+ )"
+DEPEND="${RDEPEND}
+ doc? ( dev-python/docutils )"
+RDEPEND="${RDEPEND}
+ sys-apps/file
+ sys-libs/ncurses:0"
+
+PDEPEND="emacs? ( app-emacs/eselect-mode )
+ vim-syntax? ( app-vim/eselect-syntax )"
+
+src_compile() {
+ emake
+ use doc && emake html
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ newbashcomp misc/${PN}.bashcomp ${PN}
+ dodoc AUTHORS ChangeLog NEWS README TODO doc/*.txt
+ if use doc; then
+ docinto html
+ dodoc *.html doc/*.html doc/*.css
+ fi
+
+ # needed by news module
+ keepdir /var/lib/gentoo/news
+ if ! use prefix; then
+ fowners root:portage /var/lib/gentoo/news
+ fperms g+w /var/lib/gentoo/news
+ fi
+}
+
+pkg_postinst() {
+ # fowners in src_install doesn't work for the portage group:
+ # merging changes the group back to root
+ if ! use prefix; then
+ chgrp portage "${EROOT}/var/lib/gentoo/news" \
+ && chmod g+w "${EROOT}/var/lib/gentoo/news"
+ fi
+}