summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-01-06 06:03:16 +0100
committerMichał Górny <mgorny@gentoo.org>2023-01-06 06:03:16 +0100
commit9d30eb42c7abba3e93dc73394bbdb34d735a8246 (patch)
tree1c97959ae3fc4cd121c15c0d497241d4058a2be6 /app-admin
parentdev-python/boto3: Bump to 1.26.44 (diff)
downloadgentoo-9d30eb42c7abba3e93dc73394bbdb34d735a8246.tar.gz
gentoo-9d30eb42c7abba3e93dc73394bbdb34d735a8246.tar.bz2
gentoo-9d30eb42c7abba3e93dc73394bbdb34d735a8246.zip
app-admin/awscli: Bump to 1.27.44
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/awscli/Manifest1
-rw-r--r--app-admin/awscli/awscli-1.27.44.ebuild80
2 files changed, 81 insertions, 0 deletions
diff --git a/app-admin/awscli/Manifest b/app-admin/awscli/Manifest
index 58e324ae5ba2..fd1f8c228eb2 100644
--- a/app-admin/awscli/Manifest
+++ b/app-admin/awscli/Manifest
@@ -3,3 +3,4 @@ DIST aws-cli-1.27.37.gh.tar.gz 2332965 BLAKE2B 9c855f02bc63f64e3d9bb706139305a6b
DIST aws-cli-1.27.41.gh.tar.gz 2333941 BLAKE2B ab39bd9acdf7d2d6f7ac6a8168b5959ede6799b4e06e04892fd49fae056b384c4fe9f7d721301b46be90f84fc0ead345968d1bc93399c8d8a374559e10c31519 SHA512 81d36eb1554386968924ea14c42e03fc21ab32ab97750f2d8fd20ac0deb6a6a7184b84b41e06ba0738ece233ff9dba08fe1f9f801bce1a2b38656c73f23e76e0
DIST aws-cli-1.27.42.gh.tar.gz 2334306 BLAKE2B ae531e82fcc4f7fc290d1a383f3d93eb20fc238a759d9f2afefed64998f47958456b9f32345a314e0d34a8817777d47e554fa367845c8d7dcfac27f3e3b6a12e SHA512 f2d976e9892b512a9d0d4bf2a629089aa0b63f273ef6464173cdabbe7e9e348bfaded1e2b1e15656db0ca4245d9de798b6e896da945aab359dacd8f1811bd5ba
DIST aws-cli-1.27.43.gh.tar.gz 2334390 BLAKE2B dce5ebdf220a946084506765a72f6d7afd7a8667c9cc8d4c5ffe39fc0386d96a96f129fe54c5b150b5b47b5cfa1a3a1b3dbd7e8f424191030f5ff22872ac169e SHA512 a927b05bc2dd9eb5c64f4f80e85719f8571f025ab3734beed34720376088f0434c286d050159a7042f1149f3a5c1936588c20faf97cbd4b068d0a74a390876db
+DIST aws-cli-1.27.44.gh.tar.gz 2334804 BLAKE2B bd7064f1e7691ce8d66448899083715b6d53b6ed5530366bcd2162046b559503a5ec6b1c56d039745e392c4bad098975dba694f3899a4734b5d985d2c793c93b SHA512 476226affbd8fa533143faebdc3b3131796b3f60fc9704721a3573e0ac0c96fe4bc9ae3dd377a4e6eeba5b74ed13e86a99c629cc4a7dd1a441fb78855bfbcadf
diff --git a/app-admin/awscli/awscli-1.27.44.ebuild b/app-admin/awscli/awscli-1.27.44.ebuild
new file mode 100644
index 000000000000..62c19f3a63fb
--- /dev/null
+++ b/app-admin/awscli/awscli-1.27.44.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit bash-completion-r1 distutils-r1 multiprocessing
+
+MY_P=aws-cli-${PV}
+DESCRIPTION="Universal Command Line Environment for AWS"
+HOMEPAGE="
+ https://github.com/aws/aws-cli/
+ https://pypi.org/project/awscli/
+"
+SRC_URI="
+ https://github.com/aws/aws-cli/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+# botocore is x.(y+2).z
+BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 2)).$(ver_cut 3-)"
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/rsa[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.6.0[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ !app-admin/awscli-bin
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-forked[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+ # strip overzealous upper bounds on requirements
+ sed -i -e 's:,<[0-9.]*::' -e 's:==:>=:' setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # TODO
+ tests/functional/eks/test_kubeconfig.py::TestKubeconfigLoader::test_load_simple
+ tests/unit/customizations/eks/test_update_kubeconfig.py::TestKubeconfigSelector::test_choose_env_only
+ tests/unit/customizations/eks/test_update_kubeconfig.py::TestKubeconfigSelector::test_choose_existing
+ tests/unit/customizations/eks/test_kubeconfig.py::TestKubeconfigValidator::test_valid
+ )
+
+ # integration tests require AWS credentials and Internet access
+ epytest tests/{functional,unit} -n "$(makeopts_jobs)" --forked
+}
+
+python_install_all() {
+ newbashcomp bin/aws_bash_completer aws
+
+ insinto /usr/share/zsh/site-functions
+ newins bin/aws_zsh_completer.sh _aws
+
+ distutils-r1_python_install_all
+
+ rm "${ED}"/usr/bin/{aws.cmd,aws_bash_completer,aws_zsh_completer.sh} || die
+}