summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2018-05-31 13:52:37 +0200
committerLars Wendler <polynomial-c@gentoo.org>2018-05-31 13:53:04 +0200
commita81eab6e099fc55682769d065ee7d1d913a63511 (patch)
tree5028f89b9c0513e7aa630acbfa95d37d7dc65eeb /app-admin
parentapp-emulation/reg: Remove unused IUSE (diff)
downloadgentoo-a81eab6e099fc55682769d065ee7d1d913a63511.tar.gz
gentoo-a81eab6e099fc55682769d065ee7d1d913a63511.tar.bz2
gentoo-a81eab6e099fc55682769d065ee7d1d913a63511.zip
app-admin/monit: Revbump to install bash-completion file. Removed old
Also added ipv6 USE flag. Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/monit/monit-5.25.2-r1.ebuild (renamed from app-admin/monit/monit-5.25.2.ebuild)13
1 files changed, 10 insertions, 3 deletions
diff --git a/app-admin/monit/monit-5.25.2.ebuild b/app-admin/monit/monit-5.25.2-r1.ebuild
index 43e22cd6648d..8897263d608b 100644
--- a/app-admin/monit/monit-5.25.2.ebuild
+++ b/app-admin/monit/monit-5.25.2-r1.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-inherit pam systemd
+inherit bash-completion-r1 pam systemd
DESCRIPTION="Monitoring and managing daemons or similar programs running on a Unix system"
HOMEPAGE="http://mmonit.com/monit/"
@@ -11,7 +11,7 @@ SRC_URI="http://mmonit.com/monit/dist/${P}.tar.gz"
LICENSE="AGPL-3"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux"
-IUSE="libressl pam ssl"
+IUSE="ipv6 libressl pam ssl"
RDEPEND="
ssl? (
@@ -30,7 +30,12 @@ src_prepare() {
}
src_configure() {
- econf $(use_with ssl) $(use_with pam)
+ local myeconfargs=(
+ $(use_with ipv6)
+ $(use_with pam)
+ $(use_with ssl)
+ )
+ econf "${myeconfargs[@]}"
}
src_install() {
@@ -43,6 +48,8 @@ src_install() {
systemd_dounit "${FILESDIR}"/${PN}.service
use pam && newpamd "${FILESDIR}"/${PN}.pamd ${PN}
+
+ dobashcomp system/bash/monit
}
pkg_postinst() {