summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-09-23 08:36:45 +0200
committerMichał Górny <mgorny@gentoo.org>2021-09-23 10:16:17 +0200
commitafc141479060b9ce30b9958dddf975e877c11744 (patch)
tree4fcbaa3ebc8bb0b993cdfc0484f24ee5eadb0750 /app-admin
parentdev-python/boto3: Bump to 1.18.46 (diff)
downloadgentoo-afc141479060b9ce30b9958dddf975e877c11744.tar.gz
gentoo-afc141479060b9ce30b9958dddf975e877c11744.tar.bz2
gentoo-afc141479060b9ce30b9958dddf975e877c11744.zip
app-admin/awscli: Bump to 1.20.46
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/awscli/Manifest1
-rw-r--r--app-admin/awscli/awscli-1.20.46.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/app-admin/awscli/Manifest b/app-admin/awscli/Manifest
index b3a552754d1f..3da3df3ce568 100644
--- a/app-admin/awscli/Manifest
+++ b/app-admin/awscli/Manifest
@@ -5,3 +5,4 @@ DIST awscli-1.20.42.tar.gz 2072504 BLAKE2B 5f6f38f8c96350b670c15cd6cfdd1556cbbfa
DIST awscli-1.20.43.tar.gz 2073056 BLAKE2B e4d3301022083db4b4dd59ce9d0acc5b2ef2ba2359236bebb11b024dcf681deedbd0df8a7cf143503318dc66a9d69305fefc97dc3407bdb77985fd0854ba7915 SHA512 5fb9a6f18a04640bdee94b80aa5b5893dbcc9316c06f543ec8491fef3db4394d6d1aa2cf35972cec04e6c8c74c9111fab71d007b63c4a3152aad80b099d5c43e
DIST awscli-1.20.44.tar.gz 2073627 BLAKE2B 906e03139bde50724348b445750bcc2b286fe33c0ba8873e0373bfc4f62124a25a400821cd8d3608f3f52fe8a3649218c5c10bebad8a5887b131088aab80220d SHA512 58a7232e1708791cf4d9149aab6afebca50e422a0cdf10215aed9ea1e4f71daeb64253bcc12c4934737fe2f5688dc50e6cf8fde1335c99338804590030b0973c
DIST awscli-1.20.45.tar.gz 2074157 BLAKE2B 4ff9af5217bf241c89de1fb601ff5c41f22072ac122cf5ec3ebed017df2871d064f0d16f26795eec99954d7d67d76db1d93ddab21b7157c56a83fb0880d1287a SHA512 a842d83f33217f9e6298df28ed3cd0ea4a66964239ba25c09c7c7e7749e0f5c405f379a556827960f1c4525d0f7c80dd7aa87c016b92d74a2d6d6636c1c0f486
+DIST awscli-1.20.46.tar.gz 2079078 BLAKE2B c5e4f7c3f068dbcba9e6c8b4b96e3d41e60b0bf58aecfc06fa93cc918d570bdac77f3ccc28819c04f4cc7be25627d505c1180d78cb4ccd9fae4ea4c7b517e3bb SHA512 b0c46fce82497a399725bb4965700a7c9a41be4ca62115da6028ba2b7c7420b72301c4ad46133067d0da42690a8ca5575f54f54977d158090d01995308a2b785
diff --git a/app-admin/awscli/awscli-1.20.46.ebuild b/app-admin/awscli/awscli-1.20.46.ebuild
new file mode 100644
index 000000000000..95a3e5aaa0df
--- /dev/null
+++ b/app-admin/awscli/awscli-1.20.46.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit bash-completion-r1 distutils-r1
+
+DESCRIPTION="Universal Command Line Environment for AWS"
+HOMEPAGE="https://pypi.org/project/awscli/"
+#SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+SRC_URI="https://github.com/aws/aws-cli/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/aws-cli-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+# botocore is x.(y+1).z
+BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 1)).$(ver_cut 3-)"
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/rsa[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.4.0[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests --install nose
+
+PATCHES=(
+ "${FILESDIR}"/awscli-1.19.47-py39.patch
+)
+
+python_test() {
+ distutils_install_for_testing
+ # integration tests require AWS credentials and Internet access
+ nosetests -v tests/{functional,unit} ||
+ die "Tests failed for ${EPYTHON}"
+}
+
+python_install_all() {
+ newbashcomp bin/aws_bash_completer aws
+
+ insinto /usr/share/zsh/site-functions
+ newins bin/aws_zsh_completer.sh _aws
+
+ distutils-r1_python_install_all
+
+ rm "${ED}"/usr/bin/{aws.cmd,aws_bash_completer,aws_zsh_completer.sh} || die
+}