summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2019-01-18 00:11:34 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2019-01-18 00:11:34 -0600
commitc2a66c3e7c7b3c5d9bcaa73030b3d7f1b7a60e5d (patch)
tree4ce65543f4b7d889c223ea6adcd17d52863ca90f /app-admin
parentsys-apps/portage: remove old version 2.3.55 (diff)
downloadgentoo-c2a66c3e7c7b3c5d9bcaa73030b3d7f1b7a60e5d.tar.gz
gentoo-c2a66c3e7c7b3c5d9bcaa73030b3d7f1b7a60e5d.tar.bz2
gentoo-c2a66c3e7c7b3c5d9bcaa73030b3d7f1b7a60e5d.zip
app-admin/ansible: 2.6.12 and 2.7.6 bump
Package-Manager: Portage-2.3.51, Repoman-2.3.12 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/ansible/Manifest2
-rw-r--r--app-admin/ansible/ansible-2.6.12.ebuild66
-rw-r--r--app-admin/ansible/ansible-2.7.6.ebuild66
3 files changed, 134 insertions, 0 deletions
diff --git a/app-admin/ansible/Manifest b/app-admin/ansible/Manifest
index 986ae10f18e0..99c38ffab098 100644
--- a/app-admin/ansible/Manifest
+++ b/app-admin/ansible/Manifest
@@ -1,3 +1,5 @@
DIST ansible-2.5.14.tar.gz 10119785 BLAKE2B 6e771aafc16053185ee6d275d6d41f64aa3f0d6dffbe721a66b548b97e84d78916e03827d592b961f9a4e0bb03fae09320731a4b8fdb814126cecdfb51f9f136 SHA512 9635b1c4bc9a93a24f4bb2894c9fed63803cecb01c5562559e3b808791d1007b26aa0aade4aa05fd4bae0f7d01216588d4e2e0bf4c5fb6cdf677d9b40e9e2de8
DIST ansible-2.6.11.tar.gz 10722546 BLAKE2B d98a82323409b894343c22c0b6226ef643bae34198627a6de426fdb65ef2a9892429edda20d522b8f501fe34c47b463f844abc7e6cf38009bd22398ca0c35f11 SHA512 5b795644d2bc02470b8a71be42720405614eac3e602a8906257c82ace36dc4c3727322b12ffadda6e2b752d963a40559cc35b1bc0a85596123896e7d1ac75b6b
+DIST ansible-2.6.12.tar.gz 10726648 BLAKE2B 9f3b1b48069f5b450f649bf1c21ee57922ac3db6a8b1b11c459b572bf298813490f230400f09d35d4d7b21a709643ac37cb527719fea59a1b57616b476235dcb SHA512 daee0a5c37a83dfd22b1fccb5245735e4874f7428f5e8f0244a8a208c7f73729bffc06df16d16e257ae65b8d4cafeb4e3b67e49160b5d9d530666166b5096a70
DIST ansible-2.7.5.tar.gz 11781337 BLAKE2B cbb1ae02ee5733c03797db8acbb79980e24afe6e265aa609bbb22d8b43675c8ec995a4b10f3212e8dbf2fe49fdbccf1d2f8ee251bb4bd11ee5198a2ca2443147 SHA512 b3a8a2c10e42f4dcf0f3867901eaaf555e6b9bcbd808b91765a8825db3ec49d618d8893f244d52e49e944d0900a876bbb31b3a7b89d636e435e94cd4b281be18
+DIST ansible-2.7.6.tar.gz 11796062 BLAKE2B 171dbcc7380ded52b03b9b109705008a492dbc5b8542fa600562c66abb8c3d3ace6bc92696559357d62fec106938e8fa4366b67cd621e4e8144fad59d0870db7 SHA512 db0813009b4683b74bf4dda640adc3dad750e053c3a87f97c6e61a2a5ea7668ea51e97ec204ddcdba6f09733bb399f824f87f365b74c35315b979603c99a6b70
diff --git a/app-admin/ansible/ansible-2.6.12.ebuild b/app-admin/ansible/ansible-2.6.12.ebuild
new file mode 100644
index 000000000000..4bec3453ac7f
--- /dev/null
+++ b/app-admin/ansible/ansible-2.6.12.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6} )
+
+inherit distutils-r1 eutils
+
+DESCRIPTION="Model-driven deployment, config management, and command execution framework"
+HOMEPAGE="https://ansible.com/"
+SRC_URI="https://releases.ansible.com/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x64-macos"
+IUSE="doc test"
+
+RDEPEND="
+ dev-python/paramiko[${PYTHON_USEDEP}]
+ dev-python/jinja[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/httplib2[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/netaddr[${PYTHON_USEDEP}]
+ net-misc/sshpass
+ virtual/ssh
+"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/packaging-16.6[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? (
+ ${RDEPEND}
+ dev-python/nose[${PYTHON_USEDEP}]
+ >=dev-python/mock-1.0.1[${PYTHON_USEDEP}]
+ dev-python/passlib[${PYTHON_USEDEP}]
+ dev-python/coverage[${PYTHON_USEDEP}]
+ dev-python/unittest2[${PYTHON_USEDEP}]
+ dev-vcs/git
+ )"
+
+# not included in release tarball
+RESTRICT="test"
+
+python_compile_all() {
+ if use doc; then
+ cd docs/docsite || die
+ export CPUS=4
+ emake -f Makefile.sphinx html
+ fi
+}
+
+python_test() {
+ nosetests -d -w test/units -v --with-coverage --cover-package=ansible --cover-branches || die
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/docsite/_build/html/. )
+ distutils-r1_python_install_all
+
+ doman docs/man/man1/*.1
+ dodoc -r examples
+}
diff --git a/app-admin/ansible/ansible-2.7.6.ebuild b/app-admin/ansible/ansible-2.7.6.ebuild
new file mode 100644
index 000000000000..c32faea9ddfd
--- /dev/null
+++ b/app-admin/ansible/ansible-2.7.6.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6} )
+
+inherit distutils-r1 eutils
+
+DESCRIPTION="Model-driven deployment, config management, and command execution framework"
+HOMEPAGE="https://ansible.com/"
+SRC_URI="https://releases.ansible.com/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86 ~x64-macos"
+IUSE="doc test"
+
+RDEPEND="
+ dev-python/paramiko[${PYTHON_USEDEP}]
+ dev-python/jinja[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/httplib2[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/netaddr[${PYTHON_USEDEP}]
+ net-misc/sshpass
+ virtual/ssh
+"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/packaging-16.6[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? (
+ ${RDEPEND}
+ dev-python/nose[${PYTHON_USEDEP}]
+ >=dev-python/mock-1.0.1[${PYTHON_USEDEP}]
+ dev-python/passlib[${PYTHON_USEDEP}]
+ dev-python/coverage[${PYTHON_USEDEP}]
+ dev-python/unittest2[${PYTHON_USEDEP}]
+ dev-vcs/git
+ )"
+
+# not included in release tarball
+RESTRICT="test"
+
+python_compile_all() {
+ if use doc; then
+ cd docs/docsite || die
+ export CPUS=4
+ emake -f Makefile.sphinx html
+ fi
+}
+
+python_test() {
+ nosetests -d -w test/units -v --with-coverage --cover-package=ansible --cover-branches || die
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/docsite/_build/html/. )
+ distutils-r1_python_install_all
+
+ doman docs/man/man1/*.1
+ dodoc -r examples
+}