summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Mozes <hydrapolic@gmail.com>2018-03-12 09:20:17 +0100
committerPatrice Clement <monsieurp@gentoo.org>2018-03-12 23:59:07 +0100
commitc729888d599e0ab0d74bead25089f8bcd94185b0 (patch)
tree6de98eef4f7f221f118d56d14d62ef7dfc02d796 /app-admin
parentwww-apps/kibana-bin: drop old. (diff)
downloadgentoo-c729888d599e0ab0d74bead25089f8bcd94185b0.tar.gz
gentoo-c729888d599e0ab0d74bead25089f8bcd94185b0.tar.bz2
gentoo-c729888d599e0ab0d74bead25089f8bcd94185b0.zip
app-admin/logstash-bin: bump to 5.6.8/6.2.2.
Closes: https://bugs.gentoo.org/647828 Package-Manager: Portage-2.3.24, Repoman-2.3.6 Closes: https://github.com/gentoo/gentoo/pull/7431
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/logstash-bin/Manifest2
-rw-r--r--app-admin/logstash-bin/logstash-bin-5.6.8.ebuild77
-rw-r--r--app-admin/logstash-bin/logstash-bin-6.2.2.ebuild77
3 files changed, 156 insertions, 0 deletions
diff --git a/app-admin/logstash-bin/Manifest b/app-admin/logstash-bin/Manifest
index d115ba5e88c0..51c35ee4d3bc 100644
--- a/app-admin/logstash-bin/Manifest
+++ b/app-admin/logstash-bin/Manifest
@@ -1,3 +1,5 @@
DIST logstash-5.6.5.zip 109135563 BLAKE2B 6846231439807dd4fc77ae86af849aaefcc9084482f2f88de6148da3d31ef583164da6749ebe0c4def83217e95729a933acbb3e04777db58639eaab91de06831 SHA512 f1dcbb8f67d2f2868e38646b56376428e0996cbf302837300939b8c7ff6d764417fccea40f90559c48441f939e6940e84501ee3ad1e29ad2538969f2cc12b2b8
+DIST logstash-5.6.8.zip 109269226 BLAKE2B 7537b1a9687cc1f45f2573ed0ac9d4065bfc7e6d94e5a9d861a4227ace47346f1320e2fe9139a6bb82b8a75d5b4766e9a1e844dcc43c6b89990f1c1eb88f1262 SHA512 31dfc2792d54813d1361f117bcd4a489a5e37e1a3ad1c6f811fc0e15b4bbfeb84f5d842dea2b8fcb08e503a51ad58ccc298da9bf86536abcfb5541e71b999806
DIST logstash-6.0.1.zip 116215793 BLAKE2B 676810b9cd62f578e31e1d63d4aae8c920590905a7344434d5e14607bab0e3ce59e2740e6839491f44ce769b24330a7a060174dcb5e6cb9cf51a31d165ba990b SHA512 395e4e2ff199d9ffc5156901d6ba6ab17771ab8f8859acede74567b2294e2d7ee2a6693e79f7b3e82c8d5c1959ad259bfb22e7992670cdcd3b73c7b72a635a31
DIST logstash-6.1.1.zip 116335093 BLAKE2B e7a990c2ea0eb3ec7de714f038765817c76eaf9e6cef0e55106f1f1aca406ec95d6be779f24c1fa28e096b51feeef968cb31f416f99c85c2f45d798bb74aadf7 SHA512 a2a420169dff31f3d5d65628a9d1eaad930a8e544fc4e986e3671ffeea3a1d03c8f77f8b51568a0da082588a843568fb7aefe29c1c90365882f429f9536f9240
+DIST logstash-6.2.2.zip 146093122 BLAKE2B 0bd01673bb030593a944ecdd859ff0f44d8732f3ffef2b45b38798124c9caa547f625ae9c85300500683bac149b6ca4b9976bd0769fa0684989d40aa452a3584 SHA512 eb67b1fbe2530e4b24252a03aca572a41188e119cbf4a88267795782b347155f2e20405add6626585688fa6ed9d38fa463a0818fccd12612285950904dbd0cad
diff --git a/app-admin/logstash-bin/logstash-bin-5.6.8.ebuild b/app-admin/logstash-bin/logstash-bin-5.6.8.ebuild
new file mode 100644
index 000000000000..b14f892c2844
--- /dev/null
+++ b/app-admin/logstash-bin/logstash-bin-5.6.8.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit java-pkg-2 user
+
+MY_PN="${PN%-bin}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Tool for managing events and logs"
+HOMEPAGE="https://www.elastic.co/products/logstash"
+SRC_URI="https://artifacts.elastic.co/downloads/${MY_PN}/${MY_P}.zip"
+
+# source: LICENSE.txt and NOTICE.txt
+LICENSE="Apache-2.0 MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RESTRICT="strip"
+QA_PREBUILT="opt/logstash/vendor/jruby/lib/jni/*/libjffi*.so"
+
+RDEPEND="virtual/jre:1.8"
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+ enewgroup ${MY_PN}
+ enewuser ${MY_PN} -1 -1 /var/lib/${MY_PN} ${MY_PN}
+}
+
+src_install() {
+ keepdir /etc/"${MY_PN}"/{conf.d,patterns,plugins}
+ keepdir "/var/lib/${MY_PN}"
+ keepdir "/var/log/${MY_PN}"
+
+ insinto "/usr/share/${MY_PN}"
+ newins "${FILESDIR}/agent.conf.sample" agent.conf
+
+ rm -v config/startup.options || die
+ insinto /etc/${MY_PN}
+ doins config/*
+ rm -rv config data || die
+
+ insinto "/opt/${MY_PN}"
+ doins -r .
+ fperms 0755 "/opt/${MY_PN}/bin/${MY_PN}" "/opt/${MY_PN}/vendor/jruby/bin/jruby" "/opt/${MY_PN}/bin/logstash-plugin"
+
+ newconfd "${FILESDIR}/${MY_PN}.confd-r1" "${MY_PN}"
+ newinitd "${FILESDIR}/${MY_PN}.initd-r1" "${MY_PN}"
+
+ insinto /usr/share/eselect/modules
+ doins "${FILESDIR}"/logstash-plugin.eselect
+}
+
+pkg_postinst() {
+ ewarn "The default pidfile directory has been changed from /run/logstash to /run."
+ ewarn "Please ensure any running logstash processes are shut down cleanly."
+ ewarn
+ ewarn "The default data directory has been moved from /opt/logstash/data to"
+ ewarn "/var/lib/logstash/data. Please check and move its contents as necessary."
+ ewarn
+ ewarn "Self installed plugins are removed during Logstash upgrades (Bug #622602)"
+ ewarn "Install the plugins via eselect module that will automatically re-install"
+ ewarn "all self installed plugins after Logstash upgrades."
+ einfo
+ einfo "Installing plugins:"
+ einfo "eselect logstash-plugin install logstash-output-gelf"
+ einfo
+
+ einfo "Reinstalling self installed plugins (installed via eselect module):"
+ eselect logstash-plugin reinstall
+
+ einfo
+ einfo "Sample configuration:"
+ einfo "${EROOT%/}/usr/share/${MY_PN}"
+}
diff --git a/app-admin/logstash-bin/logstash-bin-6.2.2.ebuild b/app-admin/logstash-bin/logstash-bin-6.2.2.ebuild
new file mode 100644
index 000000000000..1977b1915acb
--- /dev/null
+++ b/app-admin/logstash-bin/logstash-bin-6.2.2.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit java-pkg-2 user
+
+MY_PN="${PN%-bin}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Tool for managing events and logs"
+HOMEPAGE="https://www.elastic.co/products/logstash"
+SRC_URI="https://artifacts.elastic.co/downloads/${MY_PN}/${MY_P}.zip"
+
+# source: LICENSE.txt and NOTICE.txt
+LICENSE="Apache-2.0 MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RESTRICT="strip"
+QA_PREBUILT="opt/logstash/vendor/jruby/lib/jni/*/libjffi*.so"
+
+RDEPEND="virtual/jre:1.8"
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+ enewgroup ${MY_PN}
+ enewuser ${MY_PN} -1 -1 /var/lib/${MY_PN} ${MY_PN}
+}
+
+src_install() {
+ keepdir /etc/"${MY_PN}"/{conf.d,patterns,plugins}
+ keepdir "/var/lib/${MY_PN}"
+ keepdir "/var/log/${MY_PN}"
+
+ insinto "/usr/share/${MY_PN}"
+ newins "${FILESDIR}/agent.conf.sample" agent.conf
+
+ rm -v config/startup.options || die
+ insinto /etc/${MY_PN}
+ doins -r config/.
+ rm -rv config data || die
+
+ insinto "/opt/${MY_PN}"
+ doins -r .
+ fperms 0755 "/opt/${MY_PN}/bin/${MY_PN}" "/opt/${MY_PN}/vendor/jruby/bin/jruby" "/opt/${MY_PN}/bin/logstash-plugin"
+
+ newconfd "${FILESDIR}/${MY_PN}.confd-r1" "${MY_PN}"
+ newinitd "${FILESDIR}/${MY_PN}.initd-r1" "${MY_PN}"
+
+ insinto /usr/share/eselect/modules
+ doins "${FILESDIR}"/logstash-plugin.eselect
+}
+
+pkg_postinst() {
+ ewarn "The default pidfile directory has been changed from /run/logstash to /run."
+ ewarn "Please ensure any running logstash processes are shut down cleanly."
+ ewarn
+ ewarn "The default data directory has been moved from /opt/logstash/data to"
+ ewarn "/var/lib/logstash/data. Please check and move its contents as necessary."
+ ewarn
+ ewarn "Self installed plugins are removed during Logstash upgrades (Bug #622602)"
+ ewarn "Install the plugins via eselect module that will automatically re-install"
+ ewarn "all self installed plugins after Logstash upgrades."
+ einfo
+ einfo "Installing plugins:"
+ einfo "eselect logstash-plugin install logstash-output-gelf"
+ einfo
+
+ einfo "Reinstalling self installed plugins (installed via eselect module):"
+ eselect logstash-plugin reinstall
+
+ einfo
+ einfo "Sample configuration:"
+ einfo "${EROOT%/}/usr/share/${MY_PN}"
+}