summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-12-17 11:59:55 +0100
committerMichał Górny <mgorny@gentoo.org>2022-12-17 13:34:41 +0100
commitccf4f5d452610fdb79b8813558796a8641c69efd (patch)
treecb046f61d6a2b665f5980c7790af4c0ab3ebff41 /app-admin
parentdev-python/boto3: Bump to 1.26.32 (diff)
downloadgentoo-ccf4f5d452610fdb79b8813558796a8641c69efd.tar.gz
gentoo-ccf4f5d452610fdb79b8813558796a8641c69efd.tar.bz2
gentoo-ccf4f5d452610fdb79b8813558796a8641c69efd.zip
app-admin/awscli: Bump to 1.27.32
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/awscli/Manifest1
-rw-r--r--app-admin/awscli/awscli-1.27.32.ebuild80
2 files changed, 81 insertions, 0 deletions
diff --git a/app-admin/awscli/Manifest b/app-admin/awscli/Manifest
index 3892d1399841..ca7f10d5d3a6 100644
--- a/app-admin/awscli/Manifest
+++ b/app-admin/awscli/Manifest
@@ -1,3 +1,4 @@
DIST aws-cli-1.27.20.gh.tar.gz 2315771 BLAKE2B 6729a6709e2ae3d493700b49dbcb7020391f7ce9e2d023e942271a27502309c8f699e90063aa6a13256981123d22772653888fcaae7bebe3cde471caa21bf4a1 SHA512 b520136e0c41e1b40ce48f90024461ace2d0967f3897dcdf68c90cc89ca637e3ba1dee117d5c1f7c6cd9d0d598e819c5faf5ebbf8a35818dc5e8c85933122af6
DIST aws-cli-1.27.29.gh.tar.gz 2325759 BLAKE2B 693131da782ce248a00560617d3d1cd57e1dcac20ba8a6a560b5a1c06c7f6b18576efd4e0a2151d538e28b3f59593ded609e8fea3d29bce9f91bc270f888e23a SHA512 828a3fdda0b3156c1b09ed53b5c2c6486857bdd1e4e3d5cfd77e817bc6c1e53e1ff3f7ddf83c55e8ca93b2944f37333244adffa0f3b9416b1c4197db9b364dde
DIST aws-cli-1.27.31.gh.tar.gz 2327529 BLAKE2B 5c274358df6ed3081e945f21aac184fb774cc4b5d621954f4c4b88996252c3edb0b9c76d6aaab1f5273f0c2db1d19a7d5a46f3c1915190e7d5c141e9cfcf908d SHA512 37b295265d32e8ca73f3b16c4225027df8b735c39a930ad64db9590737da0e9407560fb82514417a0f7b42692fec27c8b949f91c973e719199c9767ff613559d
+DIST aws-cli-1.27.32.gh.tar.gz 2328348 BLAKE2B 0958525a47f6dac8422dd37c9e099c2bf48d4bb5a8897673d18bb5b747dc6a0806d71cdf92899daf768ffa7cf9b7d39fe559cadad46eabc7913130d98c578d75 SHA512 db034e58761368a72e5a233e49e6c904281635fb47384f984b2ead1bd285bdb0af1a7e7b76d77ddaa6d19496ee1add756e1dbc43044aab1ba2b1f09232a112c9
diff --git a/app-admin/awscli/awscli-1.27.32.ebuild b/app-admin/awscli/awscli-1.27.32.ebuild
new file mode 100644
index 000000000000..caea725bbca7
--- /dev/null
+++ b/app-admin/awscli/awscli-1.27.32.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit bash-completion-r1 distutils-r1 multiprocessing
+
+MY_P=aws-cli-${PV}
+DESCRIPTION="Universal Command Line Environment for AWS"
+HOMEPAGE="
+ https://github.com/aws/aws-cli/
+ https://pypi.org/project/awscli/
+"
+SRC_URI="
+ https://github.com/aws/aws-cli/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+# botocore is x.(y+2).z
+BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 2)).$(ver_cut 3-)"
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/rsa[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.6.0[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ !app-admin/awscli-bin
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-forked[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+ # strip overzealous upper bounds on requirements
+ sed -i -e 's:,<[0-9.]*::' -e 's:==:>=:' setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # TODO
+ tests/functional/eks/test_kubeconfig.py::TestKubeconfigLoader::test_load_simple
+ tests/unit/customizations/eks/test_update_kubeconfig.py::TestKubeconfigSelector::test_choose_env_only
+ tests/unit/customizations/eks/test_update_kubeconfig.py::TestKubeconfigSelector::test_choose_existing
+ tests/unit/customizations/eks/test_kubeconfig.py::TestKubeconfigValidator::test_valid
+ )
+
+ # integration tests require AWS credentials and Internet access
+ epytest tests/{functional,unit} -n "$(makeopts_jobs)" --forked
+}
+
+python_install_all() {
+ newbashcomp bin/aws_bash_completer aws
+
+ insinto /usr/share/zsh/site-functions
+ newins bin/aws_zsh_completer.sh _aws
+
+ distutils-r1_python_install_all
+
+ rm "${ED}"/usr/bin/{aws.cmd,aws_bash_completer,aws_zsh_completer.sh} || die
+}