summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-06-15 01:21:32 +0000
committerSam James <sam@gentoo.org>2021-06-15 01:21:36 +0000
commitcd260d9a9fdb2c2a8f0ef7b4e947c7df0ef1d2a2 (patch)
tree1b871905fe7dd1b106e16306c5a92d999421c1d4 /app-admin
parentprofiles: last-rite media-sound/sc2mpd (diff)
downloadgentoo-cd260d9a9fdb2c2a8f0ef7b4e947c7df0ef1d2a2.tar.gz
gentoo-cd260d9a9fdb2c2a8f0ef7b4e947c7df0ef1d2a2.tar.bz2
gentoo-cd260d9a9fdb2c2a8f0ef7b4e947c7df0ef1d2a2.zip
app-admin/tripwire: update EAPI 6 -> 7, workaround GCC 11 failure
Set C++ standard to c++14 rather than perform a huge sed on the byte type. Closes: https://bugs.gentoo.org/786465 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/tripwire/tripwire-2.4.3.7.ebuild15
1 files changed, 12 insertions, 3 deletions
diff --git a/app-admin/tripwire/tripwire-2.4.3.7.ebuild b/app-admin/tripwire/tripwire-2.4.3.7.ebuild
index 423a09ff9917..306f41254523 100644
--- a/app-admin/tripwire/tripwire-2.4.3.7.ebuild
+++ b/app-admin/tripwire/tripwire-2.4.3.7.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
inherit autotools flag-o-matic
@@ -36,8 +36,17 @@ src_configure() {
# see #32613, #45823, and others.
# -taviso@gentoo.org
strip-flags
- append-cppflags -DCONFIG_DIR='"\"/etc/tripwire\""' -fno-strict-aliasing
- econf $(use_enable ssl openssl) $(use_enable static)
+
+ append-cppflags -DCONFIG_DIR='"\"/etc/tripwire\""'
+ append-cflags -fno-strict-aliasing
+
+ # "integer.cpp:1162:24: error: reference to ‘byte’ is ambiguous"
+ # bug #786465
+ append-cxxflags -std=c++14
+
+ econf \
+ $(use_enable ssl openssl) \
+ $(use_enable static)
}
src_install() {