summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2015-10-02 13:30:28 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2015-10-02 13:30:28 -0500
commitcef028c70356c9c999fac0b48d0109ca20265264 (patch)
tree751c00e8262210f3bc31bae27714ab97155afe0e /app-admin
parentdev-libs/nss: drop 'cp -t' as it is unsupported in fbsd (diff)
downloadgentoo-cef028c70356c9c999fac0b48d0109ca20265264.tar.gz
gentoo-cef028c70356c9c999fac0b48d0109ca20265264.tar.bz2
gentoo-cef028c70356c9c999fac0b48d0109ca20265264.zip
app-admin/puppet-agent: bup
Package-Manager: portage-2.2.20.1
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/puppet-agent/Manifest2
-rw-r--r--app-admin/puppet-agent/puppet-agent-1.2.5.ebuild77
2 files changed, 79 insertions, 0 deletions
diff --git a/app-admin/puppet-agent/Manifest b/app-admin/puppet-agent/Manifest
index 429ae4dd2e2a..ebf38f701dfc 100644
--- a/app-admin/puppet-agent/Manifest
+++ b/app-admin/puppet-agent/Manifest
@@ -2,3 +2,5 @@ DIST puppet-agent_1.2.2-1wheezy_amd64.deb 14860604 SHA256 5910ff850e8814092b50dc
DIST puppet-agent_1.2.2-1wheezy_i386.deb 14816930 SHA256 092b8bfe1e1156322d0ab68d411487c80146bd778916409b1c907791f41a49c8 SHA512 50879ce4eebcd451dafb33cb7a12c36ee9bcaedfc29ffa0d60552efa5aa4cd66d0007061d28a80d31615c67442f8526863185e6753418772d8275e58454d6886 WHIRLPOOL 7abb0b6f52f5dd07a5ccb56b1c795c05f8c4efd18665d2ca209400e51419e4ae335e630a845c031a47df09d96ce20fbc92d7cafa082deb3872306daf74838612
DIST puppet-agent_1.2.4-1wheezy_amd64.deb 15187770 SHA256 a711255c7b5aab5f1a653fcbe461db0934645b1da876f24595d531c7ad8c81d4 SHA512 dc7656a7f79f1f2e5144bf625b87548ed1b78290ae03c969abb850f0b1c346536c37c2b204ac0e6add830c1fd692ca4f946ea01bba50bb9794c094069f237d73 WHIRLPOOL 3809a0f9c5db1c73c6edcc344e6fdc7fb5acf340e36225611c72088175fe64ea26c3770ba126a61ed91fa275cf898828d9d192872a216a52b8345f25de1df7e6
DIST puppet-agent_1.2.4-1wheezy_i386.deb 15122670 SHA256 33e9b16ea215089e7a89288faebd4767163e05d7c4a9d5c51ca71b041496c204 SHA512 944f6388d317fab9a2714a6cdc57e713a973d3c1df259b3358be3a0d737878df9f1d66186af8aea0cc768e55650f1dd1d3ef8682b942728fba45e7c0bca20867 WHIRLPOOL bd5710845a9c8f27fb566ead63e45649fb3854200df0259c76b9478d93792b453a9d5cf4fdc20112991d4d091c82143b7504b51be65815b2dcb67796f275303d
+DIST puppet-agent_1.2.5-1wheezy_amd64.deb 15187830 SHA256 4d557e45571df033a9e1babf406f9b8a4c387fe6dec7d3645f5e7ad5d7625f0d SHA512 25557aa4d5fa3d2ba0aa226c835d6779d075f0ef7c054cfda9826b1fedd08c90f5143630206b1bd51550f193aecdf4eef6395437f24e5fdfe10d3ed10fb4b75f WHIRLPOOL d6ef920932a708d1a143245f84380384b3a22320c0bb21e60be9807e29af1d3da6dbfef2f498fcb90fe4584618ae338546103c71eb305b743d326e9c20704f1f
+DIST puppet-agent_1.2.5-1wheezy_i386.deb 15122650 SHA256 f34a6e9c70b5276806dacf64fb2b41fd927e6875071d044f9901c5a8d9dacd1d SHA512 0989501ca3f011601bb301126ad58084571ee67eb961fbf1f5cf002eb9155bf4f8e838452ac62b45472f00c0a7538cb5c72c3e43c651675a7940d8ab9a1a309c WHIRLPOOL f9698e3154254d9931fdbccd9a75edccae8ab799f8add0e32995453d62a0d070001ad858449c5b816c1b1a448beb8b99b180558feea3b36fc84c0e730e2d5b7e
diff --git a/app-admin/puppet-agent/puppet-agent-1.2.5.ebuild b/app-admin/puppet-agent/puppet-agent-1.2.5.ebuild
new file mode 100644
index 000000000000..d0c66a57f01c
--- /dev/null
+++ b/app-admin/puppet-agent/puppet-agent-1.2.5.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils systemd unpacker
+
+DESCRIPTION="general puppet client utils along with mcollective hiera and facter"
+HOMEPAGE="https://puppetlabs.com/"
+SRC_BASE="http://apt.puppetlabs.com/pool/wheezy/PC1/${PN:0:1}/${PN}/${PN}_${PV}-1wheezy"
+SRC_URI="
+ amd64? ( ${SRC_BASE}_amd64.deb )
+ x86? ( ${SRC_BASE}_i386.deb )
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="puppetdb selinux"
+RESTRICT="strip"
+
+CDEPEND="!app-admin/augeas
+ !app-admin/mcollective
+ !app-admin/puppet
+ !dev-ruby/hiera
+ !dev-ruby/facter
+ !app-emulation/virt-what"
+
+DEPEND="
+ ${CDEPEND}"
+RDEPEND="${CDEPEND}
+ sys-apps/dmidecode
+ selinux? (
+ sys-libs/libselinux[ruby]
+ sec-policy/selinux-puppet
+ )
+ puppetdb? ( >=dev-ruby/puppetdb-termini-3.0.1-r2 )"
+
+S=${WORKDIR}
+
+src_install() {
+ # conf.d
+ doconfd etc/default/puppet
+ doconfd etc/default/mcollective
+ # logrotate.d
+ insinto /etc/logrotate.d
+ doins etc/logrotate.d/mcollective
+ # puppet itself
+ insinto /etc/puppetlabs
+ doins -r etc/puppetlabs/*
+ # logdir for systemd
+ dodir var/log/puppetlabs/puppet/
+ fperms 0750 var/log/puppetlabs/puppet/
+ # the rest
+ insinto /opt
+ dodir opt/puppetlabs/puppet/cache
+ doins -r opt/*
+ fperms 0750 /opt/puppetlabs/puppet/cache
+ # init
+ newinitd "${FILESDIR}/puppet.initd" puppet
+ newinitd "${FILESDIR}/mcollective.initd" mcollective
+ systemd_dounit "${FILESDIR}/puppet.service"
+ systemd_dounit "${FILESDIR}/mcollective.service"
+ systemd_newtmpfilesd "${FILESDIR}/puppet-agent.conf.tmpfilesd" puppet-agent.conf
+ # symlinks
+ chmod 0755 -R "${D}/opt/puppetlabs/puppet/bin/"
+ chmod 0755 "${D}//opt/puppetlabs/puppet/lib/virt-what/virt-what-cpuid-helper"
+ dosym /opt/puppetlabs/bin/facter /usr/bin/facter
+ dosym /opt/puppetlabs/bin/hiera /usr/bin/hiera
+ dosym /opt/puppetlabs/bin/mco /usr/bin/mco
+ dosym /opt/puppetlabs/bin/puppet /usr/bin/puppet
+ dosym /opt/puppetlabs/puppet/bin/mcollectived /usr/sbin/mcollectived
+ dosym /opt/puppetlabs/puppet/bin/virt-what /usr/bin/virt-what
+ dosym /opt/puppetlabs/puppet/bin/augparse /usr/bin/augparse
+ dosym /opt/puppetlabs/puppet/bin/augtool /usr/bin/augtool
+ dosym /opt/puppetlabs/puppet/bin/extlookup2hiera /usr/bin/extlookup2hiera
+}