summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-04-03 19:08:50 +0200
committerMichał Górny <mgorny@gentoo.org>2018-04-03 19:30:37 +0200
commitd2857c767d1444a7d0dcdc36fb60e0d75a51c05d (patch)
tree04d870ecefe5800cb9dbf551d5f14e5617360dac /app-admin
parentdev-vcs/git: add ~amd64-fbsd keyword. (diff)
downloadgentoo-d2857c767d1444a7d0dcdc36fb60e0d75a51c05d.tar.gz
gentoo-d2857c767d1444a7d0dcdc36fb60e0d75a51c05d.tar.bz2
gentoo-d2857c767d1444a7d0dcdc36fb60e0d75a51c05d.zip
app-admin/systemrescuecd-x86: Bump to 5.2.2
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/systemrescuecd-x86/Manifest1
-rw-r--r--app-admin/systemrescuecd-x86/systemrescuecd-x86-5.2.2.ebuild61
2 files changed, 62 insertions, 0 deletions
diff --git a/app-admin/systemrescuecd-x86/Manifest b/app-admin/systemrescuecd-x86/Manifest
index 7b1155c886ea..bc0615e30a23 100644
--- a/app-admin/systemrescuecd-x86/Manifest
+++ b/app-admin/systemrescuecd-x86/Manifest
@@ -31,3 +31,4 @@ DIST systemrescuecd-x86-5.1.1.iso 517359616 BLAKE2B f139a521076f0345a65bddfd999f
DIST systemrescuecd-x86-5.1.2.iso 523479040 BLAKE2B abf6f1e3e05e382b48dcfd4ecde9f70896462418cf36057e3a42dc2366e0b56133deeb6f00363d15d94238c22fb8ac5c88b57ca6c213c9dcc299fa04def5e2cd SHA512 516e60632459dd5408f83035aa265ed4169b13f978a23960a85837c9c8b5bbab70776e22a6e6727184bd9df81cbbeff4a5819d5927ff0ff3a79036bc4c54cfdc
DIST systemrescuecd-x86-5.2.0.iso 569669632 BLAKE2B fe31a68df650b46bd875b91c643c8f1daaa60042ea6c59ac452bb99a2792dcdcee62f1b60c329a70c95689af22c1a0fc52a966631af347258d665f55d2f6d8c0 SHA512 42da80a419aa27bea891339dc163a62bff8ba34d74c202a7fd0317592e8870a71ddc7fa9e9ded5e9d2f75dc36ec8417673074ffde60ea472815405456e34876c
DIST systemrescuecd-x86-5.2.1.iso 570523648 BLAKE2B 9bb6b2ff7b9930f658baddbf60ef89e86171febcfb48eb0a6ce1bfea8fd3348773a9da948370f9f310dd0e992c40aa64a4ef1442f5cd7f408f847d147074cf1f SHA512 6820f079c9e97ac0d383ed9096a120e7e31771e1d41465f4cf7f5db36a7cb83ccfaae5c5e561181c3b3cb169d4cc4a9a6904a707ecde06a6de4f2456d2a658e4
+DIST systemrescuecd-x86-5.2.2.iso 572006400 BLAKE2B 2cc95acc529ae8e0525664ffbdfefaf6e4513e8135fa6af120121b0b7930b0203bd17d5d70ccafacfe0064bb8615f45aa22b6e6e3fcee8a005a0315fd9b5cf62 SHA512 7dd1ccd63775e35f6589808416468c4a9314f4a7a5d0cb1f2bc34ffb9eef3a450b0da244dfc9e325d828c39404c0cdcce27cc990eade33762c17a1e32f8db9b5
diff --git a/app-admin/systemrescuecd-x86/systemrescuecd-x86-5.2.2.ebuild b/app-admin/systemrescuecd-x86/systemrescuecd-x86-5.2.2.ebuild
new file mode 100644
index 000000000000..7bfc35a7dd27
--- /dev/null
+++ b/app-admin/systemrescuecd-x86/systemrescuecd-x86-5.2.2.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="The .iso image of SystemRescueCD rescue disk, x86 (+ amd64) variant"
+HOMEPAGE="http://www.sysresccd.org/"
+# Large ISO mirroring explicitly approved by infra in bug #588766
+SRC_URI="mirror://sourceforge/systemrescuecd/sysresccd-${PN#*-}/${PV}/${P}.iso"
+
+LICENSE="GPL-2"
+SLOT="${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="+isohybrid"
+
+DEPEND="isohybrid? ( >=sys-boot/syslinux-4 )"
+
+S=${WORKDIR}
+
+src_install() {
+ insinto "/usr/share/${PN%-*}"
+ doins "${DISTDIR}/${P}.iso"
+
+ if use isohybrid; then
+ set -- isohybrid -u "${ED}usr/share/${PN%-*}/${P}.iso"
+ echo "${@}"
+ "${@}" || die "${*} failed"
+ fi
+}
+
+pkg_postinst() {
+ local f=${EROOT%/}/usr/share/${PN%-*}/${PN}-newest.iso
+
+ # no version newer than ours? we're the newest!
+ if ! has_version ">${CATEGORY}/${PF}"; then
+ ln -f -s -v "${P}.iso" "${f}" || die
+ fi
+}
+
+pkg_postrm() {
+ local f=${EROOT%/}/usr/share/${PN%-*}/${PN}-newest.iso
+
+ # if there is no version newer than ours installed
+ if ! has_version ">${CATEGORY}/${PF}"; then
+ # and we are truly and completely uninstalled...
+ if [[ ! ${REPLACED_BY_VERSION} ]]; then
+ # then find an older version to set the symlink to
+ local newest_version=$(best_version "<${CATEGORY}/${PF}")
+
+ if [[ ${newest_version} ]]; then
+ # update the symlink
+ ln -f -s -v "${newest_version%-r*}.iso" "${f}" || die
+ else
+ # last version removed? clean up the symlink
+ rm -v "${f}" || die
+ # and the parent directory
+ rmdir "${f%/*}" || die
+ fi
+ fi
+ fi
+}