summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-10-07 08:30:49 +0200
committerMichał Górny <mgorny@gentoo.org>2021-10-07 09:21:04 +0200
commitd785638d611450efe388534fb427c1ed883cc1a9 (patch)
tree96ae8dc8832e1db3b01ed383e5b1c7a6f890896a /app-admin
parentdev-python/boto3: Bump to 1.18.56 (diff)
downloadgentoo-d785638d611450efe388534fb427c1ed883cc1a9.tar.gz
gentoo-d785638d611450efe388534fb427c1ed883cc1a9.tar.bz2
gentoo-d785638d611450efe388534fb427c1ed883cc1a9.zip
app-admin/awscli: Bump to 1.20.56
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/awscli/Manifest1
-rw-r--r--app-admin/awscli/awscli-1.20.56.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/app-admin/awscli/Manifest b/app-admin/awscli/Manifest
index fec13123de7c..00ed0c8e4d34 100644
--- a/app-admin/awscli/Manifest
+++ b/app-admin/awscli/Manifest
@@ -4,3 +4,4 @@ DIST awscli-1.20.47.tar.gz 2079314 BLAKE2B 2c202ed3e3527a6881c3f9ca73e8639732442
DIST awscli-1.20.53.tar.gz 2081402 BLAKE2B 88d56df063ae6473122913e4713e17bfd8c32961477b8e723ed3c0c0b7dc72ccc4dfd8d897699e2060a2b65a198b96eccf77accdac9a21510aa56dba5423b76e SHA512 48576b535bdf6b9e6397eadd589c41eeec480d2eaf3035ca6e64bd86984aba9170a83b71c0f7f3f64cfaebaf5104fe3adcdaebace5166343fb3b772f5ad8ccfd
DIST awscli-1.20.54.tar.gz 2082080 BLAKE2B 157e35ab297d18aa9739319801e28fabfbd9f68a2ea6215052d11821f96e8df022fe45ba9b34cc9e62ca59186fd16aeda453813f7ad86f96d2b6e483f8fd89a1 SHA512 845e5746808bb40ff41b4a3280bce7787fa6278f3b9176c8ae1237b06d1c6ea01a132ab8b4134d369380823d758c16317a1985ca9f307d17824d2cad5c92858e
DIST awscli-1.20.55.tar.gz 2082482 BLAKE2B 5f8d9d84e6993e22ffd6f1e7e46b0afa2aecd12b4c2c18968e0f85d7544aced039a21b2245bfd66393bbb0d240f9b3119da7f745891b04f9156b677f613fbb63 SHA512 5d76c07417a3edcdff490ecdad9469f6f0f3077f4fccba9b6cf8518390df90d49d126e6c924a57333c5b68a97b833cb0bbb72133ddc63fd74893f888eca974a5
+DIST awscli-1.20.56.tar.gz 2082836 BLAKE2B e935334dba5aaa77cbd4fe3adb789c33c9fa80832bf4ad7517024787911e377020e8cdc38b0bd87db81571a2da888acd96306198a66748597495460292286938 SHA512 5b3bfebe217c05df70421b29c6a239a76493898717bd5db10ef7001e6c9af1488a52e6e25ab85b5ed725c87402a562ebe6849eb39743681c644143f17fccc3b6
diff --git a/app-admin/awscli/awscli-1.20.56.ebuild b/app-admin/awscli/awscli-1.20.56.ebuild
new file mode 100644
index 000000000000..81d5997098c2
--- /dev/null
+++ b/app-admin/awscli/awscli-1.20.56.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit bash-completion-r1 distutils-r1
+
+DESCRIPTION="Universal Command Line Environment for AWS"
+HOMEPAGE="https://pypi.org/project/awscli/"
+#SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+SRC_URI="https://github.com/aws/aws-cli/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/aws-cli-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+# botocore is x.(y+1).z
+BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 1)).$(ver_cut 3-)"
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/rsa[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.4.0[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests --install pytest
+
+python_test() {
+ distutils_install_for_testing
+ # integration tests require AWS credentials and Internet access
+ epytest tests/{functional,unit}
+}
+
+python_install_all() {
+ newbashcomp bin/aws_bash_completer aws
+
+ insinto /usr/share/zsh/site-functions
+ newins bin/aws_zsh_completer.sh _aws
+
+ distutils-r1_python_install_all
+
+ rm "${ED}"/usr/bin/{aws.cmd,aws_bash_completer,aws_zsh_completer.sh} || die
+}