summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-05-15 22:45:01 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2021-05-15 23:49:18 +0200
commitddfc9955724025a1544e942bc146d70c7a0c971d (patch)
tree08cced727bbdb679a501e99fa87bd47eb58f5584 /app-admin
parentdev-ml/opam: Drop 1.3.1-r2, EAPI5-- (diff)
downloadgentoo-ddfc9955724025a1544e942bc146d70c7a0c971d.tar.gz
gentoo-ddfc9955724025a1544e942bc146d70c7a0c971d.tar.bz2
gentoo-ddfc9955724025a1544e942bc146d70c7a0c971d.zip
profiles: Cleanup last-rited packages
kde-misc/kolor-manager app-admin/elektra media-gfx/icc-examin media-gfx/synnefo media-libs/libXcm media-libs/openicc media-libs/oyranos Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/elektra/Manifest1
-rw-r--r--app-admin/elektra/elektra-0.8.20-r1.ebuild114
-rw-r--r--app-admin/elektra/metadata.xml12
3 files changed, 0 insertions, 127 deletions
diff --git a/app-admin/elektra/Manifest b/app-admin/elektra/Manifest
deleted file mode 100644
index 98112946bd87..000000000000
--- a/app-admin/elektra/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST elektra-0.8.20.tar.gz 4740032 BLAKE2B e76ad93eadbbec9bb273da4f7bab5622d47deebdab6736c430543159c0754f3b96696954891962b60716d5b969e64bf5ef6886a6239abee8b98888aae09fcdd9 SHA512 11cc88329f84ad4d6337132d76479d26f2d9c12f7a939558a79ea96540129096ea0a26ffda3705c01a2c7c749453588bb1654a4c07cca3374e4076ce768c5848
diff --git a/app-admin/elektra/elektra-0.8.20-r1.ebuild b/app-admin/elektra/elektra-0.8.20-r1.ebuild
deleted file mode 100644
index ccb2065bb7c2..000000000000
--- a/app-admin/elektra/elektra-0.8.20-r1.ebuild
+++ /dev/null
@@ -1,114 +0,0 @@
-# Copyright 1999-2018 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit cmake-utils
-
-DESCRIPTION="Framework to store config parameters in hierarchical key-value pairs"
-HOMEPAGE="https://www.libelektra.org"
-SRC_URI="https://www.libelektra.org/ftp/elektra/releases/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0/${PV}"
-KEYWORDS="~amd64 ~x86"
-PLUGIN_IUSE="augeas iconv ini simpleini syslog systemd tcl +uname xml yajl";
-IUSE="dbus doc static-libs test ${PLUGIN_IUSE}"
-
-RDEPEND="
- dev-libs/libltdl:0
- >=dev-libs/libxml2-2.9.1-r4
- augeas? ( app-admin/augeas )
- dbus? ( >=sys-apps/dbus-1.6.18-r1 )
- iconv? ( >=virtual/libiconv-0-r1 )
- systemd? ( sys-apps/systemd )
- uname? ( sys-apps/coreutils )
- yajl? ( >=dev-libs/yajl-1.0.11-r1 )
-"
-# qt5? (
-# app-text/discount
-# dev-qt/qtdeclarative:5
-# dev-qt/qtgui:5
-# dev-qt/qttest:5
-# dev-qt/qtwidgets:5
-# )
-DEPEND="${RDEPEND}
- doc? ( app-doc/doxygen )
- test? ( >=dev-cpp/gtest-1.7.0 )
-"
-
-DOCS=( README.md doc/AUTHORS doc/CODING.md doc/todo/TODO )
-# tries to write to user's home directory (and doesn't respect HOME)
-RESTRICT="test"
-
-src_prepare() {
- cmake-utils_src_prepare
-
- einfo remove bundled libs
- # TODO: Remove bundled inih from src/plugins/ini (add to portage):
- # https://code.google.com/p/inih/
- rm -rf src/external || die
-
- # move doc files to correct location
- sed -e "s/elektra-api/${PF}/" -i cmake/ElektraCache.cmake || die
- sed -e "/^install.*LICENSE/s/^/#DONT /" -i CMakeLists.txt || die
-
- # avoid useless build time, nothing ends up installed
- cmake_comment_add_subdirectory benchmarks
- cmake_comment_add_subdirectory examples
-}
-
-src_configure() {
- # default storage and resolver requirements
- local my_plugins="NONE;dump;resolver;resolver_fm_hpu_b;sync;"
- # defaults chosen by availability in 0.8.16
- my_plugins+="ccode;conditionals;constants;enum;error;filecheck;fstab;glob;"
- my_plugins+="hexcode;hidden;hosts;iterate;keytometa;line;lineendings;list;"
- my_plugins+="logchange;mathcheck;network;ni;null;path;profile;regexstore;"
- my_plugins+="rename;semlock;shell;spec;struct;timeofday;tracer;type;validation;"
-
- use augeas && my_plugins+="augeas;"
- use dbus && my_plugins+="dbus;"
- use iconv && my_plugins+="iconv;"
- use ini && my_plugins+="ini;" # bundles inih
- use simpleini && my_plugins+="simpleini;"
- use syslog && my_plugins+="syslog;"
- use systemd && my_plugins+="journald;"
- use tcl && my_plugins+="tcl;"
- use uname && my_plugins+="uname;"
- use xml && my_plugins+="xmltool;"
- use yajl && my_plugins+="yajl;"
-
- # Disabling for good (?):
- # counter - Only useful for debugging the plugin framework
- # doc - Explaining basic makeup of a function //bug #514402
- # noresolver - Does not resolve, but can act as one
- # template - Template for new plugin written in C
- # wresolver - Resolver for non-POSIX, e.g. w32/w64 systems
- # my_plugins+=";-counter;-doc;-noresolver;-template;-wresolver"
-
- local my_tools="kdb"
-# use qt5 && my_tools+=";qt-gui"
-
- local mycmakeargs=(
- -DBUILD_PDF=OFF
- -DBUILD_SHARED=ON
- -DBUILD_STATIC=$(usex static-libs)
- -DBUILD_TESTING=$(usex test)
- -DENABLE_TESTING=$(usex test)
- -DPLUGINS=${my_plugins}
- -DTOOLS=${my_tools}
- -DBUILD_DOCUMENTATION=$(usex doc)
- -DTARGET_CMAKE_FOLDER=share/cmake/Modules
- )
-
- cmake-utils_src_configure
-}
-
-src_install() {
- cmake-utils_src_install
- einfo remove test_data
- rm -rvf "${ED%/}/usr/share/${PN}" || die "Failed to remove test_data"
- einfo remove tool_exec
- rm -rvf "${ED%/}/usr/$(get_libdir)/${PN}/tool_exec" || die "Failed to remove tool_exec"
-}
diff --git a/app-admin/elektra/metadata.xml b/app-admin/elektra/metadata.xml
deleted file mode 100644
index 6f5f3e3ebc04..000000000000
--- a/app-admin/elektra/metadata.xml
+++ /dev/null
@@ -1,12 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <!-- maintainer-needed -->
- <use>
- <flag name="augeas">Enable plugin for reading and writing configuration files with help from Augeas</flag>
- <flag name="ini">Enable new, advanced ini support</flag>
- <flag name="simpleini">Enable simpleini support</flag>
- <flag name="uname">Enable uname information for the key database</flag>
- <flag name="yajl">Enable yajl support</flag>
- </use>
-</pkgmetadata>