summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2018-02-19 10:56:15 +0100
committerHans de Graaff <graaff@gentoo.org>2018-02-19 10:56:15 +0100
commitf668591b65d1c01f8849f33670b4d14f3087f094 (patch)
tree6fcd67814a5f54d16bbaa319bb0f1d31374159dd /app-admin
parentapp-editors/emacs: Drop old elog message. (diff)
downloadgentoo-f668591b65d1c01f8849f33670b4d14f3087f094.tar.gz
gentoo-f668591b65d1c01f8849f33670b4d14f3087f094.tar.bz2
gentoo-f668591b65d1c01f8849f33670b4d14f3087f094.zip
app-admin/puppet: drop webrick patch for newer rubies
This issue is fixed in 4.10.10 in a more complete way, and the old fix, which does not clash with the new fixes, now breaks things. Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/puppet/puppet-4.10.10-r1.ebuild (renamed from app-admin/puppet/puppet-4.10.10.ebuild)3
1 files changed, 0 insertions, 3 deletions
diff --git a/app-admin/puppet/puppet-4.10.10.ebuild b/app-admin/puppet/puppet-4.10.10-r1.ebuild
index c404e787afc..a75388c365f 100644
--- a/app-admin/puppet/puppet-4.10.10.ebuild
+++ b/app-admin/puppet/puppet-4.10.10-r1.ebuild
@@ -79,9 +79,6 @@ all_ruby_prepare() {
epatch "${FILESDIR}/43e2c935252b995134ce353e5e6312cf77aea480.patch"
fi
- # fix compatibility with ruby 2.3.6/2.4.3 webrick
- epatch "${FILESDIR}/puppet-4-webrick-ruby.patch"
-
# Use working version of mocha
sed -i -e '1igem "mocha", "~>0.14.0"; gem "rack", "~>1.0"' spec/spec_helper.rb || die