summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam Jorna <wraeth@gentoo.org>2016-04-30 23:53:20 +1000
committerSam Jorna <wraeth@gentoo.org>2016-05-01 00:34:05 +1000
commitfe63884b4355094e5c69514f0e36b311d3aa873f (patch)
tree16b830616fda5409a33b21e9a18c57de835add58 /app-admin
parentdev-util/bats: new package (diff)
downloadgentoo-fe63884b4355094e5c69514f0e36b311d3aa873f.tar.gz
gentoo-fe63884b4355094e5c69514f0e36b311d3aa873f.tar.bz2
gentoo-fe63884b4355094e5c69514f0e36b311d3aa873f.zip
app-admin/yadm: new package
yadm is a dotfile manager that handles the hassle of synchronizing the dotfiles in your home folder across different workstations. It has a philosophy using git and getting out of git's way to ensure it does what it does best. Maintainer assigned to Espen H per request under Proxy Maintainers. Gentoo-bug: 581118 Package-Manager: portage-2.2.28
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/yadm/Manifest1
-rw-r--r--app-admin/yadm/metadata.xml26
-rw-r--r--app-admin/yadm/yadm-1.04.ebuild37
3 files changed, 64 insertions, 0 deletions
diff --git a/app-admin/yadm/Manifest b/app-admin/yadm/Manifest
new file mode 100644
index 000000000000..227ed5581169
--- /dev/null
+++ b/app-admin/yadm/Manifest
@@ -0,0 +1 @@
+DIST yadm-1.04.tar.gz 27391 SHA256 a73aa51245866ce67aeb4322a62995ebbb13f29dc35508f486819dceb534968a SHA512 f3f909118f29382c6cbae565de336c27fd7d159955a231ac22b0d25e25e50c4c3e1bdc68b1629920904ad9353ee8ce8f7e5c5e50d289984447815a685a4132c9 WHIRLPOOL c74c2bfc89abb6955bb4e0d60b1cb0777c9f9ec43bc1919c130cd8470e44c090fba9003e473f4344ed92df23e399ea45ece6dafde80d575a8af491bb4c16b554
diff --git a/app-admin/yadm/metadata.xml b/app-admin/yadm/metadata.xml
new file mode 100644
index 000000000000..a5fe84884c09
--- /dev/null
+++ b/app-admin/yadm/metadata.xml
@@ -0,0 +1,26 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>dev+gentoobugzilla@henriksen.is</email>
+ <name>Espen H</name>
+ <description>Proxy maintainer - set to assignee on bugs</description>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">TheLocehiliosan/yadm</remote-id>
+ </upstream>
+ <longdescription lang="en">
+ yadm is a dotfile manager that handles the hassle of synchronizing the
+ dotfiles in your home folder across different workstations. It has a
+ philosophy using git and getting out of git's way to ensure it does what it
+ does best. What sets it apart is that it supports encryption, which enables
+ you to add files like mutt configuration with passwords and host it
+ publicly. It also enables you to add suffixes to your files like
+ ##Linux.hostname, and yadm will automatically symlink the file if you are
+ on that hostname.
+ </longdescription>
+</pkgmetadata>
diff --git a/app-admin/yadm/yadm-1.04.ebuild b/app-admin/yadm/yadm-1.04.ebuild
new file mode 100644
index 000000000000..661af4e8814a
--- /dev/null
+++ b/app-admin/yadm/yadm-1.04.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DESCRIPTION="A dotfile manager for the config files in your home folder"
+HOMEPAGE="https://github.com/TheLocehiliosan/yadm/"
+SRC_URI="https://github.com/TheLocehiliosan/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DOCS=( CHANGES CONTRIBUTORS README.md )
+
+DEPEND="
+ test? (
+ dev-util/bats
+ dev-vcs/git
+ )"
+RDEPEND="dev-vcs/git
+ app-crypt/gnupg"
+
+src_test() {
+ # 109_accept_encryption tests are interactive, thus fail. Skip them
+ bats $(find test/ -type f -name '*.bats' -and -not -name '109_accept_encryption.bats') \
+ || die "Tests failed"
+}
+
+src_install() {
+ einstalldocs
+
+ dobin yadm
+ doman yadm.1
+}