summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2018-12-29 10:46:34 -0500
committerAnthony G. Basile <blueness@gentoo.org>2018-12-29 10:46:34 -0500
commit932704acba7b24776b8ed877b6d79eeb92e2f9f4 (patch)
treee5765f26ff8bf5aea317d18a19d332eaa8720b86 /app-antivirus/clamav
parentsys-libs/queue-standalone: initial commit (diff)
downloadgentoo-932704acba7b24776b8ed877b6d79eeb92e2f9f4.tar.gz
gentoo-932704acba7b24776b8ed877b6d79eeb92e2f9f4.tar.bz2
gentoo-932704acba7b24776b8ed877b6d79eeb92e2f9f4.zip
app-antivirus/clamav: add support for musl
Signed-off-by: Anthony G. Basile <blueness@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Diffstat (limited to 'app-antivirus/clamav')
-rw-r--r--app-antivirus/clamav/clamav-0.100.1-r1.ebuild2
-rw-r--r--app-antivirus/clamav/clamav-0.100.2.ebuild2
-rw-r--r--app-antivirus/clamav/clamav-0.101.0.ebuild2
3 files changed, 6 insertions, 0 deletions
diff --git a/app-antivirus/clamav/clamav-0.100.1-r1.ebuild b/app-antivirus/clamav/clamav-0.100.1-r1.ebuild
index c8f5513c563c..f86c5fdd38d6 100644
--- a/app-antivirus/clamav/clamav-0.100.1-r1.ebuild
+++ b/app-antivirus/clamav/clamav-0.100.1-r1.ebuild
@@ -25,6 +25,7 @@ CDEPEND="bzip2? ( app-arch/bzip2 )
sys-devel/libtool
|| ( dev-libs/libpcre2 >dev-libs/libpcre-6 )
system-libmspack? ( dev-libs/libmspack )
+ elibc_musl? ( sys-libs/fts-standalone )
!!<app-antivirus/clamav-0.99"
# hard block clamav < 0.99 due to linking problems Bug #567680
# openssl is now *required* see this link as to why
@@ -54,6 +55,7 @@ src_prepare() {
}
src_configure() {
+ use elibc_musl && append-ldflags -lfts
use ppc64 && append-flags -mminimal-toc
use uclibc && export ac_cv_type_error_t=yes
diff --git a/app-antivirus/clamav/clamav-0.100.2.ebuild b/app-antivirus/clamav/clamav-0.100.2.ebuild
index aa24c3f02f14..fd98bc0029f3 100644
--- a/app-antivirus/clamav/clamav-0.100.2.ebuild
+++ b/app-antivirus/clamav/clamav-0.100.2.ebuild
@@ -26,6 +26,7 @@ CDEPEND="bzip2? ( app-arch/bzip2 )
|| ( dev-libs/libpcre2 >dev-libs/libpcre-6 )
dev-libs/libmspack
xml? ( dev-libs/libxml2 )
+ elibc_musl? ( sys-libs/fts-standalone )
!!<app-antivirus/clamav-0.99"
# hard block clamav < 0.99 due to linking problems Bug #567680
# openssl is now *required* see this link as to why
@@ -55,6 +56,7 @@ src_prepare() {
}
src_configure() {
+ use elibc_musl && append-ldflags -lfts
use ppc64 && append-flags -mminimal-toc
use uclibc && export ac_cv_type_error_t=yes
diff --git a/app-antivirus/clamav/clamav-0.101.0.ebuild b/app-antivirus/clamav/clamav-0.101.0.ebuild
index ac686da8a562..5f65942960da 100644
--- a/app-antivirus/clamav/clamav-0.101.0.ebuild
+++ b/app-antivirus/clamav/clamav-0.101.0.ebuild
@@ -26,6 +26,7 @@ CDEPEND="bzip2? ( app-arch/bzip2 )
|| ( dev-libs/libpcre2 >dev-libs/libpcre-6 )
dev-libs/libmspack
xml? ( dev-libs/libxml2 )
+ elibc_musl? ( sys-libs/fts-standalone )
!!<app-antivirus/clamav-0.99"
# hard block clamav < 0.99 due to linking problems Bug #567680
# openssl is now *required* see this link as to why
@@ -55,6 +56,7 @@ pkg_setup() {
#}
src_configure() {
+ use elibc_musl && append-ldflags -lfts
use ppc64 && append-flags -mminimal-toc
use uclibc && export ac_cv_type_error_t=yes