summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2019-07-31 14:02:32 +0200
committerLars Wendler <polynomial-c@gentoo.org>2019-07-31 14:07:20 +0200
commit23f936685079e75931b026d5dcdb2e18015daf71 (patch)
tree89988fdd214ea909a9ed369e00af39d0a5bcb8be /app-antivirus
parentdev-util/cmake: amd64 stable wrt bug #691114 (diff)
downloadgentoo-23f936685079e75931b026d5dcdb2e18015daf71.tar.gz
gentoo-23f936685079e75931b026d5dcdb2e18015daf71.tar.bz2
gentoo-23f936685079e75931b026d5dcdb2e18015daf71.zip
app-antivirus/clamav: Revbump to remove automagic dep on dev-libs/icu
Fixed without excplicit permission due to maintainer timeout. Bug: https://bugs.gentoo.org/661328 Package-Manager: Portage-2.3.69, Repoman-2.3.16 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'app-antivirus')
-rw-r--r--app-antivirus/clamav/clamav-0.101.2-r1.ebuild (renamed from app-antivirus/clamav/clamav-0.101.2.ebuild)15
-rw-r--r--app-antivirus/clamav/files/clamav-0.101.2-libxml2_pkgconfig.patch78
2 files changed, 85 insertions, 8 deletions
diff --git a/app-antivirus/clamav/clamav-0.101.2.ebuild b/app-antivirus/clamav/clamav-0.101.2-r1.ebuild
index 165eaec43722..986cc1711ae1 100644
--- a/app-antivirus/clamav/clamav-0.101.2.ebuild
+++ b/app-antivirus/clamav/clamav-0.101.2-r1.ebuild
@@ -40,20 +40,19 @@ RDEPEND="${CDEPEND}
DOCS=( docs/UserManual.md docs/UserManual )
HTML_DOCS=( docs/html )
-#PATCHES=(
-# "${FILESDIR}/clamav-0.100.0_autotools.patch"
-#)
+PATCHES=(
+ "${FILESDIR}/clamav-0.101.2-libxml2_pkgconfig.patch" #661328
+)
pkg_setup() {
enewgroup clamav
enewuser clamav -1 -1 /dev/null clamav
}
-#src_prepare() {
-# default
-#
-# eautoconf
-#}
+src_prepare() {
+ default
+ eautoconf
+}
src_configure() {
use elibc_musl && append-ldflags -lfts
diff --git a/app-antivirus/clamav/files/clamav-0.101.2-libxml2_pkgconfig.patch b/app-antivirus/clamav/files/clamav-0.101.2-libxml2_pkgconfig.patch
new file mode 100644
index 000000000000..e1f5bb9b338a
--- /dev/null
+++ b/app-antivirus/clamav/files/clamav-0.101.2-libxml2_pkgconfig.patch
@@ -0,0 +1,78 @@
+https://bugs.gentoo.org/661328
+
+--- clamav-0.101.2/m4/reorganization/libs/xml.m4
++++ clamav-0.101.2/m4/reorganization/libs/xml.m4
+@@ -4,55 +4,19 @@
+ [AS_HELP_STRING([--disable-xml], [do not include DMG and XAR support])],
+ want_xml=$enableval, want_xml="auto")
+
+-XML_HOME=""
+-if test "X$want_xml" != "Xno"; then
+- AC_MSG_CHECKING([for libxml2 installation])
+- AC_ARG_WITH([xml],
+- AS_HELP_STRING([--with-xml@<:@=DIR@:>@], [path to directory containing libxml2 library
+- @<:@default=/usr/local or /usr if not found in /usr/local@:>@]),
+- [with_xml_val=$withval]
+- )
+-fi
+-
+-AS_IF([test "x$with_xml_val" = "xno"], [XML_HOME=""],
+- [test "x$with_xml_val" = "xyes"], [XML_HOME="/usr/local"],
+- [XML_HOME="$with_xml_val"])
+-
+-AS_IF([test "x$XML_HOME" != "x"], [
+- AS_IF([test ! -x "$XML_HOME/bin/xml2-config"], [XML_HOME=""])
+- ])
+-
+-AS_IF([test "x$XML_HOME" = "x" -a "x$with_xml_val" = "xyes"], [
+- AS_IF([test -x "/usr/bin/xml2-config"], [XML_HOME="/usr"])
+- ])
+-
+-if test "x$XML_HOME" != "x"; then
+- AC_MSG_RESULT([$XML_HOME])
+-else
+- AC_MSG_RESULT([not found])
+-fi
+-
+-found_xml="no"
+-XMLCONF_VERSION=""
+-XML_CPPFLAGS=""
+-XML_LIBS=""
+-if test "x$XML_HOME" != "x"; then
+- AC_MSG_CHECKING([xml2-config version])
+- XMLCONF_VERSION="`$XML_HOME/bin/xml2-config --version`"
+- if test "x%XMLCONF_VERSION" != "x"; then
+- AC_MSG_RESULT([$XMLCONF_VERSION])
+- found_xml="yes"
+- XML_CPPFLAGS="`$XML_HOME/bin/xml2-config --cflags`"
+- XML_LIBS="`$XML_HOME/bin/xml2-config --libs`"
+- AS_ECHO("$XML_CPPFLAGS")
+- AS_ECHO("$XML_LIBS")
+- else
+- AC_MSG_ERROR([xml2-config failed])
+- fi
+-fi
++PKG_CHECK_MODULES([XML], [libxml-2.0],
++ [found_xml=yes],
++ [
++ found_xml=no
++ AS_IF([test "x$want_xml" = xyes],
++ [AC_MSG_ERROR([--enable-xml set but cannot find libxml2])]
++ )
++ ]
++)
+
+ working_xml="no"
+ if test "X$found_xml" != "Xno"; then
++ XML_HOME=$(${PKG_CONFIG} --variable prefix libxml-2.0)
+ AC_MSG_CHECKING([for xmlreader.h in $XML_HOME])
+
+ if test ! -f "$XML_HOME/include/libxml2/libxml/xmlreader.h"; then
+@@ -61,6 +25,7 @@
+ AC_MSG_RESULT([found])
+ save_LIBS="$LIBS"
+ save_CPPFLAGS="$CPPFLAGS"
++ XML_CPPFLAGS="$XML_CFLAGS"
+ CPPFLAGS="$CPPFLAGS $XML_CPPFLAGS"
+ save_LDFLAGS="$LDFLAGS"
+ LDFLAGS="$LDFLAGS $XML_LIBS"