summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2018-05-23 14:38:55 +0200
committerPatrice Clement <monsieurp@gentoo.org>2018-05-23 14:40:06 +0200
commit1a7acfd7f96271609e2c6df77097da4d2f796401 (patch)
treecbc8b1f009f9864c3c80f74b38e8aa5bed0919a3 /app-arch/alien/alien-8.95-r1.ebuild
parentapp-office/libreoffice: 5.4.7.2 bump, just for arm64, drop USE=kde (diff)
downloadgentoo-1a7acfd7f96271609e2c6df77097da4d2f796401.tar.gz
gentoo-1a7acfd7f96271609e2c6df77097da4d2f796401.tar.bz2
gentoo-1a7acfd7f96271609e2c6df77097da4d2f796401.zip
app-arch/alien: add support for more tar extensions.
Courtesy of Austin English <wizardedit@gentoo.org>. I've also slipped in a EAPI 6 update whilst at it. Closes: https://bugs.gentoo.org/629524 Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'app-arch/alien/alien-8.95-r1.ebuild')
-rw-r--r--app-arch/alien/alien-8.95-r1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/app-arch/alien/alien-8.95-r1.ebuild b/app-arch/alien/alien-8.95-r1.ebuild
new file mode 100644
index 000000000000..c088b5dc1813
--- /dev/null
+++ b/app-arch/alien/alien-8.95-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit perl-module
+
+DESCRIPTION="Converts between the rpm, dpkg, stampede slp, and slackware tgz file formats"
+HOMEPAGE="http://kitenet.net/programs/alien"
+SRC_URI="mirror://debian/pool/main/a/${PN}/${PN}_${PV}.tar.xz -> ${P}.tar.xz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~x86"
+IUSE="+bzip2"
+
+RDEPEND="
+ app-arch/rpm
+ app-arch/dpkg
+ dev-util/debhelper
+ >=app-arch/tar-1.14.91
+ bzip2? (
+ app-arch/bzip2
+ )"
+
+DEPEND="${RDEPEND}"
+
+PATCHES=( "${FILESDIR}/${P}-tar-extensions.patch" )
+
+src_prepare() {
+ default
+ sed -e s%'$(VARPREFIX)'%${D}% -e s%'$(PREFIX)'%${D}/usr%g \
+ -i "${S}"/Makefile.PL || die "sed failed"
+}