summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSébastien Fabbro <bicatali@gentoo.org>2017-07-29 18:46:47 +0000
committerSébastien Fabbro <bicatali@gentoo.org>2017-07-31 18:11:45 +0000
commitd8d4a949b4d145d328b6a0faaf2cc1694c306912 (patch)
tree7eaac7bb22b0a9cf4b26459ae3264c459b84e1b6 /app-arch/brotli/brotli-0.6.0.ebuild
parentdev-python/python-lzo: version bump (diff)
downloadgentoo-d8d4a949b4d145d328b6a0faaf2cc1694c306912.tar.gz
gentoo-d8d4a949b4d145d328b6a0faaf2cc1694c306912.tar.bz2
gentoo-d8d4a949b4d145d328b6a0faaf2cc1694c306912.zip
app-arch/brotli: initial import
Package-Manager: Portage-2.3.6, Repoman-2.3.3
Diffstat (limited to 'app-arch/brotli/brotli-0.6.0.ebuild')
-rw-r--r--app-arch/brotli/brotli-0.6.0.ebuild61
1 files changed, 61 insertions, 0 deletions
diff --git a/app-arch/brotli/brotli-0.6.0.ebuild b/app-arch/brotli/brotli-0.6.0.ebuild
new file mode 100644
index 000000000000..91daf8320a8c
--- /dev/null
+++ b/app-arch/brotli/brotli-0.6.0.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy )
+DISTUTILS_OPTIONAL="1"
+
+inherit cmake-utils distutils-r1
+
+DESCRIPTION="Generic-purpose lossless compression algorithm"
+HOMEPAGE="https://github.com/google/brotli"
+SRC_URI="https://github.com/google/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="python? ( ${PYTHON_DEPS} )"
+DEPEND="${RDEPEND}"
+
+IUSE="python test"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+LICENSE="MIT python? ( Apache-2.0 )"
+
+DOCS=( README.md CONTRIBUTING.md )
+
+PATCHES=( "${FILESDIR}"/${P}-no-rpath.patch )
+
+src_prepare() {
+ cmake-utils_src_prepare
+ use python && distutils-r1_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_SHARED_LIBS=ON
+ -DBUILD_TESTING="$(usex test)"
+ )
+ cmake-utils_src_configure
+ use python && distutils-r1_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+ use python && distutils-r1_src_compile
+}
+
+python_test(){
+ esetup.py test || die
+}
+
+src_test() {
+ cmake-utils_src_test
+ use python && distutils-r1_src_test
+}
+
+src_install() {
+ cmake-utils_src_install
+ use python && distutils-r1_src_install
+}