summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2021-05-05 09:58:22 -0400
committerCraig Andrews <candrews@gentoo.org>2021-05-05 09:58:22 -0400
commita7166b7b1066616e78e15d161b8539466e368081 (patch)
tree3a7d11c2d4d3407748bf550459511f2fb90f1420 /app-arch/brotli
parentnet-p2p/xmr-stak-rx: remove last-rited package (diff)
downloadgentoo-a7166b7b1066616e78e15d161b8539466e368081.tar.gz
gentoo-a7166b7b1066616e78e15d161b8539466e368081.tar.bz2
gentoo-a7166b7b1066616e78e15d161b8539466e368081.zip
app-arch/brotli: Switch to CMAKE_ECLASS=cmake
Closes: https://bugs.gentoo.org/770565 Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'app-arch/brotli')
-rw-r--r--app-arch/brotli/brotli-1.0.9-r3.ebuild86
-rw-r--r--app-arch/brotli/brotli-9999.ebuild11
2 files changed, 92 insertions, 5 deletions
diff --git a/app-arch/brotli/brotli-1.0.9-r3.ebuild b/app-arch/brotli/brotli-1.0.9-r3.ebuild
new file mode 100644
index 000000000000..9a372fb31664
--- /dev/null
+++ b/app-arch/brotli/brotli-1.0.9-r3.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9} )
+DISTUTILS_OPTIONAL="1"
+DISTUTILS_IN_SOURCE_BUILD="1"
+CMAKE_ECLASS=cmake
+
+inherit cmake-multilib distutils-r1
+
+DESCRIPTION="Generic-purpose lossless compression algorithm"
+HOMEPAGE="https://github.com/google/brotli"
+
+SLOT="0/$(ver_cut 1)"
+
+RDEPEND="python? ( ${PYTHON_DEPS} )"
+DEPEND="${RDEPEND}"
+
+IUSE="python static-libs test"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+LICENSE="MIT python? ( Apache-2.0 )"
+
+DOCS=( README.md CONTRIBUTING.md )
+
+if [[ ${PV} == "9999" ]] ; then
+ SRC_URI=""
+ EGIT_REPO_URI="https://github.com/google/${PN}.git"
+ inherit git-r3
+else
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x64-solaris"
+ SRC_URI="https://github.com/google/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+fi
+
+# tests are currently broken, see https://github.com/google/brotli/issues/850
+RESTRICT="test"
+
+PATCHES=(
+ "${FILESDIR}/${PV}-linker.patch"
+)
+
+src_prepare() {
+ use python && distutils-r1_src_prepare
+ cmake_src_prepare
+}
+
+multilib_src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TESTING="$(usex test)"
+ )
+ cmake_src_configure
+}
+src_configure() {
+ cmake-multilib_src_configure
+ use python && distutils-r1_src_configure
+}
+
+multilib_src_compile() {
+ cmake_src_compile
+}
+src_compile() {
+ cmake-multilib_src_compile
+ use python && distutils-r1_src_compile
+}
+
+python_test() {
+ esetup.py test || die
+}
+
+multilib_src_test() {
+ cmake_src_test
+}
+src_test() {
+ cmake-multilib_src_test
+ use python && distutils-r1_src_test
+}
+
+multilib_src_install() {
+ cmake_src_install
+ use static-libs || rm "${ED}"/usr/$(get_libdir)/*.a || die
+}
+multilib_src_install_all() {
+ use python && distutils-r1_src_install
+}
diff --git a/app-arch/brotli/brotli-9999.ebuild b/app-arch/brotli/brotli-9999.ebuild
index 87affbe108c9..7dacb49548c2 100644
--- a/app-arch/brotli/brotli-9999.ebuild
+++ b/app-arch/brotli/brotli-9999.ebuild
@@ -6,6 +6,7 @@ EAPI=7
PYTHON_COMPAT=( python3_{7,8,9} )
DISTUTILS_OPTIONAL="1"
DISTUTILS_IN_SOURCE_BUILD="1"
+CMAKE_ECLASS=cmake
inherit cmake-multilib distutils-r1
@@ -37,14 +38,14 @@ RESTRICT="!test? ( test )"
src_prepare() {
use python && distutils-r1_src_prepare
- cmake-utils_src_prepare
+ cmake_src_prepare
}
multilib_src_configure() {
local mycmakeargs=(
-DBUILD_TESTING="$(usex test)"
)
- cmake-utils_src_configure
+ cmake_src_configure
}
src_configure() {
cmake-multilib_src_configure
@@ -52,7 +53,7 @@ src_configure() {
}
multilib_src_compile() {
- cmake-utils_src_compile
+ cmake_src_compile
}
src_compile() {
cmake-multilib_src_compile
@@ -64,7 +65,7 @@ python_test() {
}
multilib_src_test() {
- cmake-utils_src_test
+ cmake_src_test
}
src_test() {
cmake-multilib_src_test
@@ -72,7 +73,7 @@ src_test() {
}
multilib_src_install() {
- cmake-utils_src_install
+ cmake_src_install
use static-libs || rm "${ED}"/usr/$(get_libdir)/*.a || die
}
multilib_src_install_all() {