summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlon Bar-Lev <alonbl@gentoo.org>2016-06-11 14:35:50 +0300
committerAlon Bar-Lev <alonbl@gentoo.org>2016-06-11 14:35:50 +0300
commit051b5a43c0f1dc76674d0cab4fd0016c0cea7db4 (patch)
tree4b40c2a20cf523cd2a4b60acec205123c7f2b4bd /app-arch/deltarpm/deltarpm-3.6_pre20110223-r2.ebuild
parentapp-arch/deltarpm: version bump (diff)
downloadgentoo-051b5a43c0f1dc76674d0cab4fd0016c0cea7db4.tar.gz
gentoo-051b5a43c0f1dc76674d0cab4fd0016c0cea7db4.tar.bz2
gentoo-051b5a43c0f1dc76674d0cab4fd0016c0cea7db4.zip
app-arch/deltarpm: cleanup
Package-Manager: portage-2.2.28
Diffstat (limited to 'app-arch/deltarpm/deltarpm-3.6_pre20110223-r2.ebuild')
-rw-r--r--app-arch/deltarpm/deltarpm-3.6_pre20110223-r2.ebuild58
1 files changed, 0 insertions, 58 deletions
diff --git a/app-arch/deltarpm/deltarpm-3.6_pre20110223-r2.ebuild b/app-arch/deltarpm/deltarpm-3.6_pre20110223-r2.ebuild
deleted file mode 100644
index 534a55330dc0..000000000000
--- a/app-arch/deltarpm/deltarpm-3.6_pre20110223-r2.ebuild
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 )
-
-inherit eutils toolchain-funcs python-single-r1
-
-SNAPSHOT="20110223"
-
-DESCRIPTION="tools to create and apply deltarpms"
-HOMEPAGE="http://gitorious.org/deltarpm/deltarpm"
-SRC_URI="http://pkgs.fedoraproject.org/repo/pkgs/${PN}/${PN}-git-${SNAPSHOT}.tar.bz2/70f8884be63614ca7c3fc888cf20ebc8/${PN}-git-${SNAPSHOT}.tar.bz2"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="python"
-
-RDEPEND="sys-libs/zlib
- app-arch/xz-utils
- app-arch/bzip2
- <app-arch/rpm-5
- python? ( ${PYTHON_DEPS} )"
-DEPEND=${RDEPEND}
-
-REQUIRED_USE=${PYTHON_REQUIRED_USE}
-
-S="${WORKDIR}/${PN}-git-${SNAPSHOT}"
-
-pkg_setup() {
- use python && python-single-r1_pkg_setup
-}
-
-src_prepare() {
- # disable implicit python3 use, #568094
- sed -i \
- -e '/^prefix/s:/local::' \
- -e '/^mandir/s:/man:/share/man:' \
- -e '/for/s:python3::' \
- Makefile || die
- epatch "${FILESDIR}/3.6_pre20110223-build.patch"
-}
-
-src_compile() {
- emake -j1 CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" CC="$(tc-getCC)"
-
- if use python; then
- emake CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" CC="$(tc-getCC)" python
- fi
-}
-
-src_install() {
- default
- python_optimize
-}