summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2016-05-08 11:30:21 +0200
committerJeroen Roovers <jer@gentoo.org>2016-05-08 11:36:38 +0200
commit8a02a709d464e1f2e8ce8b351deaa3f2ddbf47c3 (patch)
tree64057ea47f673efcc549821c2959ea513bfe1073 /app-arch/dpkg
parentnet-libs/libproxy: Fix gmcs detection (#549734) and webkit dependencies (#574... (diff)
downloadgentoo-8a02a709d464e1f2e8ce8b351deaa3f2ddbf47c3.tar.gz
gentoo-8a02a709d464e1f2e8ce8b351deaa3f2ddbf47c3.tar.bz2
gentoo-8a02a709d464e1f2e8ce8b351deaa3f2ddbf47c3.zip
app-arch/dpkg: Version bump.
Package-Manager: portage-2.2.28
Diffstat (limited to 'app-arch/dpkg')
-rw-r--r--app-arch/dpkg/Manifest2
-rw-r--r--app-arch/dpkg/dpkg-1.17.27.ebuild98
-rw-r--r--app-arch/dpkg/dpkg-1.18.6.ebuild98
3 files changed, 198 insertions, 0 deletions
diff --git a/app-arch/dpkg/Manifest b/app-arch/dpkg/Manifest
index 5944211e2f67..9f549898b2e6 100644
--- a/app-arch/dpkg/Manifest
+++ b/app-arch/dpkg/Manifest
@@ -1,2 +1,4 @@
DIST dpkg_1.17.26.tar.xz 4410860 SHA256 aa4e758752cdfd7ecb118d7a7d31139a0c090c92aa494aa2e46603006deb1ec8 SHA512 4d2f2a7691dd34d47b62ec1f602d9bab612b151f05362607ec8e31037c4ba0baf5d609c46352240e9806e5781db8df9781e8a0ee9fd24faf54f8b43244a7e538 WHIRLPOOL 56decf0774f2d4405fb0934415c50749230c06fe9112e0ebb4458a8917538c83644eadb885d24350bbf713a6250dd5687956b70d47e22c06cf39ff87cb2d5a23
+DIST dpkg_1.17.27.tar.xz 4413092 SHA256 90749c31b9f1fceb46dd9fab5b50de34272efef333cc16d9e144f514fd944bb6 SHA512 6f0229bf6c6b76be22d0baf4af21b1175b5397c4a84eb47f0d02bb93173207cc087015a53a2ed9feb7195d313d447d71a0d7361eb1238377c38f8be4465f8bbd WHIRLPOOL cc8525d391bbb42e399e4a1ecb526db1071122272f7eb1b23bdbbad361dfa0f7af8f1fac867f5fb2028d74171ecd3b175b813b2370b2982b17c1d05b39921455
DIST dpkg_1.18.4.tar.xz 4377024 SHA256 fe89243868888ce715bf45861f26264f767d4e4dbd0d6f1a26ce60bbbbf106da SHA512 047a1b38b685d48557aaf8baa847042d7b4ef38de1bcc069108a7b12f29fd84c16caccaeb79c9a1f6445ea8a3327f5d81ff692dfadd0151a0c8e2ed4e24b5f45 WHIRLPOOL 9dee8af7762b8b581758d1def871fe5b2151982c486cd15bc73b2fdd5895e6b483acc3a44035225e436e4c1534234ea95da53611876fd45b352b7491e902d98a
+DIST dpkg_1.18.6.tar.xz 4617492 SHA256 dd0bc323baafe7aae1571a41d37ab92452171e7a2ce34429f77621fdc0e5dea2 SHA512 84bec49af80ca6e003413dcfbd8da6962f397c8319fbcd93a1c83ed613b4f9a5512ee51d01512203475e97e6570a802238515647cbd5aeab096c13104c50dd33 WHIRLPOOL a8ce16147f933ca6f1d902b7e25cbc34100b710429886eef5b2cfdb333d418d94c33bfd1a7b9bcd5f91e5729ebb70cb38398122d90e4d01304e6c3ce21825ffc
diff --git a/app-arch/dpkg/dpkg-1.17.27.ebuild b/app-arch/dpkg/dpkg-1.17.27.ebuild
new file mode 100644
index 000000000000..808e52f6014b
--- /dev/null
+++ b/app-arch/dpkg/dpkg-1.17.27.ebuild
@@ -0,0 +1,98 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils multilib autotools toolchain-funcs
+
+DESCRIPTION="Package maintenance system for Debian"
+HOMEPAGE="http://packages.qa.debian.org/dpkg"
+SRC_URI="mirror://debian/pool/main/d/${PN}/${P/-/_}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-solaris ~x86-solaris"
+IUSE="+bzip2 +lzma nls selinux test unicode +update-alternatives +zlib"
+
+RDEPEND="
+ >=dev-lang/perl-5.6.0:=
+ dev-perl/TimeDate
+ >=sys-libs/ncurses-5.2-r7
+ bzip2? ( app-arch/bzip2 )
+ lzma? ( app-arch/xz-utils )
+ selinux? ( sys-libs/libselinux )
+ zlib? ( >=sys-libs/zlib-1.1.4 )
+"
+DEPEND="
+ ${RDEPEND}
+ app-arch/xz-utils
+ sys-devel/flex
+ virtual/pkgconfig
+ nls? (
+ app-text/po4a
+ >=sys-devel/gettext-0.18.2
+ )
+ test? (
+ dev-perl/DateTime-Format-DateParse
+ dev-perl/IO-String
+ dev-perl/Test-Pod
+ virtual/perl-Test-Harness
+ )
+"
+
+DOCS=( ChangeLog THANKS TODO )
+
+src_prepare() {
+ # do not expect Debian's gzip --rsyncable extension
+ epatch "${FILESDIR}"/${PN}-1.17.0-gzip-rsyncable.patch
+
+ epatch "${FILESDIR}"/${PN}-1.17.1-flags.patch
+
+ # Force the use of the running bash for get-version (this file is never
+ # installed, so no need to worry about hardcoding a temporary bash)
+ sed -i -e '1c\#!'"${BASH}" get-version || die
+
+ if [[ ${CHOST} == mips64*-linux-gnu ]] ; then
+ # Debian targets use custom full tuples. Map the default one
+ # based on the ABI we're using.
+ local abi
+ if [[ ${ABI} == "n64" ]] ; then
+ abi="mips64"
+ else
+ abi="mipsn32"
+ fi
+ printf "gnu-linux-mips64 ${abi}\ngnu-linux-mips64el ${abi}el\n" >> triplettable
+ fi
+
+ use nls && strip-linguas -i po
+
+ eautoreconf
+}
+
+src_configure() {
+ tc-export CC
+ econf \
+ $(use_enable nls) \
+ $(use_enable unicode) \
+ $(use_enable update-alternatives) \
+ $(use_with bzip2 bz2) \
+ $(use_with lzma liblzma) \
+ $(use_with selinux) \
+ $(use_with zlib) \
+ --disable-compiler-warnings \
+ --disable-dselect \
+ --disable-silent-rules \
+ --disable-start-stop-daemon \
+ --localstatedir="${EPREFIX}"/var
+}
+
+src_compile() {
+ emake AR=$(tc-getAR)
+}
+
+src_install() {
+ default
+
+ keepdir /usr/$(get_libdir)/db/methods/{mnt,floppy,disk}
+ keepdir /usr/$(get_libdir)/db/{alternatives,info,methods,parts,updates}
+}
diff --git a/app-arch/dpkg/dpkg-1.18.6.ebuild b/app-arch/dpkg/dpkg-1.18.6.ebuild
new file mode 100644
index 000000000000..9fd8b48d22f4
--- /dev/null
+++ b/app-arch/dpkg/dpkg-1.18.6.ebuild
@@ -0,0 +1,98 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils multilib autotools toolchain-funcs
+
+DESCRIPTION="Package maintenance system for Debian"
+HOMEPAGE="http://packages.qa.debian.org/dpkg"
+SRC_URI="mirror://debian/pool/main/d/${PN}/${P/-/_}.tar.xz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-solaris ~x86-solaris"
+IUSE="+bzip2 +lzma nls selinux test unicode +update-alternatives +zlib"
+
+RDEPEND="
+ >=dev-lang/perl-5.6.0:=
+ dev-perl/TimeDate
+ >=sys-libs/ncurses-5.2-r7:=
+ bzip2? ( app-arch/bzip2 )
+ lzma? ( app-arch/xz-utils )
+ selinux? ( sys-libs/libselinux )
+ zlib? ( >=sys-libs/zlib-1.1.4 )
+"
+DEPEND="
+ ${RDEPEND}
+ app-arch/xz-utils
+ sys-devel/flex
+ virtual/pkgconfig
+ nls? (
+ app-text/po4a
+ >=sys-devel/gettext-0.18.2
+ )
+ test? (
+ dev-perl/DateTime-Format-DateParse
+ dev-perl/IO-String
+ dev-perl/Test-Pod
+ virtual/perl-Test-Harness
+ )
+"
+
+DOCS=( ChangeLog THANKS TODO )
+
+src_prepare() {
+ # do not expect Debian's gzip --rsyncable extension
+ epatch "${FILESDIR}"/${PN}-1.17.0-gzip-rsyncable.patch
+
+ epatch "${FILESDIR}"/${PN}-1.17.1-flags.patch
+
+ # Force the use of the running bash for get-version (this file is never
+ # installed, so no need to worry about hardcoding a temporary bash)
+ sed -i -e '1c\#!'"${BASH}" get-version || die
+
+ if [[ ${CHOST} == mips64*-linux-gnu ]] ; then
+ # Debian targets use custom full tuples. Map the default one
+ # based on the ABI we're using.
+ local abi
+ if [[ ${ABI} == "n64" ]] ; then
+ abi="mips64"
+ else
+ abi="mipsn32"
+ fi
+ printf "gnu-linux-mips64 ${abi}\ngnu-linux-mips64el ${abi}el\n" >> triplettable
+ fi
+
+ use nls && strip-linguas -i po
+
+ eautoreconf
+}
+
+src_configure() {
+ tc-export CC
+ econf \
+ $(use_enable nls) \
+ $(use_enable unicode) \
+ $(use_enable update-alternatives) \
+ $(use_with bzip2 bz2) \
+ $(use_with lzma liblzma) \
+ $(use_with selinux) \
+ $(use_with zlib) \
+ --disable-compiler-warnings \
+ --disable-dselect \
+ --disable-silent-rules \
+ --disable-start-stop-daemon \
+ --localstatedir="${EPREFIX}"/var
+}
+
+src_compile() {
+ emake AR=$(tc-getAR)
+}
+
+src_install() {
+ default
+
+ keepdir /usr/$(get_libdir)/db/methods/{mnt,floppy,disk}
+ keepdir /usr/$(get_libdir)/db/{alternatives,info,methods,parts,updates}
+}