summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-arch/engrampa/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-arch/engrampa/files')
-rw-r--r--app-arch/engrampa/files/engrampa-1.8.0-caja-schema-fix.patch89
1 files changed, 89 insertions, 0 deletions
diff --git a/app-arch/engrampa/files/engrampa-1.8.0-caja-schema-fix.patch b/app-arch/engrampa/files/engrampa-1.8.0-caja-schema-fix.patch
new file mode 100644
index 000000000000..2068046465da
--- /dev/null
+++ b/app-arch/engrampa/files/engrampa-1.8.0-caja-schema-fix.patch
@@ -0,0 +1,89 @@
+From 49f97664d7fdfc7914245cb26f660cbedd36afa4 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Ball=C3=B3=20Gy=C3=B6rgy?= <ballogyor@gmail.com>
+Date: Thu, 2 Oct 2014 14:29:01 +0200
+Subject: [PATCH] Use Caja GSettings schema optionally
+
+Excludes changes to glib version in configure.ac
+
+This makes Caja dependency optional.
+
+Closes https://github.com/mate-desktop/engrampa/pull/60
+---
+ configure.ac | 2 +-
+ src/fr-window.c | 34 ++++++++++++++++++++++++----------
+ 2 files changed, 25 insertions(+), 11 deletions(-)
+
+diff --git a/src/fr-window.c b/src/fr-window.c
+index f9ceef8..6994066 100644
+--- a/src/fr-window.c
++++ b/src/fr-window.c
+@@ -638,7 +638,9 @@ fr_window_free_private_data (FrWindow *window)
+ _g_object_unref (window->priv->settings_ui);
+ _g_object_unref (window->priv->settings_general);
+ _g_object_unref (window->priv->settings_dialogs);
+- _g_object_unref (window->priv->settings_caja);
++
++ if (window->priv->settings_caja)
++ _g_object_unref (window->priv->settings_caja);
+ }
+
+
+@@ -4598,11 +4600,13 @@ static gboolean
+ is_single_click_policy (FrWindow *window)
+ {
+ char *value;
+- gboolean result;
++ gboolean result = FALSE;
+
+- value = g_settings_get_string (window->priv->settings_caja, CAJA_CLICK_POLICY);
+- result = (value != NULL) && (strncmp (value, "single", 6) == 0);
+- g_free (value);
++ if (window->priv->settings_caja) {
++ value = g_settings_get_string (window->priv->settings_caja, CAJA_CLICK_POLICY);
++ result = (value != NULL) && (strncmp (value, "single", 6) == 0);
++ g_free (value);
++ }
+
+ return result;
+ }
+@@ -5384,6 +5388,8 @@ fr_window_construct (FrWindow *window)
+ GtkToolItem *open_recent_tool_item;
+ GtkWidget *menu_item;
+ GError *error = NULL;
++ GSettingsSchemaSource *schema_source;
++ GSettingsSchema *caja_schema;
+
+ /* data common to all windows. */
+
+@@ -5401,7 +5407,13 @@ fr_window_construct (FrWindow *window)
+ window->priv->settings_ui = g_settings_new (ENGRAMPA_SCHEMA_UI);
+ window->priv->settings_general = g_settings_new (ENGRAMPA_SCHEMA_GENERAL);
+ window->priv->settings_dialogs = g_settings_new (ENGRAMPA_SCHEMA_DIALOGS);
+- window->priv->settings_caja = g_settings_new (CAJA_SCHEMA);
++
++ schema_source = g_settings_schema_source_get_default ();
++ caja_schema = g_settings_schema_source_lookup (schema_source, CAJA_SCHEMA, FALSE);
++ if (caja_schema) {
++ window->priv->settings_caja = g_settings_new (CAJA_SCHEMA);
++ g_settings_schema_unref (caja_schema);
++ }
+
+ /* Create the application. */
+
+@@ -5994,10 +6006,12 @@ fr_window_construct (FrWindow *window)
+ "changed::" PREF_LISTING_USE_MIME_ICONS,
+ G_CALLBACK (pref_use_mime_icons_changed),
+ window);
+- g_signal_connect (window->priv->settings_caja,
+- "changed::" CAJA_CLICK_POLICY,
+- G_CALLBACK (pref_click_policy_changed),
+- window);
++
++ if (window->priv->settings_caja)
++ g_signal_connect (window->priv->settings_caja,
++ "changed::" CAJA_CLICK_POLICY,
++ G_CALLBACK (pref_click_policy_changed),
++ window);
+
+ /* Give focus to the list. */
+