summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2016-04-03 11:55:23 +0200
committerPacho Ramos <pacho@gentoo.org>2016-04-03 14:39:51 +0200
commit63f093ed793c86d719fd9ccf6f0955cdbd0d8647 (patch)
treedb1852ce6c8d603ab5d6b75b8ecaacdef7441463 /app-arch/gcab/gcab-0.7.ebuild
parentmail-client/evolution: Version bump (diff)
downloadgentoo-63f093ed793c86d719fd9ccf6f0955cdbd0d8647.tar.gz
gentoo-63f093ed793c86d719fd9ccf6f0955cdbd0d8647.tar.bz2
gentoo-63f093ed793c86d719fd9ccf6f0955cdbd0d8647.zip
app-arch/gcab: Version bump
Package-Manager: portage-2.2.28
Diffstat (limited to 'app-arch/gcab/gcab-0.7.ebuild')
-rw-r--r--app-arch/gcab/gcab-0.7.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/app-arch/gcab/gcab-0.7.ebuild b/app-arch/gcab/gcab-0.7.ebuild
new file mode 100644
index 000000000000..1c58e9a694d2
--- /dev/null
+++ b/app-arch/gcab/gcab-0.7.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+GCONF_DEBUG="no"
+VALA_USE_DEPEND="vapigen"
+
+inherit gnome2 vala
+
+DESCRIPTION="Library and tool for working with Microsoft Cabinet (CAB) files"
+HOMEPAGE="https://wiki.gnome.org/msitools"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+IUSE="+introspection vala"
+REQUIRED_USE="vala? ( introspection )"
+
+RDEPEND="
+ >=dev-libs/glib-2.22:2
+ sys-libs/zlib
+ introspection? ( >=dev-libs/gobject-introspection-0.9.4:= )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/gtk-doc-am-1.14
+ >=dev-util/intltool-0.40
+ sys-devel/gettext
+ virtual/pkgconfig
+ vala? ( $(vala_depend) )
+"
+
+src_prepare() {
+ gnome2_src_prepare
+ use vala && vala_src_prepare
+}
+
+src_configure() {
+ local myconf
+ use vala || myconf="VAPIGEN=no"
+ gnome2_src_configure \
+ --disable-static \
+ $(use_enable introspection) \
+ ${myconf}
+}