summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2018-01-08 09:30:55 +0100
committerLars Wendler <polynomial-c@gentoo.org>2018-01-08 09:32:57 +0100
commit2f149a2ea9ff654e305feea7693e6ff9e2663c9a (patch)
treea9224405d18ceed9efc20cd2a5d2c7f9a7040d07 /app-arch/gzip/gzip-1.9.ebuild
parentmedia-libs/libogg: find and remove '*.a' not required (diff)
downloadgentoo-2f149a2ea9ff654e305feea7693e6ff9e2663c9a.tar.gz
gentoo-2f149a2ea9ff654e305feea7693e6ff9e2663c9a.tar.bz2
gentoo-2f149a2ea9ff654e305feea7693e6ff9e2663c9a.zip
app-arch/gzip: Bump to version 1.9
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'app-arch/gzip/gzip-1.9.ebuild')
-rw-r--r--app-arch/gzip/gzip-1.9.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/app-arch/gzip/gzip-1.9.ebuild b/app-arch/gzip/gzip-1.9.ebuild
new file mode 100644
index 000000000000..d582478b998d
--- /dev/null
+++ b/app-arch/gzip/gzip-1.9.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit flag-o-matic
+
+DESCRIPTION="Standard GNU compressor"
+HOMEPAGE="https://www.gnu.org/software/gzip/"
+SRC_URI="mirror://gnu/gzip/${P}.tar.xz
+ mirror://gnu-alpha/gzip/${P}.tar.xz
+ mirror://gentoo/${P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="pic static"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.3.8-install-symlinks.patch"
+)
+
+src_configure() {
+ use static && append-flags -static
+ # avoid text relocation in gzip
+ use pic && export DEFS="NO_ASM"
+ econf
+}
+
+src_install() {
+ default
+ docinto txt
+ dodoc algorithm.doc gzip.doc
+
+ # keep most things in /usr, just the fun stuff in /
+ dodir /bin
+ mv "${ED%/}"/usr/bin/{gunzip,gzip,uncompress,zcat} "${ED%/}"/bin/ || die
+ sed -e "s:${EPREFIX}/usr:${EPREFIX}:" -i "${ED%/}"/bin/gunzip || die
+}