summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2015-11-14 23:43:34 +0000
committerPatrice Clement <monsieurp@gentoo.org>2015-11-14 23:43:34 +0000
commit85ad34bb5c2bab0c7d3d25d011fceba61b33e6c2 (patch)
tree180fe51e53764b52f9a7833fff7c001c70046106 /app-arch/lha/lha-114i-r8.ebuild
parentapp-arch/lha: Mend header. Stick patch in PATCHES array. Mask KEYWORDS. (diff)
downloadgentoo-85ad34bb5c2bab0c7d3d25d011fceba61b33e6c2.tar.gz
gentoo-85ad34bb5c2bab0c7d3d25d011fceba61b33e6c2.tar.bz2
gentoo-85ad34bb5c2bab0c7d3d25d011fceba61b33e6c2.zip
app-arch/lha: QA warnings are now gone for good.
Package-Manager: portage-2.2.20.1 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'app-arch/lha/lha-114i-r8.ebuild')
-rw-r--r--app-arch/lha/lha-114i-r8.ebuild34
1 files changed, 17 insertions, 17 deletions
diff --git a/app-arch/lha/lha-114i-r8.ebuild b/app-arch/lha/lha-114i-r8.ebuild
index 46a631b653e1..301e798ecedc 100644
--- a/app-arch/lha/lha-114i-r8.ebuild
+++ b/app-arch/lha/lha-114i-r8.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-#Id$
+# $Id$
EAPI=5
inherit autotools eutils flag-o-matic
@@ -23,31 +23,31 @@ PATCHES=(
)
src_prepare() {
- epatch "${PATCHES[@]}"
+ epatch "${PATCHES[@]}"
- sed -e '/^AM_C_PROTOTYPES/d' \
- -e 's/^AM_CONFIG_HEADER/AC_CONFIG_HEADERS/' \
- -i configure.ac || die #423125, 467544
+ sed -e '/^AM_C_PROTOTYPES/d' \
+ -e 's/^AM_CONFIG_HEADER/AC_CONFIG_HEADERS/' \
+ -i configure.ac || die #423125, 467544
- eautoreconf
+ eautoreconf
}
src_configure() {
- append-cppflags -DPROTOTYPES #423125
+ append-cppflags -DPROTOTYPES #423125
- if [[ ${CHOST} == *-interix* ]]; then
- export ac_cv_header_inttypes_h=no
- export ac_cv_func_iconv=no
- fi
+ if [[ ${CHOST} == *-interix* ]]; then
+ export ac_cv_header_inttypes_h=no
+ export ac_cv_func_iconv=no
+ fi
- econf
+ econf
}
src_install() {
- emake \
- DESTDIR="${D}" \
- mandir="${EPREFIX}"/usr/share/man/ja \
- install
+ emake \
+ DESTDIR="${D}" \
+ mandir="${EPREFIX}"/usr/share/man/ja \
+ install
- dodoc ChangeLog Hacking_of_LHa
+ dodoc ChangeLog Hacking_of_LHa
}