summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Stakenvicius <axs@gentoo.org>2016-01-09 09:48:50 -0500
committerIan Stakenvicius <axs@gentoo.org>2016-01-11 11:53:21 -0500
commit1236680f7cce8054172c79943d7493d859410556 (patch)
tree0184df421c3a06b324ae44cd951a3ae0afadfe53 /app-arch/libarchive
parentdev-libs/libbsd: convert to multlib (diff)
downloadgentoo-1236680f7cce8054172c79943d7493d859410556.tar.gz
gentoo-1236680f7cce8054172c79943d7493d859410556.tar.bz2
gentoo-1236680f7cce8054172c79943d7493d859410556.zip
app-arch/libarchive: convert to multilib
multilib is needed to support samba-4 (new rdep) Package-Manager: portage-2.2.26
Diffstat (limited to 'app-arch/libarchive')
-rw-r--r--app-arch/libarchive/files/libarchive-3.1.2-outofsource.patch29
-rw-r--r--app-arch/libarchive/libarchive-3.1.2-r3.ebuild121
2 files changed, 150 insertions, 0 deletions
diff --git a/app-arch/libarchive/files/libarchive-3.1.2-outofsource.patch b/app-arch/libarchive/files/libarchive-3.1.2-outofsource.patch
new file mode 100644
index 000000000000..6545c6132391
--- /dev/null
+++ b/app-arch/libarchive/files/libarchive-3.1.2-outofsource.patch
@@ -0,0 +1,29 @@
+--- a/Makefile.am 2013-02-09 12:23:03.000000000 -0500
++++ b/Makefile.am 2016-01-08 16:43:00.868186895 -0500
+@@ -508,7 +508,7 @@
+ # Building it automatically provides a sanity-check on libarchive_test_SOURCES
+ # above.
+ libarchive/test/list.h: Makefile
+- cat $(top_srcdir)/libarchive/test/test_*.c | grep DEFINE_TEST > libarchive/test/list.h
++ mkdir -p libarchive/test && cat $(top_srcdir)/libarchive/test/test_*.c | grep DEFINE_TEST > libarchive/test/list.h
+
+ libarchive_TESTS_ENVIRONMENT= LIBARCHIVE_TEST_FILES=`cd $(top_srcdir);/bin/pwd`/libarchive/test LRZIP=NOCONFIG
+
+@@ -835,7 +835,7 @@
+ $(PLATFORMCPPFLAGS)
+
+ tar/test/list.h: Makefile
+- cat $(top_srcdir)/tar/test/test_*.c | grep DEFINE_TEST > tar/test/list.h
++ mkdir -p tar/test && cat $(top_srcdir)/tar/test/test_*.c | grep DEFINE_TEST > tar/test/list.h
+
+ if BUILD_BSDTAR
+ bsdtar_test_programs= bsdtar_test
+@@ -975,7 +975,7 @@
+ bsdcpio_test_LDADD=libarchive_fe.la
+
+ cpio/test/list.h: Makefile
+- cat $(top_srcdir)/cpio/test/test_*.c | grep DEFINE_TEST > cpio/test/list.h
++ mkdir -p cpio/test && cat $(top_srcdir)/cpio/test/test_*.c | grep DEFINE_TEST > cpio/test/list.h
+
+ if BUILD_BSDCPIO
+ bsdcpio_test_programs= bsdcpio_test
diff --git a/app-arch/libarchive/libarchive-3.1.2-r3.ebuild b/app-arch/libarchive/libarchive-3.1.2-r3.ebuild
new file mode 100644
index 000000000000..8153c43242d6
--- /dev/null
+++ b/app-arch/libarchive/libarchive-3.1.2-r3.ebuild
@@ -0,0 +1,121 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit autotools eutils multilib-minimal toolchain-funcs
+
+DESCRIPTION="BSD tar command"
+HOMEPAGE="http://www.libarchive.org/"
+SRC_URI="http://www.libarchive.org/downloads/${P}.tar.gz"
+
+LICENSE="BSD BSD-2 BSD-4 public-domain"
+SLOT="0/13"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="acl +bzip2 +e2fsprogs expat +iconv kernel_linux libressl +lzma lzo nettle static-libs xattr +zlib"
+
+RDEPEND="
+ !libressl? ( dev-libs/openssl:0[${MULTILIB_USEDEP}] )
+ libressl? ( dev-libs/libressl[${MULTILIB_USEDEP}] )
+ acl? ( virtual/acl[${MULTILIB_USEDEP}] )
+ bzip2? ( app-arch/bzip2[${MULTILIB_USEDEP}] )
+ expat? ( dev-libs/expat[${MULTILIB_USEDEP}] )
+ !expat? ( dev-libs/libxml2[${MULTILIB_USEDEP}] )
+ iconv? ( virtual/libiconv[${MULTILIB_USEDEP}] )
+ kernel_linux? (
+ xattr? ( sys-apps/attr[${MULTILIB_USEDEP}] )
+ )
+ lzma? ( app-arch/xz-utils[${MULTILIB_USEDEP}] )
+ lzo? ( >=dev-libs/lzo-2[${MULTILIB_USEDEP}] )
+ nettle? ( dev-libs/nettle[${MULTILIB_USEDEP}] )
+ zlib? ( sys-libs/zlib[${MULTILIB_USEDEP}] )"
+DEPEND="${RDEPEND}
+ kernel_linux? (
+ virtual/os-headers
+ e2fsprogs? ( sys-fs/e2fsprogs )
+ )"
+
+DOCS=( NEWS README )
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-CVE-2013-0211.patch
+ epatch "${FILESDIR}"/${P}-outofsource.patch
+ eautoreconf
+}
+
+multilib_src_configure() {
+ export ac_cv_header_ext2fs_ext2_fs_h=$(usex e2fsprogs) #354923
+
+ local myconf=()
+ myconf=(
+ $(use_enable static-libs static)
+ $(use_enable xattr)
+ $(use_enable acl)
+ $(use_with zlib)
+ $(use_with bzip2 bz2lib)
+ $(use_with iconv)
+ $(use_with lzma)
+ $(use_with lzo lzo2)
+ $(use_with nettle)
+ $(use_with !expat xml2)
+ $(use_with expat)
+ )
+ if multilib_is_native_abi ; then myconf+=(
+ --enable-bsdtar=$(tc-is-static-only && echo static || echo shared)
+ --enable-bsdcpio=$(tc-is-static-only && echo static || echo shared)
+ ); else myconf+=(
+ --disable-bsdtar
+ --disable-bsdcpio
+ ); fi
+
+ # We disable lzmadec because we support the newer liblzma from xz-utils
+ # and not liblzmadec with this version.
+ myconf+=(
+ --without-lzmadec
+ )
+
+ ECONF_SOURCE="${S}" econf "${myconf[@]}"
+}
+
+multilib_src_compile() {
+ if multilib_is_native_abi ; then
+ emake
+ else
+ emake libarchive.la
+ fi
+}
+
+multilib_src_test() {
+ # Replace the default src_test so that it builds tests in parallel
+ multilib_is_native_abi && emake check
+}
+
+multilib_src_install() {
+ if multilib_is_native_abi ; then
+ emake DESTDIR="${D}" install
+
+ # Libs.private: should be used from libarchive.pc instead
+ prune_libtool_files
+
+ # Create tar symlink for FreeBSD
+ if ! use prefix && [[ ${CHOST} == *-freebsd* ]]; then
+ dosym bsdtar /usr/bin/tar
+ echo '.so bsdtar.1' > "${T}"/tar.1
+ doman "${T}"/tar.1
+ # We may wish to switch to symlink bsdcpio to cpio too one day
+ fi
+ else
+ emake DESTDIR="${D}" \
+ install-includeHEADERS \
+ install-libLTLIBRARIES \
+ install-pkgconfigDATA
+
+ # Libs.private: should be used from libarchive.pc instead
+ prune_libtool_files
+ fi
+}
+
+multilib_src_install_all() {
+ cd "${S}" || die
+ dodoc "${DOCS[@]}"
+}