summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-arch/libarchive
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-arch/libarchive')
-rw-r--r--app-arch/libarchive/Manifest1
-rw-r--r--app-arch/libarchive/files/libarchive-3.1.2-CVE-2013-0211.patch32
-rw-r--r--app-arch/libarchive/libarchive-3.1.2-r1.ebuild91
-rw-r--r--app-arch/libarchive/metadata.xml34
4 files changed, 158 insertions, 0 deletions
diff --git a/app-arch/libarchive/Manifest b/app-arch/libarchive/Manifest
new file mode 100644
index 000000000000..d9a56ff4e636
--- /dev/null
+++ b/app-arch/libarchive/Manifest
@@ -0,0 +1 @@
+DIST libarchive-3.1.2.tar.gz 4527540 SHA256 eb87eacd8fe49e8d90c8fdc189813023ccc319c5e752b01fb6ad0cc7b2c53d5e SHA512 1f3c2a675031f93c7d42ae2ed06742b0b1e2236ff57d9117791d62fb8ae77d6cafffbcb5d45b5bd98daa908bd18c576cf82e01a9b1eba699705e23eff3688114 WHIRLPOOL b90f336afb5264be91fb17d7dae3d5697e3f84e24d276af1d5ac076fe15ef6f5756488f09506fabe470473becb5449cd1f34865309dcf8a914e6e83506e8695f
diff --git a/app-arch/libarchive/files/libarchive-3.1.2-CVE-2013-0211.patch b/app-arch/libarchive/files/libarchive-3.1.2-CVE-2013-0211.patch
new file mode 100644
index 000000000000..78427ce47740
--- /dev/null
+++ b/app-arch/libarchive/files/libarchive-3.1.2-CVE-2013-0211.patch
@@ -0,0 +1,32 @@
+From 22531545514043e04633e1c015c7540b9de9dbe4 Mon Sep 17 00:00:00 2001
+From: Tim Kientzle <kientzle@acm.org>
+Date: Fri, 22 Mar 2013 23:48:41 -0700
+Subject: [PATCH] Limit write requests to at most INT_MAX. This prevents a
+ certain common programming error (passing -1 to write) from leading to other
+ problems deeper in the library.
+
+---
+ libarchive/archive_write.c | 5 +++++
+ 1 file changed, 5 insertions(+)
+
+diff --git a/libarchive/archive_write.c b/libarchive/archive_write.c
+index eede5e0..be85621 100644
+--- a/libarchive/archive_write.c
++++ b/libarchive/archive_write.c
+@@ -673,8 +673,13 @@ static ssize_t
+ _archive_write_data(struct archive *_a, const void *buff, size_t s)
+ {
+ struct archive_write *a = (struct archive_write *)_a;
++ const size_t max_write = INT_MAX;
++
+ archive_check_magic(&a->archive, ARCHIVE_WRITE_MAGIC,
+ ARCHIVE_STATE_DATA, "archive_write_data");
++ /* In particular, this catches attempts to pass negative values. */
++ if (s > max_write)
++ s = max_write;
+ archive_clear_error(&a->archive);
+ return ((a->format_write_data)(a, buff, s));
+ }
+--
+1.8.1
+
diff --git a/app-arch/libarchive/libarchive-3.1.2-r1.ebuild b/app-arch/libarchive/libarchive-3.1.2-r1.ebuild
new file mode 100644
index 000000000000..ce57a8000dcc
--- /dev/null
+++ b/app-arch/libarchive/libarchive-3.1.2-r1.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils libtool multilib toolchain-funcs
+
+DESCRIPTION="BSD tar command"
+HOMEPAGE="http://www.libarchive.org/"
+SRC_URI="http://www.libarchive.org/downloads/${P}.tar.gz"
+
+LICENSE="BSD BSD-2 BSD-4 public-domain"
+SLOT="0/13"
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="acl +bzip2 +e2fsprogs expat +iconv kernel_linux +lzma lzo nettle static-libs xattr +zlib"
+
+RDEPEND="dev-libs/openssl:0
+ acl? ( virtual/acl )
+ bzip2? ( app-arch/bzip2 )
+ expat? ( dev-libs/expat )
+ !expat? ( dev-libs/libxml2 )
+ iconv? ( virtual/libiconv )
+ kernel_linux? (
+ xattr? ( sys-apps/attr )
+ )
+ lzma? ( app-arch/xz-utils )
+ lzo? ( >=dev-libs/lzo-2 )
+ nettle? ( dev-libs/nettle )
+ zlib? ( sys-libs/zlib )"
+DEPEND="${RDEPEND}
+ kernel_linux? (
+ virtual/os-headers
+ e2fsprogs? ( sys-fs/e2fsprogs )
+ )"
+
+DOCS="NEWS README"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-CVE-2013-0211.patch
+ elibtoolize
+}
+
+src_configure() {
+ export ac_cv_header_ext2fs_ext2_fs_h=$(usex e2fsprogs) #354923
+
+ # We disable lzmadec because we support the newer liblzma from xz-utils
+ # and not liblzmadec with this version.
+ econf \
+ $(use_enable static-libs static) \
+ --enable-bsdtar=$(tc-is-static-only && echo static || echo shared) \
+ --enable-bsdcpio=$(tc-is-static-only && echo static || echo shared) \
+ $(use_enable xattr) \
+ $(use_enable acl) \
+ $(use_with zlib) \
+ $(use_with bzip2 bz2lib) \
+ --without-lzmadec \
+ $(use_with iconv) \
+ $(use_with lzma) \
+ $(use_with lzo lzo2) \
+ $(use_with nettle) \
+ $(use_with !expat xml2) \
+ $(use_with expat)
+}
+
+src_test() {
+ # Replace the default src_test so that it builds tests in parallel
+ emake check
+}
+
+src_install() {
+ default
+
+ # Libs.private: should be used from libarchive.pc instead
+ prune_libtool_files
+
+ # Create tar symlink for FreeBSD
+ if ! use prefix && [[ ${CHOST} == *-freebsd* ]]; then
+ dosym bsdtar /usr/bin/tar
+ echo '.so bsdtar.1' > "${T}"/tar.1
+ doman "${T}"/tar.1
+ # We may wish to switch to symlink bsdcpio to cpio too one day
+ fi
+}
+
+pkg_preinst() {
+ preserve_old_lib /usr/$(get_libdir)/${PN}$(get_libname 12)
+}
+
+pkg_postinst() {
+ preserve_old_lib_notify /usr/$(get_libdir)/${PN}$(get_libname 12)
+}
diff --git a/app-arch/libarchive/metadata.xml b/app-arch/libarchive/metadata.xml
new file mode 100644
index 000000000000..ca60b945eeab
--- /dev/null
+++ b/app-arch/libarchive/metadata.xml
@@ -0,0 +1,34 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>bsd</herd>
+ <maintainer>
+ <email>ssuominen@gentoo.org</email>
+ <name>Samuli Suominen</name>
+ </maintainer>
+ <longdescription lang='en'>
+ The bsdtar program creates and manipulates streaming archive files.
+ It has a number of advantages over previous tar implementations.
+ </longdescription>
+ <use>
+ <flag name='zlib'>
+ Allow accessing gzip-compressed archives through
+ <pkg>sys-libs/zlib</pkg>. This only affects libarchive's native
+ support: bsdtar will keep using gunzip as a filter if that's not
+ built-in. It's also needed for supporting extraction of ZIP
+ files.
+ </flag>
+ <flag name='bzip2'>
+ Allow accessing bzip2-compressed archives through libbz2 (which
+ comes with <pkg>app-arch/bzip2</pkg>). This only affects
+ libarchive's native support: bsdtar will keep using bunzip2 as a
+ filter if that's not built-in.
+ </flag>
+ <flag name='nettle'>
+ Use <pkg>dev-libs/nettle</pkg> as crypto backend
+ </flag>
+ <flag name='e2fsprogs'>
+ Use file flags from <pkg>sys-fs/e2fsprogs</pkg> headers instead of <pkg>virtual/os-headers</pkg> headers
+ </flag>
+ </use>
+</pkgmetadata>