summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAgostino Sarubbo <ago@gentoo.org>2017-03-03 11:08:51 +0100
committerAgostino Sarubbo <ago@gentoo.org>2017-03-03 11:08:51 +0100
commit526e33891a16c5ae2639ab4265ee3633d8c9b2b5 (patch)
tree19c6f673af361e9269b19a3a1046d5f878730c94 /app-arch/lrzip
parentdev-vcs/git-lfs: Version bump (diff)
downloadgentoo-526e33891a16c5ae2639ab4265ee3633d8c9b2b5.tar.gz
gentoo-526e33891a16c5ae2639ab4265ee3633d8c9b2b5.tar.bz2
gentoo-526e33891a16c5ae2639ab4265ee3633d8c9b2b5.zip
app-arch/lrzip: version bump to 0.631
Package-Manager: portage-2.3.3 Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
Diffstat (limited to 'app-arch/lrzip')
-rw-r--r--app-arch/lrzip/Manifest1
-rw-r--r--app-arch/lrzip/lrzip-0.631.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/app-arch/lrzip/Manifest b/app-arch/lrzip/Manifest
index ae2e2661c661..251668e57e9b 100644
--- a/app-arch/lrzip/Manifest
+++ b/app-arch/lrzip/Manifest
@@ -1,3 +1,4 @@
DIST lrzip-0.614.tar.bz2 491995 SHA256 65024d69d1773f3ccf84508a481d7de128c03d1cf9750b5803aead4a24522763 SHA512 6c82d7b4cc6081fb4f102a34f3a5ecf834b3fa3d222ac9dd4f3f0615c83610c08315eae9cc98291bd5e3eb71453cf391cdad4db980012e4368d16d80f34d2bd8 WHIRLPOOL 1669d9e551786f81c3849b2bfb813422cccc21c9d00104b58d42a0470ae9b8633339ef88ead6c5956eea92ac6800ee9b259fbfb15d1b22aa45fe92db7040cf68
DIST lrzip-0.621.tar.bz2 503286 SHA256 31c26fbee8b9b0bd413ca214862dbc0d9e6d3477f23e9839774936bf140ceb6b SHA512 be94f54c3d84c93e3c1ab7b08ca6d2a02bc343983785be4884f42521520d2babc31db3abbec4b77dc9f710d18648adcc3d24b203289d8d4728afb3ef0fb90c0a WHIRLPOOL 41bd08db70f30ff183f3e82e784a40b08070a3a728eafad50b64c7ce453ed2c379721be64d0ac0ee04e1c66b6ad528d0210977624a8c17f90775f70b83921ae7
DIST lrzip-0.630.tar.bz2 521517 SHA256 2461f6bfa3231a98a76548741cbc64a2389e94eb5c3de152df8a118e23edd307 SHA512 fa46a2e9cb2574086d24296b7376865ac9f998724041c00e69f28d4984a6b8f7441de7d7fab2820e6cd6d6da4ead8ba66d0eb18f0381e8438db09301fb009460 WHIRLPOOL 41cfbc661d38fcb183107dedd4a03fcd740ec40adb040e79021cda97172e20ce76a83ecd1e53da0a498ccc5d3a093942f85a33ae39d87297adbbe80cf3786e3f
+DIST lrzip-0.631.tar.bz2 522158 SHA256 0d11e268d0d72310d6d73a8ce6bb3d85e26de3f34d8a713055f3f25a77226455 SHA512 6420cd465ccd4581066408482335a82089f84f0aca1b05249b9fc6039b7e67df94457a7c871859e363206df3a40e93cfde576388785113f6c99b31d34c00a307 WHIRLPOOL 1973c0d6c046ed5600ee092e35acfe0f52814b30312d33baedf2c30dcb1727c373b2e42c4bee4831ad2e6dce67792379d081df2b987f7915125272d101132645
diff --git a/app-arch/lrzip/lrzip-0.631.ebuild b/app-arch/lrzip/lrzip-0.631.ebuild
new file mode 100644
index 000000000000..d3b839bd266c
--- /dev/null
+++ b/app-arch/lrzip/lrzip-0.631.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils
+
+DESCRIPTION="Long Range ZIP or Lzma RZIP optimized for compressing large files"
+HOMEPAGE="https://github.com/ckolivas/lrzip"
+SRC_URI="http://ck.kolivas.org/apps/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
+IUSE="static-libs"
+
+RDEPEND="dev-libs/lzo
+ app-arch/bzip2
+ sys-libs/zlib"
+DEPEND="${RDEPEND}
+ x86? ( dev-lang/nasm )
+ virtual/perl-Pod-Parser"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-missing-stdarg_h.patch
+ )
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ prune_libtool_files
+}