summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAmy Winston <amynka@gentoo.org>2016-07-06 18:40:24 +0200
committerAmy Winston <amynka@gentoo.org>2016-07-06 18:40:24 +0200
commit8759c82ee21fb03b5044eac80c99d400ed706356 (patch)
tree050239ffea11a26d334b92a74bbef9b26ff94427 /app-arch/lrzip
parentsys-block/partitionmanager: Remove 2.2.0 (diff)
downloadgentoo-8759c82ee21fb03b5044eac80c99d400ed706356.tar.gz
gentoo-8759c82ee21fb03b5044eac80c99d400ed706356.tar.bz2
gentoo-8759c82ee21fb03b5044eac80c99d400ed706356.zip
app-arch/lrzip: version bump 0.630 bug #585780
- Add static-libs useflag bug #490060 - Convert patch to p1 - Change homepage Package-Manager: portage-2.2.28
Diffstat (limited to 'app-arch/lrzip')
-rw-r--r--app-arch/lrzip/Manifest1
-rw-r--r--app-arch/lrzip/files/lrzip-missing-stdarg_h.patch4
-rw-r--r--app-arch/lrzip/lrzip-0.630.ebuild36
3 files changed, 39 insertions, 2 deletions
diff --git a/app-arch/lrzip/Manifest b/app-arch/lrzip/Manifest
index c9b86197490e..ae2e2661c661 100644
--- a/app-arch/lrzip/Manifest
+++ b/app-arch/lrzip/Manifest
@@ -1,2 +1,3 @@
DIST lrzip-0.614.tar.bz2 491995 SHA256 65024d69d1773f3ccf84508a481d7de128c03d1cf9750b5803aead4a24522763 SHA512 6c82d7b4cc6081fb4f102a34f3a5ecf834b3fa3d222ac9dd4f3f0615c83610c08315eae9cc98291bd5e3eb71453cf391cdad4db980012e4368d16d80f34d2bd8 WHIRLPOOL 1669d9e551786f81c3849b2bfb813422cccc21c9d00104b58d42a0470ae9b8633339ef88ead6c5956eea92ac6800ee9b259fbfb15d1b22aa45fe92db7040cf68
DIST lrzip-0.621.tar.bz2 503286 SHA256 31c26fbee8b9b0bd413ca214862dbc0d9e6d3477f23e9839774936bf140ceb6b SHA512 be94f54c3d84c93e3c1ab7b08ca6d2a02bc343983785be4884f42521520d2babc31db3abbec4b77dc9f710d18648adcc3d24b203289d8d4728afb3ef0fb90c0a WHIRLPOOL 41bd08db70f30ff183f3e82e784a40b08070a3a728eafad50b64c7ce453ed2c379721be64d0ac0ee04e1c66b6ad528d0210977624a8c17f90775f70b83921ae7
+DIST lrzip-0.630.tar.bz2 521517 SHA256 2461f6bfa3231a98a76548741cbc64a2389e94eb5c3de152df8a118e23edd307 SHA512 fa46a2e9cb2574086d24296b7376865ac9f998724041c00e69f28d4984a6b8f7441de7d7fab2820e6cd6d6da4ead8ba66d0eb18f0381e8438db09301fb009460 WHIRLPOOL 41cfbc661d38fcb183107dedd4a03fcd740ec40adb040e79021cda97172e20ce76a83ecd1e53da0a498ccc5d3a093942f85a33ae39d87297adbbe80cf3786e3f
diff --git a/app-arch/lrzip/files/lrzip-missing-stdarg_h.patch b/app-arch/lrzip/files/lrzip-missing-stdarg_h.patch
index dcc698bd9b93..8f427d46a6a1 100644
--- a/app-arch/lrzip/files/lrzip-missing-stdarg_h.patch
+++ b/app-arch/lrzip/files/lrzip-missing-stdarg_h.patch
@@ -1,6 +1,6 @@
diff -Naur Lrzip.h.orig Lrzip.h
---- Lrzip.h.orig 2013-11-30 20:07:27.343086997 +0000
-+++ Lrzip.h 2013-11-30 20:07:44.072641056 +0000
+--- a/Lrzip.h 2013-11-30 20:07:27.343086997 +0000
++++ b/Lrzip.h 2013-11-30 20:07:44.072641056 +0000
@@ -22,6 +22,7 @@
#include <stdbool.h>
diff --git a/app-arch/lrzip/lrzip-0.630.ebuild b/app-arch/lrzip/lrzip-0.630.ebuild
new file mode 100644
index 000000000000..84f6232bde0c
--- /dev/null
+++ b/app-arch/lrzip/lrzip-0.630.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit eutils
+
+DESCRIPTION="Long Range ZIP or Lzma RZIP optimized for compressing large files"
+HOMEPAGE="https://github.com/ckolivas/lrzip"
+SRC_URI="http://ck.kolivas.org/apps/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
+IUSE="static-libs"
+
+RDEPEND="dev-libs/lzo
+ app-arch/bzip2
+ sys-libs/zlib"
+DEPEND="${RDEPEND}
+ x86? ( dev-lang/nasm )
+ virtual/perl-Pod-Parser"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-missing-stdarg_h.patch
+ )
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ prune_libtool_files
+}