summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2015-11-03 22:27:45 +0100
committerMichał Górny <mgorny@gentoo.org>2015-11-03 22:55:33 +0100
commitdadf36167d14bbbd8e5b5d5ac5da9537443a51f0 (patch)
tree2b4d9136db754f1f4116153d80e3a9126fca3a6a /app-arch/lz4/lz4-9999.ebuild
parentapp-emulation/docker: version bump to 1.9.0. Ebuild ported from Tianon's ove... (diff)
downloadgentoo-dadf36167d14bbbd8e5b5d5ac5da9537443a51f0.tar.gz
gentoo-dadf36167d14bbbd8e5b5d5ac5da9537443a51f0.tar.bz2
gentoo-dadf36167d14bbbd8e5b5d5ac5da9537443a51f0.zip
app-arch/lz4: Version bump to r131
Bump to upstream revision 131. Fix the build procedure following Makefile changes. Bump subslot to current revision since upstream changed ABI without bumping SONAME. Fixes: https://bugs.gentoo.org/show_bug.cgi?id=522860
Diffstat (limited to 'app-arch/lz4/lz4-9999.ebuild')
-rw-r--r--app-arch/lz4/lz4-9999.ebuild24
1 files changed, 17 insertions, 7 deletions
diff --git a/app-arch/lz4/lz4-9999.ebuild b/app-arch/lz4/lz4-9999.ebuild
index 7da32eaaa62a..277023bec797 100644
--- a/app-arch/lz4/lz4-9999.ebuild
+++ b/app-arch/lz4/lz4-9999.ebuild
@@ -11,21 +11,29 @@ if [[ ${PV} == 9999 ]]; then
EGIT_REPO_URI="https://github.com/Cyan4973/lz4.git"
EGIT_BRANCH=dev
else
- SRC_URI="https://dev.gentoo.org/~ryao/dist/${P}.tar.xz"
+ MY_PV="r${PV##0_p}"
+ MY_P="${PN}-${MY_PV}"
+ SRC_URI="https://github.com/Cyan4973/lz4/archive/${MY_PV}.tar.gz -> ${MY_P}.tar.gz"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux"
+ S="${WORKDIR}/${MY_P}"
fi
DESCRIPTION="Extremely Fast Compression algorithm"
HOMEPAGE="https://github.com/Cyan4973/lz4"
LICENSE="BSD-2 GPL-2"
-SLOT="0"
-IUSE="test"
+# Upstream has trouble keeping ABI stable, so please test new versions
+# with abi-compliance-checker and update the subslot every time ABI
+# changes. This is the least we can do to keep things sane.
+SLOT="0/r131"
+IUSE="test valgrind"
-RDEPEND=""
-DEPEND="test? ( dev-util/valgrind )"
+DEPEND="test? ( valgrind? ( dev-util/valgrind ) )"
src_prepare() {
+ if ! use valgrind; then
+ sed -i -e '/^test:/s|test-mem||g' programs/Makefile || die
+ fi
multilib_copy_sources
}
@@ -33,8 +41,10 @@ multilib_src_compile() {
tc-export CC AR
# we must not use the 'all' target since it builds test programs
# & extra -m32 executables
- emake
- emake -C programs
+ emake -C lib liblz4 liblz4.pc
+ emake -C programs lz4 lz4c
+ # work around lack of proper target dependencies
+ touch lib/liblz4
}
multilib_src_install() {