summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-01-07 01:42:41 +0100
committerMichał Górny <mgorny@gentoo.org>2021-01-07 01:42:41 +0100
commit2ca9ab4a8c15fd74959cd21b468fec4bd17971aa (patch)
tree692106f3f610cd1e4629b2cf751d6f9104154663 /app-arch/lzlib
parentdev-libs/libfilezilla: Removed old (diff)
downloadgentoo-2ca9ab4a8c15fd74959cd21b468fec4bd17971aa.tar.gz
gentoo-2ca9ab4a8c15fd74959cd21b468fec4bd17971aa.tar.bz2
gentoo-2ca9ab4a8c15fd74959cd21b468fec4bd17971aa.zip
app-arch/lzlib: Bump to 1.12
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-arch/lzlib')
-rw-r--r--app-arch/lzlib/Manifest1
-rw-r--r--app-arch/lzlib/lzlib-1.12.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/app-arch/lzlib/Manifest b/app-arch/lzlib/Manifest
index 47995833baf1..7911ded06777 100644
--- a/app-arch/lzlib/Manifest
+++ b/app-arch/lzlib/Manifest
@@ -1 +1,2 @@
DIST lzlib-1.11.tar.gz 105873 BLAKE2B 6caadc4c3b78db835bcf4f11e5290342f0f952943006589345898a85211b0a0ae5d775d0a8e7747c549eae00dd0abd2e2afb5c07eb75b4fda712a9361a71bd59 SHA512 5aa3ff084177efe906518724a98a78c32d1c0e02b967800a44388fc6af441de48fcc5899457913fca11fae3beb8bebc260ac447f0a336b1c14f3f13726114567
+DIST lzlib-1.12.tar.gz 128996 BLAKE2B 3a86005eaf660a45888ec5af97bc6100368da2a3003c119c2379e881cd77ef318707342b7c930efa9473b671b8c2aff5c5e00dd5b312f647b7cafc39f29a2eea SHA512 b5379422eed4016b0ee124e39902dd22c314ca5cc5f72c1af5ec2ef6a68e1e85c523ab18e30048d453689f73f780d0144dcabaf881337e1c8101e2fe17ee21f8
diff --git a/app-arch/lzlib/lzlib-1.12.ebuild b/app-arch/lzlib/lzlib-1.12.ebuild
new file mode 100644
index 000000000000..c99b421c1c7b
--- /dev/null
+++ b/app-arch/lzlib/lzlib-1.12.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="Library for lzip compression"
+HOMEPAGE="https://www.nongnu.org/lzip/lzlib.html"
+SRC_URI="https://download.savannah.gnu.org/releases/lzip/${PN}/${P}.tar.gz"
+
+LICENSE="libstdc++" # fancy form of GPL-2+ with library exception
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+IUSE=""
+
+src_configure() {
+ local myconf=(
+ --enable-shared
+ --disable-static
+ --disable-ldconfig
+ --prefix="${EPREFIX}"/usr
+ --libdir='$(prefix)'/$(get_libdir)
+ CC="$(tc-getCC)"
+ CFLAGS="${CFLAGS}"
+ CPPFLAGS="${CPPFLAGS}"
+ LDFLAGS="${LDFLAGS}"
+ )
+
+ # not autotools-based
+ ./configure "${myconf[@]}" || die
+}