summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2020-08-30 13:02:28 +0200
committerJeroen Roovers <jer@gentoo.org>2020-08-30 13:02:45 +0200
commit03071b67da7e0ac88179ec82f9c6fd28e2634ce3 (patch)
tree34af5094d4ceb673cd739efe384e449cf58e0a3e /app-arch/mt-st
parentsci-electronics/voacapl: Version bump (diff)
downloadgentoo-03071b67da7e0ac88179ec82f9c6fd28e2634ce3.tar.gz
gentoo-03071b67da7e0ac88179ec82f9c6fd28e2634ce3.tar.bz2
gentoo-03071b67da7e0ac88179ec82f9c6fd28e2634ce3.zip
app-arch/mt-st: Version 1.4
Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'app-arch/mt-st')
-rw-r--r--app-arch/mt-st/Manifest1
-rw-r--r--app-arch/mt-st/mt-st-1.4.ebuild23
2 files changed, 24 insertions, 0 deletions
diff --git a/app-arch/mt-st/Manifest b/app-arch/mt-st/Manifest
index 2a76fd467c1e..4e723aba2a50 100644
--- a/app-arch/mt-st/Manifest
+++ b/app-arch/mt-st/Manifest
@@ -1 +1,2 @@
DIST mt-st-1.3.tar.gz 35341 BLAKE2B c58eee9bd58a3fa5105fe3f8dfb56f1af1c5ed73f99e5179ea14bc11d66151d1e6b6c99f61194c700ed79ce10a7e7f75f78ffe9b7d2c45c85e620d4da1aaeb5c SHA512 1d026ae85e1ca367e72f1810042314070f592306d9ddec331b95ea4e1153dc3edee68d8798bdf7e055a4cf9c67ec8c539e5d188e87f0546f48b5f4ee4bc6a820
+DIST mt-st-1.4.tar.gz 37864 BLAKE2B 25ae656b6442e53570366405ba76da9150cf1d4fe33c612bf922d8be967ce6b60be191948507a62bb1881d4be63ed192f7d03f1d63c38f5772aec2f3d2fe455b SHA512 e6655a5957d3ac470c0cb0a1955a12397aa22f3ea1a427cf776f6bf2d6fd665439b2bfa54c3870b7974da537f0fe71d3be43126be1a7db903e6bc7be4cfb10ec
diff --git a/app-arch/mt-st/mt-st-1.4.ebuild b/app-arch/mt-st/mt-st-1.4.ebuild
new file mode 100644
index 000000000000..8677862cdc02
--- /dev/null
+++ b/app-arch/mt-st/mt-st-1.4.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit toolchain-funcs
+
+DESCRIPTION="control magnetic tape drive operation"
+HOMEPAGE="https://github.com/iustin/mt-st"
+SRC_URI="https://github.com/iustin/mt-st/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+
+src_configure() {
+ tc-export CC
+}
+
+src_install() {
+ dosbin mt stinit
+ doman mt.1 stinit.8
+ dodoc README* stinit.def.examples
+}