summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2019-05-06 15:38:38 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2019-05-06 15:38:56 -0500
commit1de027a4a4a91be59bf59c46b84570cebbf5d50d (patch)
treeb000da559264277cc8c4b078bd94cde9ecb3bbc9 /app-arch/p7zip/p7zip-16.02-r4.ebuild
parentapp-crypt/acme: undep on tox (diff)
downloadgentoo-1de027a4a4a91be59bf59c46b84570cebbf5d50d.tar.gz
gentoo-1de027a4a4a91be59bf59c46b84570cebbf5d50d.tar.bz2
gentoo-1de027a4a4a91be59bf59c46b84570cebbf5d50d.zip
app-arch/p7zip: fix broken sed to use pipes
Fixes: https://bugs.gentoo.org/685166 Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'app-arch/p7zip/p7zip-16.02-r4.ebuild')
-rw-r--r--app-arch/p7zip/p7zip-16.02-r4.ebuild12
1 files changed, 6 insertions, 6 deletions
diff --git a/app-arch/p7zip/p7zip-16.02-r4.ebuild b/app-arch/p7zip/p7zip-16.02-r4.ebuild
index dc858bf58b87..e71c79f0fb00 100644
--- a/app-arch/p7zip/p7zip-16.02-r4.ebuild
+++ b/app-arch/p7zip/p7zip-16.02-r4.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -44,11 +44,11 @@ src_prepare() {
fi
sed \
- -e 's:-m32 ::g' \
- -e 's:-m64 ::g' \
- -e 's:-pipe::g' \
- -e '/ALLFLAGS/s:-s ::' \
- -e "/OPTFLAGS=/s:=.*:=${CXXFLAGS}:" \
+ -e 's|-m32 ||g' \
+ -e 's|-m64 ||g' \
+ -e 's|-pipe||g' \
+ -e '/ALLFLAGS/s|-s ||' \
+ -e "/OPTFLAGS=/s|=.*|=${CXXFLAGS}|" \
-i makefile* || die
# remove non-free RAR codec