summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2016-08-08 11:21:52 -0400
committerTim Harder <radhermit@gentoo.org>2016-08-08 11:25:28 -0400
commited97e43db5d1b0a118b5ef9352f68d83bae8dd01 (patch)
tree316162dfe8aa9c164c7ac7dc6b17ef50234e175a /app-arch/pixz/pixz-1.0.6.ebuild
parentnet-misc/owncloud-client: version bump to 2.2.3 (diff)
downloadgentoo-ed97e43db5d1b0a118b5ef9352f68d83bae8dd01.tar.gz
gentoo-ed97e43db5d1b0a118b5ef9352f68d83bae8dd01.tar.bz2
gentoo-ed97e43db5d1b0a118b5ef9352f68d83bae8dd01.zip
app-arch/pixz: version bump to 1.0.6 (bug #572728)
Diffstat (limited to 'app-arch/pixz/pixz-1.0.6.ebuild')
-rw-r--r--app-arch/pixz/pixz-1.0.6.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/app-arch/pixz/pixz-1.0.6.ebuild b/app-arch/pixz/pixz-1.0.6.ebuild
new file mode 100644
index 000000000000..63553def5565
--- /dev/null
+++ b/app-arch/pixz/pixz-1.0.6.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit toolchain-funcs flag-o-matic autotools
+
+DESCRIPTION="Parallel Indexed XZ compressor"
+HOMEPAGE="https://github.com/vasi/pixz"
+LICENSE="BSD-2"
+SLOT="0"
+IUSE="static"
+
+LIB_DEPEND=">=app-arch/libarchive-2.8:=[static-libs(+)]
+ >=app-arch/xz-utils-5[static-libs(+)]"
+RDEPEND="!static? ( ${LIB_DEPEND//\[static-libs(+)]} )"
+DEPEND="${RDEPEND}
+ static? ( ${LIB_DEPEND} )
+ app-text/asciidoc"
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/vasi/${PN}.git"
+ inherit git-r3
+ KEYWORDS=""
+else
+ SRC_URI="https://github.com/vasi/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~x86"
+fi
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ use static && append-ldflags -static
+ append-flags -std=gnu99
+ econf
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" OPT=""
+}
+
+src_install() {
+ dobin src/pixz
+ doman src/pixz.1
+ dodoc NEWS README.md TODO
+}