summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-01-07 22:01:07 +0100
committerMichał Górny <mgorny@gentoo.org>2021-01-07 22:01:07 +0100
commit6f1e469d60041f416c19a17a8990220daccf4c95 (patch)
treeb6988ccfaf2127becf04c9e2a24167322755c3a0 /app-arch/plzip
parentdev-libs/libxml2: drop x86-winnt bits (diff)
downloadgentoo-6f1e469d60041f416c19a17a8990220daccf4c95.tar.gz
gentoo-6f1e469d60041f416c19a17a8990220daccf4c95.tar.bz2
gentoo-6f1e469d60041f416c19a17a8990220daccf4c95.zip
app-arch/plzip: Bump to 1.9
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-arch/plzip')
-rw-r--r--app-arch/plzip/Manifest1
-rw-r--r--app-arch/plzip/plzip-1.9.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/app-arch/plzip/Manifest b/app-arch/plzip/Manifest
index ac879667e47d..17b0e2c6c697 100644
--- a/app-arch/plzip/Manifest
+++ b/app-arch/plzip/Manifest
@@ -1 +1,2 @@
DIST plzip-1.8.tar.gz 72365 BLAKE2B 66b8881b6c70932c66e40edab22235103d671a870c980c0b0b08754e94fbc1b2d0f2eeb26deac4f27fbc89d69c3b588bd51cb973b7b59cbb2d0f6ab4cc9a115d SHA512 e8e822f8ae77e06178538b62075fa1c5d9cbc76c78bee7ad595a4637cd4077f53fd9e3fe61ca3fbddaa8b950e739d97527dc8fbecae04de1ac3ef83d0d5f13b4
+DIST plzip-1.9.tar.gz 93312 BLAKE2B a5b9a81cfffa17eca9a4cf4d6b037ad943235022142bd053ec8bcfc4dd99b2b730d69332fa54187ba7704266666efde52d23e13f91c290b9cddb96a87023173e SHA512 3bca603ba6337462bde3967e7c7a7e66287f3a71adf8db987429fcdcb06ebbb90b52e666a7f98ac699bc158cbda21a9cce02490131d33fc44171b84ebb3a4a19
diff --git a/app-arch/plzip/plzip-1.9.ebuild b/app-arch/plzip/plzip-1.9.ebuild
new file mode 100644
index 000000000000..07980c802cd0
--- /dev/null
+++ b/app-arch/plzip/plzip-1.9.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="Parallel lzip compressor"
+HOMEPAGE="https://www.nongnu.org/lzip/plzip.html"
+SRC_URI="https://download.savannah.gnu.org/releases/lzip/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+IUSE=""
+
+RDEPEND="app-arch/lzlib:0="
+DEPEND=${RDEPEND}
+
+src_configure() {
+ local myconf=(
+ --prefix="${EPREFIX}"/usr
+ CXX="$(tc-getCXX)"
+ CPPFLAGS="${CPPFLAGS}"
+ CXXFLAGS="${CXXFLAGS}"
+ LDFLAGS="${LDFLAGS}"
+ )
+
+ # not autotools-based
+ ./configure "${myconf[@]}" || die
+}