summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2019-03-13 13:02:46 +0100
committerAndreas K. Hüttel <dilfridge@gentoo.org>2019-03-13 13:02:46 +0100
commit648bdf9134d87d5d6ca086b742964b77c3da87d8 (patch)
tree60d739deb8b3a39b33c8dec52d37f6e8e2b67f33 /app-arch/sharutils/sharutils-4.15.2-r1.ebuild
parentapp-arch/sharutils: Add glibc-2.28 build fix (diff)
downloadgentoo-648bdf9134d87d5d6ca086b742964b77c3da87d8.tar.gz
gentoo-648bdf9134d87d5d6ca086b742964b77c3da87d8.tar.bz2
gentoo-648bdf9134d87d5d6ca086b742964b77c3da87d8.zip
app-arch/sharutils: Add patch for CVE-2018-1000097
Bug: https://bugs.gentoo.org/652686 Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
Diffstat (limited to 'app-arch/sharutils/sharutils-4.15.2-r1.ebuild')
-rw-r--r--app-arch/sharutils/sharutils-4.15.2-r1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/app-arch/sharutils/sharutils-4.15.2-r1.ebuild b/app-arch/sharutils/sharutils-4.15.2-r1.ebuild
new file mode 100644
index 000000000000..2a7873196c5b
--- /dev/null
+++ b/app-arch/sharutils/sharutils-4.15.2-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+inherit eutils flag-o-matic
+
+MY_P="${P/_/-}"
+DESCRIPTION="Tools to deal with shar archives"
+HOMEPAGE="https://www.gnu.org/software/sharutils/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="nls"
+
+DEPEND="app-arch/xz-utils
+ sys-apps/texinfo
+ nls? ( >=sys-devel/gettext-0.10.35 )"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ default
+
+ epatch "${FILESDIR}/sharutils-4.15.2-glibc228.patch"
+ epatch "${FILESDIR}/sharutils-4.15.2-CVE-2018-1000097.patch"
+
+ # Upstream is aware but thinks this isn't a bug/problem in sharutils itself
+ # See http://lists.gnu.org/archive/html/bug-gnu-utils/2013-10/msg00011.html
+ append-cflags $(test-flags-CC -Wno-error=format-security)
+}
+
+src_configure() {
+ strip-linguas -u po
+ econf $(use_enable nls)
+}