summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2017-09-17 04:13:19 +0200
committerThomas Deutschmann <whissi@gentoo.org>2017-09-17 04:13:19 +0200
commitc2d0dfdf2be7840ead3a1d731cf9cf90253af0fd (patch)
treedb7660c24391412596d3c116370a2e476e463af9 /app-arch/sharutils
parentapp-shells/bashdb: Bump to v4.4.0.94 (diff)
downloadgentoo-c2d0dfdf2be7840ead3a1d731cf9cf90253af0fd.tar.gz
gentoo-c2d0dfdf2be7840ead3a1d731cf9cf90253af0fd.tar.bz2
gentoo-c2d0dfdf2be7840ead3a1d731cf9cf90253af0fd.zip
app-arch/sharutils: Enforce -Wno-error=format-security
See http://lists.gnu.org/archive/html/bug-gnu-utils/2013-10/msg00011.html Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'app-arch/sharutils')
-rw-r--r--app-arch/sharutils/sharutils-4.15.2.ebuild10
1 files changed, 9 insertions, 1 deletions
diff --git a/app-arch/sharutils/sharutils-4.15.2.ebuild b/app-arch/sharutils/sharutils-4.15.2.ebuild
index 75da8ed243a1..1edfe87ae807 100644
--- a/app-arch/sharutils/sharutils-4.15.2.ebuild
+++ b/app-arch/sharutils/sharutils-4.15.2.ebuild
@@ -3,7 +3,7 @@
EAPI="5"
-inherit eutils
+inherit eutils flag-o-matic
MY_P="${P/_/-}"
DESCRIPTION="Tools to deal with shar archives"
@@ -21,6 +21,14 @@ DEPEND="app-arch/xz-utils
S=${WORKDIR}/${MY_P}
+src_prepare() {
+ default
+
+ # Upstream is aware but thinks this isn't a bug/problem in sharutils itself
+ # See http://lists.gnu.org/archive/html/bug-gnu-utils/2013-10/msg00011.html
+ append-cflags $(test-flags-CC -Wno-error=format-security)
+}
+
src_configure() {
strip-linguas -u po
econf $(use_enable nls)