summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-06-08 10:27:05 +0200
committerMichał Górny <mgorny@gentoo.org>2020-06-08 10:56:02 +0200
commit11ae42c7bf610c44e7d7135aa5c0782acab32abb (patch)
tree23201ddcfcc5b17a32fbd7ccab744eb6f856a98f /app-arch/snappy/snappy-1.1.8.ebuild
parentapp-arch/lz4: Port to cmake.eclass (diff)
downloadgentoo-11ae42c7bf610c44e7d7135aa5c0782acab32abb.tar.gz
gentoo-11ae42c7bf610c44e7d7135aa5c0782acab32abb.tar.bz2
gentoo-11ae42c7bf610c44e7d7135aa5c0782acab32abb.zip
app-arch/snappy: Port to cmake.eclass
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-arch/snappy/snappy-1.1.8.ebuild')
-rw-r--r--app-arch/snappy/snappy-1.1.8.ebuild6
1 files changed, 4 insertions, 2 deletions
diff --git a/app-arch/snappy/snappy-1.1.8.ebuild b/app-arch/snappy/snappy-1.1.8.ebuild
index 73dbbab511f0..9f4dd1f9c58e 100644
--- a/app-arch/snappy/snappy-1.1.8.ebuild
+++ b/app-arch/snappy/snappy-1.1.8.ebuild
@@ -2,6 +2,8 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+
+CMAKE_ECLASS=cmake
inherit cmake-multilib
DESCRIPTION="A high-speed compression/decompression library by Google"
@@ -33,7 +35,7 @@ src_prepare() {
# it off
sed -i -e '/run_microbenchmarks/s:true:false:' snappy-test.cc || die
- cmake-utils_src_prepare
+ cmake_src_prepare
}
multilib_src_configure() {
@@ -52,7 +54,7 @@ multilib_src_configure() {
-DHAVE_LIBZ=NO
-DHAVE_LIBLZO2=NO
)
- cmake-utils_src_configure
+ cmake_src_configure
}
multilib_src_test() {