summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Levine <plevine457@gmail.com>2023-02-18 17:36:21 -0500
committerSam James <sam@gentoo.org>2023-02-22 16:13:43 +0000
commit52349d44ce357a6f0417a914425ef7973840baa1 (patch)
tree8f622501b0455f0a93ecf3292364a91cad6665cc /app-arch/snappy/snappy-1.1.9-r1.ebuild
parentdev-libs/hyperscan: add 5.4.1 (diff)
downloadgentoo-52349d44ce357a6f0417a914425ef7973840baa1.tar.gz
gentoo-52349d44ce357a6f0417a914425ef7973840baa1.tar.bz2
gentoo-52349d44ce357a6f0417a914425ef7973840baa1.zip
app-arch/snappy: build using C++14 dialect
The latest gtest requires C++14 or later. Pass -DCMAKE_CXX_STANDARD=14 explicitly to avoid having -std=c++11 added to CXXFLAGS. Closes: https://bugs.gentoo.org/895190 Closes: https://github.com/gentoo/gentoo/pull/29653 Signed-off-by: Peter Levine <plevine457@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-arch/snappy/snappy-1.1.9-r1.ebuild')
-rw-r--r--app-arch/snappy/snappy-1.1.9-r1.ebuild3
1 files changed, 2 insertions, 1 deletions
diff --git a/app-arch/snappy/snappy-1.1.9-r1.ebuild b/app-arch/snappy/snappy-1.1.9-r1.ebuild
index 6f03591f6f44..b6cbd7792108 100644
--- a/app-arch/snappy/snappy-1.1.9-r1.ebuild
+++ b/app-arch/snappy/snappy-1.1.9-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -28,6 +28,7 @@ PATCHES=(
multilib_src_configure() {
local mycmakeargs=(
+ -DCMAKE_CXX_STANDARD=14 # Latest gtest needs -std=c++14 or newer
-DSNAPPY_BUILD_TESTS=$(usex test)
-DSNAPPY_BUILD_BENCHMARKS=OFF
# Options below are related to benchmarking, that we disable.