summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-01-18 02:46:43 +0000
committerSam James <sam@gentoo.org>2024-01-18 03:19:19 +0000
commit949746114bb01aaf1b7d00e76732712383a338eb (patch)
tree088626ed30beca9b8ab5f4297ea97d04b8df8ea7 /app-arch/tar
parentnet-wireless/gnuradio: update comments (diff)
downloadgentoo-949746114bb01aaf1b7d00e76732712383a338eb.tar.gz
gentoo-949746114bb01aaf1b7d00e76732712383a338eb.tar.bz2
gentoo-949746114bb01aaf1b7d00e76732712383a338eb.zip
app-arch/tar: run tests in parallel
Inspired by vapier's cd7f047fe43fb631c4ca6979c6efb5038c616f41. `RUNTESTFLAGS` has been in the back of my head for a while now as I've been meaning to figure out the interaction between it and parallel make and which packages actually need it, so figured I'd start with something I was pretty sure used autotest... Before: ``` real 4m53.950s user 0m0.743s sys 0m0.263s ``` After: ``` real 2m3.075s user 0m0.750s sys 0m0.265s ``` Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-arch/tar')
-rw-r--r--app-arch/tar/tar-1.35.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/app-arch/tar/tar-1.35.ebuild b/app-arch/tar/tar-1.35.ebuild
index 8b1f21fcec5d..46d2ebf890bb 100644
--- a/app-arch/tar/tar-1.35.ebuild
+++ b/app-arch/tar/tar-1.35.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
VERIFY_SIG_OPENPGP_KEY_PATH=/usr/share/openpgp-keys/tar.asc
-inherit verify-sig
+inherit multiprocessing verify-sig
DESCRIPTION="Use this to make tarballs :)"
HOMEPAGE="https://www.gnu.org/software/tar/"
@@ -70,7 +70,7 @@ src_test() {
# Drop after 1.35: https://git.savannah.gnu.org/cgit/tar.git/commit/?id=18f90676e4695ffcf13413e9fbb24cc0ae2ae9d5
local -x XZ_OPT= XZ_DEFAULTS=
- default
+ emake check TESTSUITEFLAGS="--jobs=$(get_makeopts_jobs)"
}
src_install() {