summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2016-03-07 13:39:10 +0000
committerPatrice Clement <monsieurp@gentoo.org>2016-03-07 13:40:23 +0000
commit56986c80f4626161909d8ae3bd03ac47e9f00e7c (patch)
tree7fd757c6c7d0daa02b1ee9cf9ff6fdf2b70c05d3 /app-arch/torrentzip
parentdev-lang/elixir: Bump (diff)
downloadgentoo-56986c80f4626161909d8ae3bd03ac47e9f00e7c.tar.gz
gentoo-56986c80f4626161909d8ae3bd03ac47e9f00e7c.tar.bz2
gentoo-56986c80f4626161909d8ae3bd03ac47e9f00e7c.zip
app-arch/torrentzip: Fix invalid SRC_URI.
Gentoo-Bug: https://bugs.gentoo.org/575338 Reporter: Alexander Miller <alex.miller@gmx.de> Acked-by: Patrice Clement <monsieurp@gentoo.org> Signed-off-by: Patrice Clement <monsieurp@gentoo.org> Package-Manager: portage-2.2.26
Diffstat (limited to 'app-arch/torrentzip')
-rw-r--r--app-arch/torrentzip/Manifest1
-rw-r--r--app-arch/torrentzip/torrentzip-0.2-r3.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/app-arch/torrentzip/Manifest b/app-arch/torrentzip/Manifest
index 09183004e480..e167253fdcd1 100644
--- a/app-arch/torrentzip/Manifest
+++ b/app-arch/torrentzip/Manifest
@@ -1 +1,2 @@
+DIST torrentzip-0.2.tar.gz 46971 SHA256 9e55f378ef5c75c452b3f52728a7503ca76e147e0ab2395b8c41de8c20995efd SHA512 802dd1bf55e0a31df75d8195c9d2d5610be8cb7f14d14278eba72b580aff3ad415711999db05a5425303380ebfc82a68896e276319e0ead5635d0a07615ba700 WHIRLPOOL 79c96f51a0b547b2651625a3b3aee6b7a769955e10b092654086a1d91a494d08f8dd732eee45b432ca97f4f6314af0f76907fa81b422ef94676e6d729994a61d
DIST torrentzip-0.2.zip 69200 SHA256 3aa58e839743eebd97071e36585bb14cab0bddd22db646eb0765e1ae3ef2c749 SHA512 a6d6452940ab9070b96d598c7db306657afa34c3630160943260e6687e65985aa5aa8ad0b1319ee6470912207d6ef369fdb1168d5d528e8efd7405dc7722b1b8 WHIRLPOOL 0cad9f83e2d27795014be51b912d34350a59ad9c824f66237e1f15641daad812c92a7d5c6357e8d6a2517f08a381705f4eb057dc855700b007b99f3210046a1c
diff --git a/app-arch/torrentzip/torrentzip-0.2-r3.ebuild b/app-arch/torrentzip/torrentzip-0.2-r3.ebuild
new file mode 100644
index 000000000000..a921e9194e79
--- /dev/null
+++ b/app-arch/torrentzip/torrentzip-0.2-r3.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit eutils autotools
+
+DESCRIPTION="Create identical zip archives over multiple systems"
+HOMEPAGE="https://sourceforge.net/projects/trrntzip"
+
+MY_PN="trrntzip"
+MY_P="${MY_PN}_v${PV/.}"
+
+SRC_URI="mirror://sourceforge/trrntzip/${MY_P}_src.tar.gz -> ${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+DEPEND="sys-libs/zlib"
+RDEPEND="$DEPEND"
+
+S="${WORKDIR}/${MY_PN}"
+DOCS=(README AUTHORS)
+
+src_prepare() {
+ export CPPFLAGS+=" -DOF\\(args\\)=args"
+
+ epatch_user
+
+ eautoreconf
+}