summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-arch/torrentzip
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-arch/torrentzip')
-rw-r--r--app-arch/torrentzip/Manifest1
-rw-r--r--app-arch/torrentzip/files/fix-perms.patch11
-rw-r--r--app-arch/torrentzip/metadata.xml14
-rw-r--r--app-arch/torrentzip/torrentzip-0.2-r1.ebuild37
4 files changed, 63 insertions, 0 deletions
diff --git a/app-arch/torrentzip/Manifest b/app-arch/torrentzip/Manifest
new file mode 100644
index 000000000000..36f46d915661
--- /dev/null
+++ b/app-arch/torrentzip/Manifest
@@ -0,0 +1 @@
+DIST trrntzip_v02_src.tar.gz 46971 SHA256 9e55f378ef5c75c452b3f52728a7503ca76e147e0ab2395b8c41de8c20995efd SHA512 802dd1bf55e0a31df75d8195c9d2d5610be8cb7f14d14278eba72b580aff3ad415711999db05a5425303380ebfc82a68896e276319e0ead5635d0a07615ba700 WHIRLPOOL 79c96f51a0b547b2651625a3b3aee6b7a769955e10b092654086a1d91a494d08f8dd732eee45b432ca97f4f6314af0f76907fa81b422ef94676e6d729994a61d
diff --git a/app-arch/torrentzip/files/fix-perms.patch b/app-arch/torrentzip/files/fix-perms.patch
new file mode 100644
index 000000000000..ea013663443f
--- /dev/null
+++ b/app-arch/torrentzip/files/fix-perms.patch
@@ -0,0 +1,11 @@
+--- src/trrntzip.c
++++ src/trrntzip.c
+@@ -782,7 +782,7 @@
+
+ if (strstr (szTmpBuf, ".zip\0") && !(istat.st_mode & S_IWUSR))
+ {
+- chmod (direntp->d_name, S_IWUSR);
++ chmod (direntp->d_name, S_IWUSR | S_IRUSR);
+ mig.cEncounteredZips++;
+
+ if (!mig.fProcessLog)
diff --git a/app-arch/torrentzip/metadata.xml b/app-arch/torrentzip/metadata.xml
new file mode 100644
index 000000000000..207b29f7ce14
--- /dev/null
+++ b/app-arch/torrentzip/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>net-p2p</herd>
+ <longdescription>
+ TorrentZip is a replacement for MameZip. The goal of the program is to
+ use standard values when creating zips to create identical files over
+ multiple systems. It has the ability to create a torrentzip format
+ from a zip file.
+ </longdescription>
+ <upstream>
+ <remote-id type="sourceforge">trrntzip</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-arch/torrentzip/torrentzip-0.2-r1.ebuild b/app-arch/torrentzip/torrentzip-0.2-r1.ebuild
new file mode 100644
index 000000000000..41d5f4b21d3d
--- /dev/null
+++ b/app-arch/torrentzip/torrentzip-0.2-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit versionator eutils autotools
+
+DESCRIPTION="Archiver that creates standard zips to create identical files over multiple systems"
+HOMEPAGE="https://sourceforge.net/projects/trrntzip"
+
+MY_PN=trrntzip
+MY_PV="$(replace_version_separator 1 '')"
+MY_P=${MY_PN}_v${MY_PV}
+S="${WORKDIR}"/${MY_PN}
+
+SRC_URI="mirror://sourceforge/trrntzip/${MY_P}_src.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+DEPEND="sys-libs/zlib"
+RDEPEND=""
+
+S=${WORKDIR}/trrntzip
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/fix-perms.patch
+
+ eautoreconf
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "install failed"
+ dodoc README AUTHORS
+}