summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2017-12-29 12:26:05 +0100
committerDavid Seifert <soap@gentoo.org>2017-12-29 14:15:58 +0100
commitfe84e9cbdff075dcd146ddb4fef0cf37e7777765 (patch)
tree6561a2e546320a94dc2ed52b1cf017ee3c02ebdb /app-arch/unarj
parentapp-arch/funzix: Port to EAPI 6 (diff)
downloadgentoo-fe84e9cbdff075dcd146ddb4fef0cf37e7777765.tar.gz
gentoo-fe84e9cbdff075dcd146ddb4fef0cf37e7777765.tar.bz2
gentoo-fe84e9cbdff075dcd146ddb4fef0cf37e7777765.zip
app-arch/unarj: Port to EAPI 6
Closes: https://bugs.gentoo.org/520478 Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'app-arch/unarj')
-rw-r--r--app-arch/unarj/files/unarj-2.65-Wformat-security.patch66
-rw-r--r--app-arch/unarj/files/unarj-2.65-gentoo-fbsd.patch4
-rw-r--r--app-arch/unarj/unarj-2.65.ebuild25
3 files changed, 80 insertions, 15 deletions
diff --git a/app-arch/unarj/files/unarj-2.65-Wformat-security.patch b/app-arch/unarj/files/unarj-2.65-Wformat-security.patch
new file mode 100644
index 000000000000..a076dd91f13d
--- /dev/null
+++ b/app-arch/unarj/files/unarj-2.65-Wformat-security.patch
@@ -0,0 +1,66 @@
+Bug: https://bugs.gentoo.org/520478
+
+--- a/unarj.c
++++ b/unarj.c
+@@ -699,7 +699,7 @@
+ }
+ if ((arj_flags & GARBLE_FLAG) != 0)
+ {
+- printf(M_ENCRYPT);
++ puts(M_ENCRYPT);
+ printf(M_SKIPPED, filename);
+ skip();
+ return -1;
+@@ -763,7 +763,7 @@
+ }
+ printf(M_EXTRACT, name);
+ if (host_os != OS && file_type == BINARY_TYPE)
+- printf(M_DIFFHOST);
++ puts(M_DIFFHOST);
+ printf(" ");
+
+ crc = CRC_MASK;
+@@ -779,10 +779,10 @@
+ set_ftime_mode(name, time_stamp, file_mode, (uint) host_os);
+
+ if ((crc ^ CRC_MASK) == file_crc)
+- printf(M_CRCOK);
++ puts(M_CRCOK);
+ else
+ {
+- printf(M_CRCERROR);
++ puts(M_CRCERROR);
+ error_count++;
+ }
+ return 1;
+@@ -808,10 +808,10 @@
+ decode_f();
+
+ if ((crc ^ CRC_MASK) == file_crc)
+- printf(M_CRCOK);
++ puts(M_CRCOK);
+ else
+ {
+- printf(M_CRCERROR);
++ puts(M_CRCERROR);
+ error_count++;
+ }
+ return 1;
+@@ -958,7 +958,7 @@
+ int i;
+
+ for (i = 0; M_USAGE[i] != NULL; i++)
+- printf(M_USAGE[i]);
++ puts(M_USAGE[i]);
+ }
+
+ int
+@@ -973,7 +973,7 @@
+ argc = ccommand(&argv);
+ #endif
+
+- printf(M_VERSION);
++ puts(M_VERSION);
+
+ if (argc == 1)
+ {
diff --git a/app-arch/unarj/files/unarj-2.65-gentoo-fbsd.patch b/app-arch/unarj/files/unarj-2.65-gentoo-fbsd.patch
index 755b9b696cc9..2091f091e2d2 100644
--- a/app-arch/unarj/files/unarj-2.65-gentoo-fbsd.patch
+++ b/app-arch/unarj/files/unarj-2.65-gentoo-fbsd.patch
@@ -1,5 +1,5 @@
---- environ.c 2007-06-19 12:44:09 +0200
-+++ environ.c.new 2007-06-19 12:44:37 +0200
+--- a/environ.c
++++ b/environ.c
@@ -437,7 +437,6 @@
#endif
diff --git a/app-arch/unarj/unarj-2.65.ebuild b/app-arch/unarj/unarj-2.65.ebuild
index d579027e1d33..ec1cba73be8e 100644
--- a/app-arch/unarj/unarj-2.65.ebuild
+++ b/app-arch/unarj/unarj-2.65.ebuild
@@ -1,7 +1,9 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-inherit eutils toolchain-funcs
+EAPI=6
+
+inherit toolchain-funcs
DESCRIPTION="Utility for opening arj archives"
HOMEPAGE="http://www.arjsoftware.com/"
@@ -12,21 +14,18 @@ SLOT="0"
KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris ~x86-solaris"
IUSE=""
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- epatch "${FILESDIR}"/${P}-CAN-2004-0947.patch
- epatch "${FILESDIR}"/${P}-sanitation.patch
- epatch "${FILESDIR}"/${P}-gentoo-fbsd.patch
-}
+PATCHES=(
+ "${FILESDIR}"/${P}-CAN-2004-0947.patch
+ "${FILESDIR}"/${P}-sanitation.patch
+ "${FILESDIR}"/${P}-gentoo-fbsd.patch
+ "${FILESDIR}"/${PN}-2.65-Wformat-security.patch
+)
-src_compile() {
+src_configure() {
tc-export CC
- emake || die
}
src_install() {
- dobin unarj || die 'dobin failed'
- dodoc unarj.txt technote.txt || die 'dodoc failed'
+ dobin unarj
+ dodoc unarj.txt technote.txt
}