summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Savchenko <bircoph@gentoo.org>2017-07-16 21:35:26 +0300
committerAndrew Savchenko <bircoph@gentoo.org>2017-07-16 21:35:26 +0300
commit052a1affedacd447bdee25de14448dbb49757915 (patch)
treee54d67cba7b5101e6bc45f4b7b984971ccf8dc87 /app-arch/unrpa/unrpa-1.4.2.ebuild
parentapp-eselect/eselect-renpy: remove old (diff)
downloadgentoo-052a1affedacd447bdee25de14448dbb49757915.tar.gz
gentoo-052a1affedacd447bdee25de14448dbb49757915.tar.bz2
gentoo-052a1affedacd447bdee25de14448dbb49757915.zip
app-arch/unrpa: version bump
Package-Manager: Portage-2.3.6, Repoman-2.3.2 Signed-off-by: Andrew Savchenko <bircoph@gentoo.org>
Diffstat (limited to 'app-arch/unrpa/unrpa-1.4.2.ebuild')
-rw-r--r--app-arch/unrpa/unrpa-1.4.2.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/app-arch/unrpa/unrpa-1.4.2.ebuild b/app-arch/unrpa/unrpa-1.4.2.ebuild
new file mode 100644
index 000000000000..116e57d6b1bb
--- /dev/null
+++ b/app-arch/unrpa/unrpa-1.4.2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+inherit python-single-r1
+
+if [[ ${PV} == "9999" ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/Lattyware/unrpa.git"
+else
+ SRC_URI="https://github.com/Lattyware/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="Ren'Py's RPA data file extractor"
+HOMEPAGE="https://github.com/Lattyware/unrpa"
+
+LICENSE="GPL-3"
+SLOT="0"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ python_doscript "${PN}"
+ dodoc README
+}