summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2018-03-11 21:07:05 +0100
committerFabian Groffen <grobian@gentoo.org>2018-03-11 21:07:17 +0100
commita7702363a854ef306b3ad6e0566697a6c7e7c741 (patch)
treea276929e0e2a93f54146a6bab2f678ebf17f25dc /app-arch/xar/xar-1.8-r1.ebuild
parentapp-portage/gemato: Clean old up (diff)
downloadgentoo-a7702363a854ef306b3ad6e0566697a6c7e7c741.tar.gz
gentoo-a7702363a854ef306b3ad6e0566697a6c7e7c741.tar.bz2
gentoo-a7702363a854ef306b3ad6e0566697a6c7e7c741.zip
app-arch/xar: fix arm and ppc64, bug #650024
Due to a different signedness of char type on arm and ppc, xar wouldn't start at all on these platforms. A weird (compiler?) bug caused a completely random offset to be taken obviously failing any checksums. Fixes: https://bugs.gentoo.org/650024 Closes: https://bugs.gentoo.org/650024 Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'app-arch/xar/xar-1.8-r1.ebuild')
-rw-r--r--app-arch/xar/xar-1.8-r1.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/app-arch/xar/xar-1.8-r1.ebuild b/app-arch/xar/xar-1.8-r1.ebuild
new file mode 100644
index 000000000000..c1c4883df5ee
--- /dev/null
+++ b/app-arch/xar/xar-1.8-r1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit flag-o-matic multilib-minimal ltprune
+
+APPLE_PV=400
+DESCRIPTION="An easily extensible archive format"
+HOMEPAGE="https://opensource.apple.com/source/xar/"
+SRC_URI="https://opensource.apple.com/tarballs/xar/xar-${APPLE_PV}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="libressl kernel_Darwin"
+
+DEPEND="
+ !kernel_Darwin? (
+ virtual/acl
+ !libressl? ( dev-libs/openssl:0=[${MULTILIB_USEDEP}] )
+ libressl? ( dev-libs/libressl:0=[${MULTILIB_USEDEP}] )
+ )
+ app-arch/bzip2[${MULTILIB_USEDEP}]
+ sys-libs/zlib[${MULTILIB_USEDEP}]
+ dev-libs/libxml2[${MULTILIB_USEDEP}]
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.6.1-ext2.patch
+ "${FILESDIR}"/${PN}-1.8-safe_dirname.patch
+ "${FILESDIR}"/${PN}-1.8-arm-ppc.patch
+)
+
+S=${WORKDIR}/${PN}-${APPLE_PV}/${PN}
+
+multilib_src_configure() {
+ use kernel_Darwin || append-libs $(pkg-config --libs openssl)
+ ECONF_SOURCE=${S} \
+ econf \
+ --disable-static
+}
+
+multilib_src_install() {
+ default
+ prune_libtool_files
+}