summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2015-12-15 15:38:34 -0500
committerAnthony G. Basile <blueness@gentoo.org>2015-12-15 15:38:51 -0500
commitcf02c188fb8df90f7d14bf1f2fe42adbe710ca95 (patch)
tree32bd9aaee16d00f5729673b66e3e53714e7f301a /app-arch/xar
parentapp-arch/dump: (sub)slot cleanups and add libressl support (diff)
downloadgentoo-cf02c188fb8df90f7d14bf1f2fe42adbe710ca95.tar.gz
gentoo-cf02c188fb8df90f7d14bf1f2fe42adbe710ca95.tar.bz2
gentoo-cf02c188fb8df90f7d14bf1f2fe42adbe710ca95.zip
app-arch/xar: base eclass cleanup and add libressl support
Package-Manager: portage-2.2.24
Diffstat (limited to 'app-arch/xar')
-rw-r--r--app-arch/xar/xar-1.5.2-r2.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/app-arch/xar/xar-1.5.2-r2.ebuild b/app-arch/xar/xar-1.5.2-r2.ebuild
new file mode 100644
index 000000000000..b753675c1782
--- /dev/null
+++ b/app-arch/xar/xar-1.5.2-r2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit autotools eutils
+
+DESCRIPTION="An easily extensible archive format"
+HOMEPAGE="https://code.google.com/p/xar"
+SRC_URI="https://xar.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="acl +bzip2 libressl"
+
+DEPEND="
+ !libressl? ( dev-libs/openssl:0 )
+ libressl? ( dev-libs/libressl )
+ dev-libs/libxml2
+ sys-libs/zlib
+ acl? ( sys-apps/acl )
+ bzip2? ( app-arch/bzip2 )"
+RDEPEND="${DEPEND}"
+
+DOCS=( TODO )
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-automagic_acl_and_bzip2.patch"
+ epatch "${FILESDIR}/${P}-respect_ldflags.patch"
+ epatch_user
+ eautoconf
+}
+
+src_configure() {
+ econf $(use_enable acl) $(use_enable bzip2)
+}