summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-arch/xdms
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-arch/xdms')
-rw-r--r--app-arch/xdms/Manifest1
-rw-r--r--app-arch/xdms/metadata.xml14
-rw-r--r--app-arch/xdms/xdms-1.3.2.ebuild30
3 files changed, 45 insertions, 0 deletions
diff --git a/app-arch/xdms/Manifest b/app-arch/xdms/Manifest
new file mode 100644
index 000000000000..cbc9f6ebfa9e
--- /dev/null
+++ b/app-arch/xdms/Manifest
@@ -0,0 +1 @@
+DIST xdms-1.3.2.tar.bz2 43010 SHA256 367ec4f02dd6a3a225b4338ea7b961b87fb144f7388b2ea1eb3a5593fc53f47e SHA512 e29dd1d2373c635ba953ef526849e0b8fa645a0da91fff3a3512ce26eee43fb2c1280f27fae0a42a4fd47106494d6e44c5684eff3581661e538780927b851cac WHIRLPOOL 1dd14c88b29f8f6dd7dc3e72321d654f47287b61b47509d4b5ce56d9ee98f5e55b8a0287ff5fcca51a6c4b74a48e749a6aa7eaefe7f9ef8ee8ce39de2029eda6
diff --git a/app-arch/xdms/metadata.xml b/app-arch/xdms/metadata.xml
new file mode 100644
index 000000000000..123069e44581
--- /dev/null
+++ b/app-arch/xdms/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+ <longdescription>
+ Supports decompression of files compressed using all known DMS compression modes, including old and obsolete ones, and also encrypted files, for 100% compatibility.
+ Can test DMS files integrity, view file informations and show attached Banners and FILEID.DIZ .
+ Can generate standard disk images and compressed disk images, using gzip, if you want to store your files in ADF or ADZ formats.
+ Can extract the files contained inside the DMS archives, if the compressed disk is an AmigaDOS disk, using readdisk made by Bernd Schmidt.
+ Can process multiple files in batch with a single command, and also use stdin and stdout for input and output of data.
+ </longdescription>
+</pkgmetadata>
diff --git a/app-arch/xdms/xdms-1.3.2.ebuild b/app-arch/xdms/xdms-1.3.2.ebuild
new file mode 100644
index 000000000000..14424a2e4edc
--- /dev/null
+++ b/app-arch/xdms/xdms-1.3.2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit toolchain-funcs
+
+DESCRIPTION="xDMS - Amiga DMS disk image decompressor"
+HOMEPAGE="http://zakalwe.fi/~shd/foss/xdms"
+SRC_URI="http://zakalwe.fi/~shd/foss/xdms/${P}.tar.bz2"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="amd64 ~hppa ppc x86"
+IUSE=""
+
+src_unpack() {
+ unpack ${A}
+ sed -i -e 's:COPYING::' "${S}"/Makefile.in
+}
+
+src_compile() {
+ ./configure --prefix=/usr --package-prefix="${D}" \
+ || die "configure failed."
+ emake CC="$(tc-getCC)" || die "emake failed."
+}
+
+src_install() {
+ emake install || die "emake install failed."
+ prepalldocs
+}